Opened 10 years ago

Closed 10 years ago

#10064 closed defect (fixed)

No Hebrew typing, in Jabber (Google Talk) after upgrading to 2.6.1

Reported by: Katom Owned by: darkrain42
Milestone: Component: Google Talk
Version: 2.6.2 Keywords: Hebrew
Cc: datallah

Description (last modified by Katom)

I run the last version (2.6.1) on a MS-Vista machine. 2 days after running the last version of pidgin, I lost the option to type Hebrew on the Google Talk account. I actually can type, but the other side does not see it. Not log in Gmail as well, but there is a correct log of Pidgin.

Other account types (like: MSN, ICQ) worked well with the last version. I tried to upgrade GTK+ to the last version, but it didn't change anything.

I reverted back to 2.5.8 - and all is OK.

I have a friend that works OK with the last version on Windows XP

Thanks.

Change History (22)

comment:1 Changed 10 years ago by Katom

  • Description modified (diff)

comment:2 Changed 10 years ago by darkrain42

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.
Please type and send a message with Hebrew characters.

comment:3 Changed 10 years ago by Katom

  • Status changed from pending to new

The Hebrew message is on 18:57:52 Thanks.

(18:57:42) prefs: purple_prefs_get_string: Unknown pref /plugins/gtk/extpos/roles/debug
(18:57:42) prefs: /plugins/gtk/extpos/positions/debug::Debug Window changed, scheduling save.
(18:57:45) pidgin-encryption: Using pre-existing menu icon for conv 05609AE8, win 02B8E048, item 050E4958
(18:57:45) util: Writing file prefs.xml to directory C:\Users\<My Windows User name>\AppData\Roaming\.purple
(18:57:45) util: Writing file C:\Users\<My Windows User name>\AppData\Roaming\.purple\prefs.xml
(18:57:50) pidgin-encryption: Using pre-existing menu icon for conv 05609AE8, win 02B8E048, item 050E4958
(18:57:52) pidgin-encryption: send_msg: <addressee>@gmail.com
(18:57:52) pidgin-encryption: Outgoing Msg::<SPAN style="direction:rtl;text-align:right;">רואה את העברית?</SPAN>::
(18:57:52) g_log: purple_utf8_strip_unprintables: assertion `g_utf8_validate(str, -1, NULL)' failed
(18:57:52) jabber: Sending (ssl): <message type='chat' id='purplee7fc24cc' to='<addressee>@gmail.com'><body></body></message>
(18:57:53) pidgin-encryption: Using pre-existing menu icon for conv 05609AE8, win 02B8E048, item 050E4958
(18:57:53) pidgin-encryption: Using pre-existing menu icon for conv 05609AE8, win 02B8E048, item 050E4958
(18:58:03) jabber: Recv (ssl)(314): <message to="<my gmail username>@gmail.com/HomeBF205357" type="chat" id="776" from="<addressee>@gmail.com/Talk.v1049AEDAFF4"><body>?</body><active xmlns="http://jabber.org/protocol/chatstates"/><nos:x value="disabled" xmlns:nos="google:nosave"/><arc:record otr="false" xmlns:arc="http://jabber.org/protocol/archive"/></message>
(18:58:03) pidgin-encryption: Using pre-existing menu icon for conv 05609AE8, win 02B8E048, item 050E4958
(18:58:03) pidgin-pp: Got message from <addressee>@gmail.com/Talk.v1049AEDAFF4, protocol=prpl-jabber
(18:58:03) pidgin-pp: Allowed <addressee full name>
(18:58:03) pidgin-encryption: No header: <body>?</body>
(18:58:03) pidgin-encryption: Proto 'prpl-jabber', header should be: *** Encrypted with the Gaim-Encryption plugin 
(18:58:03) gsms: Status available, chat not stored
(18:58:03) gsms: gsms_received_im_cb() exiting
(18:58:03) pidgin-encryption: Using pre-existing menu icon for conv 05609AE8, win 02B8E048, item 050E4958
(18:58:03) pidgin-encryption: Using pre-existing menu icon for conv 05609AE8, win 02B8E048, item 050E4958

comment:4 Changed 10 years ago by darkrain42

  • Status changed from new to pending

If you disable pidgin-encryption, does it work?

comment:5 Changed 10 years ago by Katom

  • Status changed from pending to new

It is the same, even if pidgin-enc. is disabled. In my last check - there was a change: I don't see the Hebrew characters in the debug log!

comment:6 Changed 10 years ago by darkrain42

  • Status changed from new to pending

Please get a debug log without pidgin-encryption enabled.

comment:7 Changed 10 years ago by Katom

  • Status changed from pending to new

Currently, no matter if Pidgin Encryption work or not, I get the same situation - and there is even no Hebrew in the debug log, see here:

(20:08:23) g_log: purple_utf8_strip_unprintables: assertion `g_utf8_validate(str, -1, NULL)' failed (20:08:23) jabber: Sending (ssl): <message type='chat' id='purple129f6548' to='<addressee>@gmail.com'><body></body></message> (20:08:23) util: Writing file prefs.xml to directory C:\Users\<my Windows user name>\AppData?\Roaming\.purple (20:08:23) util: Writing file C:\Users\<my Windows user name>\AppData?\Roaming\.purple\prefs.xml

comment:8 Changed 10 years ago by darkrain42

  • Status changed from new to pending

Could you download and copy to either C:\Users\<my Windows user name>\AppData??\Roaming\.purple\plugins\ or C:\Program Files\Pidgin\plugins\ this signals-test.dll, restart Pidgin, enable the plugin in the Tools->Plugins dialog, and then get a new debug log of sending a message with hebrew letters in it, please?

I can't reproduce this issue on my side, so I'm trying to figure out why the message isn't validating as UTF-8. This plugin should provide a little more debugging output.

comment:9 Changed 10 years ago by Katom

  • Status changed from pending to new

Now I DO see the Hebrew in the log file. Probably not related to the bug. Here is what you asked for:

(21:47:02) pidgin-encryption: Using pre-existing menu icon for conv 05C9C388, win 033FE228, item 057F6D68
(21:47:02) signals test: sending-im-msg (<my Gmail username>@gmail.com/Home, <addressee>@gmail.com, <SPAN style="direction:rtl;text-align:right;">עברית</SPAN>)
(21:47:02) pidgin-encryption: send_msg: <addressee>@gmail.com
(21:47:02) pidgin-encryption: Outgoing Msg::<SPAN style="direction:rtl;text-align:right;">עברית</SPAN>::
(21:47:02) g_log: purple_utf8_strip_unprintables: assertion `g_utf8_validate(str, -1, NULL)' failed
(21:47:02) jabber: Sending (ssl): <message type='chat' id='purple81fde9b5' to='<addressee>@gmail.com'><body></body></message>
(21:47:02) signals test: writing-im-msg (<my Gmail username>@gmail.com/Home, <addressee>@gmail.com, <SPAN style="direction:rtl;text-align:right;">עברית</SPAN>)
(21:47:02) signals test: wrote-im-msg (<my Gmail username>@gmail.com/Home, <addressee>@gmail.com, <br/><SPAN style="direction:rtl;text-align:right;">עברית</SPAN>)
(21:47:02) signals test: sent-im-msg (<my Gmail username>@gmail.com/Home, <addressee>@gmail.com, <font color="#ff0000">׳(21:47:02) pidgin-encryption: Using pre-existing menu icon for conv 05C9C388, win 033FE228, item 057F6D68
(21:47:02) pidgin-encryption: Using pre-existing menu icon for conv 05C9C388, win 033FE228, item 057F6D68

comment:10 Changed 10 years ago by darkrain42

  • Cc datallah added

datallah, do you have any idea why <SPAN style="direction:rtl;text-align:right;">עברית</SPAN> wouldn't validate as UTF-8 on Windows? I can send it fine on linux.

comment:11 follow-up: Changed 10 years ago by datallah

No, I'm not aware of there ever being any issues with UTF-8 validation being any different on Windows.

Are we sure that is the exact same string being passed to g_utf8_validate()?

comment:12 Changed 10 years ago by darkrain42

  • Status changed from new to pending

Katom, please get another debug log with the signals-test plugin enabled and pidgin-encryption disabled.

Additionally, what other plugins do you have enabled?

comment:13 in reply to: ↑ 11 Changed 10 years ago by darkrain42

Replying to datallah:

No, I'm not aware of there ever being any issues with UTF-8 validation being any different on Windows.

Are we sure that is the exact same string being passed to g_utf8_validate()?

purple_utf8_strip_unprintables() is passed the argument directly from XMPP's send_im function. I guess the only other possibility here is some other plugin is munging up the message. If the debug output without pidgin-encryption offers no leads, I'll add more verbose output to purple_utf8_strip_unprintables about the argument passed in and the first 'invalid' character.

This line from the signals-test plugin should print exactly what was sent to the prpl, and it does look a little...corrupt. or something:

(21:47:02) signals test: sent-im-msg (<my Gmail username>@gmail.com/Home, <addressee>@gmail.com, <font color="#ff0000">׳(21:47:02) pidgin-encryption: Using pre-existing menu icon for conv 05C9C388, win 033FE228, item 057F6D68

comment:14 Changed 10 years ago by Katom

  • Status changed from pending to new

It can be a Vista only problem!

comment:15 Changed 10 years ago by darkrain42

  • Status changed from new to pending

comment:16 Changed 10 years ago by Katom

  • Status changed from pending to new
  • Version changed from 2.6.1 to 2.6.2

With 2.6.2 the status is the same. Here is the debug log:

(20:16:32) pidgin-encryption: Outgoing Msg::<SPAN style="direction:rtl;text-align:right;">בדיקה</SPAN>::
(20:16:32) util: purple_utf8_strip_unprintables(<font color="#ff0000">׳(20:16:32) g_log: file util.c: line 4668 (purple_utf8_strip_unprintables): should not be reached
(20:16:32) jabber: Sending (ssl): <message type='chat' id='purple5c45807d' to='<addressee>@gmail.com'><active xmlns='http://jabber.org/protocol/chatstates'/><body></body></message>
(20:16:32) signals test: writing-im-msg (<My Gmail username>@gmail.com/Home, <addressee>@gmail.com, <SPAN style="direction:rtl;text-align:right;">בדיקה</SPAN>)
(20:16:32) signals test: wrote-im-msg (<My Gmail username>@gmail.com/Home, <addressee>@gmail.com, <br/><SPAN style="direction:rtl;text-align:right;">בדיקה</SPAN>)
(20:16:32) signals test: sent-im-msg (<My Gmail username>@gmail.com/Home, <addressee>@gmail.com, <font color="#ff0000">׳(20:16:32) pidgin-encryption: Using pre-existing menu icon for conv 05C77D18, win 052E0610, item 0534AC98

comment:17 Changed 10 years ago by darkrain42

  • Status changed from new to pending

What plugins do you have enabled?

comment:18 Changed 10 years ago by Katom

  • Status changed from pending to new

It's a long list.. Any way to see it in one of the Pidgin configuration files? Anyway, the exact same configuration works perfectly with 2.5.8.

comment:19 Changed 10 years ago by darkrain42

  • Status changed from new to pending

It may work properly with 2.5.8, as that version didn't try to prevent users from sending characters that would disconnect you, but that debug output strongly points to something being very very corrupted, as the second line is supposed to contain a lot more information about the "corruption":

        purple_debug_error("util", "purple_utf8_strip_unprintables(%s) failed; "
                                   "first bad character was %02x (%c)\n",
                           str, *bad, *bad);

You can find the loaded plugins in prefs.xml in the path /pidgin/plugins/loaded.

comment:20 Changed 10 years ago by Katom

  • Status changed from pending to new

Here is the list of loaded plugins:

"C:\Program Files\Pidgin\plugins\album.dll" 
 "C:\Program Files\Pidgin\plugins\autoaccept.dll" 
 "C:\Program Files\Pidgin\plugins\autorejoin.dll" 
 "C:\Program Files\Pidgin\plugins\bot-sentry.dll" 
 "C:\Program Files\Pidgin\plugins\gtkbuddynote.dll" 
 "C:\Program Files\Pidgin\plugins\buddynote.dll" 
 "C:\Program Files\Pidgin\plugins\statenotify.dll" 
 "C:\Program Files\Pidgin\plugins\pidgin-logstatus-0.6.dll" 
 "C:\Program Files\Pidgin\plugins\listlog.dll" 
 "C:\Program Files\Pidgin\plugins\colorize.dll" 
 "C:\Program Files\Pidgin\plugins\convcharcount.dll" 
 "C:\Program Files\Pidgin\plugins\convbadger.dll" 
 "C:\Program Files\Pidgin\plugins\convcolors.dll" 
 "C:\Program Files\Pidgin\plugins\enhancedhist.dll" 
 "C:\Program Files\Pidgin\plugins\extplacement.dll" 
 "C:\Program Files\Pidgin\plugins\extpos.dll" 
 "C:\Program Files\Pidgin\plugins\extended_blist_sort.dll" 
 "C:\Program Files\Pidgin\plugins\extprefs.dll" 
 "C:\Program Files\Pidgin\plugins\gtalkinvisible.dll" 
 "C:\Program Files\Pidgin\plugins\groupmsg.dll" 
 "C:\Program Files\Pidgin\plugins\hideconv.dll" 
 "C:\Program Files\Pidgin\plugins\history.dll" 
 "C:\Program Files\Pidgin\plugins\iconaway.dll" 
 "C:\Program Files\Pidgin\plugins\jabber-settings.dll" 
 "C:\Program Files\Pidgin\plugins\lastseen.dll" 
 "C:\Program Files\Pidgin\plugins\log_reader.dll" 
 "C:\Program Files\Pidgin\plugins\MeBeamPlugin.dll" 
 "C:\Program Files\Pidgin\plugins\notify.dll" 
 "C:\Program Files\Pidgin\plugins\timestamp_format.dll" 
 "C:\Program Files\Pidgin\plugins\ssl-nss.dll" 
 "C:\Program Files\Pidgin\plugins\newline.dll" 
 "C:\Program Files\Pidgin\plugins\nicksaid.dll" 
 "C:\Program Files\Pidgin\plugins\pidgin-otr.dll" 
 "C:\Program Files\Pidgin\plugins\offlinemsg.dll" 
 "C:\Program Files\Pidgin\plugins\encrypt.dll" 
 "C:\Program Files\Pidgin\plugins\pidgin-pp.dll" 
 "C:\Program Files\Pidgin\plugins\psychic.dll" 
 "C:\Program Files\Pidgin\plugins\quote_text.dll" 
 "C:\Program Files\Pidgin\plugins\relnot.dll" 
 "C:\Program Files\Pidgin\plugins\ssl.dll" 
 "C:\Program Files\Pidgin\plugins\sslinfo.dll" 
 "C:\Program Files\Pidgin\plugins\screenshot.dll" 
 "C:\Program Files\Pidgin\plugins\sendbutton.dll" 
 "C:\Program Files\Pidgin\plugins\sepandtab.dll" 
 "C:\Program Files\Pidgin\plugins\signals-test.dll" 
 "C:\Program Files\Pidgin\plugins\switchspell.dll" 
 "C:\Program Files\Pidgin\plugins\spellchk.dll" 
 "C:\Program Files\Pidgin\plugins\winprefs.dll" 
 "C:\Program Files\Pidgin\plugins\gsms.dll" 

comment:21 Changed 10 years ago by darkrain42

  • Status changed from new to pending

Can you reproduce the issue if you disable all of your plugins?

If so, please perform a binary search on your plugins until the issue reoccurs.

comment:22 Changed 10 years ago by Katom

  • Resolution set to fixed
  • Status changed from pending to closed

OK - Found it. This is problematic plug-in:

C:\Program Files\Pidgin\plugins\colorize.dll It is part from the "Purple Plugin Pack". Upgrading it to the last (2.60) version didn't help. I disabled the plug-in and all is OK now.

Still strange that the problem is only in Jabber.. :)

Thank you all!

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!