Opened 9 years ago

Closed 7 years ago

Last modified 5 years ago

#1009 closed defect (duplicate)

ICQ Privacy Sucks

Reported by: cg0def Owned by: MarkDoliner
Milestone: Component: ICQ
Version: 2.0 Keywords: icq block user
Cc: arudil, ari, hvdkooij, ckesh

Description

icq does not really support blocking users however there is an ignore list in the official client. The block user feature in pidgin does not work at all for ICQ and you also do not get a message saying that it would not work.

Change History (20)

comment:1 Changed 9 years ago by rekkanoryo

  • Keywords changed from icq, block user to icq block user

The ICQ "block" list in Pidgin is actually the "invisible" list for ICQ. This is a known problem. I'm not sure of the status of any work to resolve the problem, but I believe it may be waiting on the privacy rewrite libpurple has needed for quite some time now.

comment:2 Changed 9 years ago by datallah

  • Component changed from winpidgin (gtk) to libpurple
  • Owner datallah deleted

comment:3 Changed 9 years ago by lschiere

  • Milestone set to 3.0.0
  • Owner set to MarkDoliner

comment:4 Changed 9 years ago by seanegan

  • Component changed from libpurple to ICQ

comment:5 Changed 9 years ago by seanegan

  • priority changed from minor to major

Duplicates: #1080 #1320 #1400 #1669 #2068

comment:6 Changed 9 years ago by seanegan

  • Summary changed from icq block user to ICQ Privacy Sucks

comment:7 follow-up: Changed 9 years ago by i-nZ

Steps to reproduce

  1. Menu->Tools->Privacy, set privacy for a icq account, and choice "Block all

users", and your account will be offline mode on your friends icq client actually.

  1. Menu->Tools->Preferences->Away/Idle?->Auto-away, Set away when idle is on, 1

minute before setting away.

  1. Wait a minute don't touch the computer, that gaim will change to Auto-away

mode, and you will find your account is online & Not Available mode in your friends icq client, Not offline mode like before. Open the set Privacy window, you will find the privacy mode is resetted to "Block only the users below".

Taken from http://bugzilla.novell.com/show_bug.cgi?id=199694

comment:8 Changed 9 years ago by sirAenuHlaalu

You may try to use bot-sentry plugin to protect you from ICQ spam http://sourceforge.net/projects/pidgin-bs/ It seems to work. By the way, I can send you a patch, which allows denying authorization requests in automatic mode.

comment:9 in reply to: ↑ 7 Changed 9 years ago by lexa2

Replying to i-nZ:

friends icq client, Not offline mode like before. Open the set Privacy window, you will find the privacy mode is resetted to "Block only the users below".

Looks like that pidgin takes track of 'privacy mode' and 'blocked list' separately for each online status. It allows you to block some users from seeing you when in 'Online' status, and block all users from seeing you when 'Invisible', except several you have specified an exceptions.

Came to this conclusion while investigating <privacy> subsection of blist.xml. Not sure, that things are like I think they are.

comment:10 Changed 8 years ago by Sim-on

Ticket #7152 has been marked as a duplicate of this ticket.

comment:11 Changed 8 years ago by datallah

Ticket #7955 has been marked as a duplicate of this ticket.

comment:12 Changed 8 years ago by darkrain42

Ticket #8468 has been marked as a duplicate of this ticket.

comment:13 Changed 7 years ago by rekkanoryo

Ticket #8543 has been marked as a duplicate of this ticket.

comment:14 Changed 7 years ago by markdoliner@…

(In e878814dfc99f1f0a681a2263488c75a068c7c8e):
Change the way oscar deals with account->perm_deny a little bit.

  1. We no longer read the privacy setting from the server for ICQ accounts
  2. We no longer change account->perm_deny when an ICQ account changes its status (or ever)
  3. When going invisible, we still override the permit deny setting and set it to "invisible to everyone except the people in my allow list," but this change is only made on the server and not account->perm_deny

Refs #1009 Fixes #5263 I think

comment:15 Changed 7 years ago by ckesh

The editing of ~/.gaim/blist.xml works: I`ve changed to

<account proto='prpl-oscar' name='********' mode='1'/>

from mode='4' at privacy tag and it not changing back.

mode 1 is for "allow only users from my buddy list"

comment:16 Changed 7 years ago by MarkDoliner

Er, are you using Pidgin? Pidgin uses ~/.purple/blist.xml, not ~/.gaim/blist.xml

comment:17 Changed 7 years ago by ckesh

Please excuse me. I can't edit my previous message. ~/.gaim/ is a leftover from the early version. Of course it's ~/.purple/ and I guess the right mode is 5.

comment:18 Changed 7 years ago by bernmeister

Mark as a duplicate of #39?

comment:19 Changed 7 years ago by darkrain42

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #39.
I think so. It looks like Mark fixed the ICQ-specific non-"ICQ privacy sucks in general" issues.

comment:20 Changed 5 years ago by Robby

  • Milestone 3.0.0 deleted
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!