Opened 9 years ago

Closed 4 years ago

#10118 closed defect (duplicate)

GTalk, not authorized

Reported by: paperdoll2003 Owned by: darkrain42
Milestone: Component: Google Talk
Version: 2.6.1 Keywords:
Cc: yrtimid

Description (last modified by darkrain42)

GoogleTalk? giving error "Not Authorized" when trying to connect.

 Error Log:
 (15:14:20) account: Connecting to account cicelyshea@gmail.com/.
 (15:14:20) connection: Connecting. gc = 037CB1C8
 (15:14:20) dnssrv: querying SRV record for gmail.com: _xmpp-
 client._tcp.gmail.com
 (15:14:20) util: Writing file prefs.xml to directory
 C:\Users\Brenda\AppData\Roaming\.purple
 (15:14:20) util: Writing file
 C:\Users\Brenda\AppData\Roaming\.purple\prefs.xml
 (15:14:20) dnssrv: found 5 SRV entries
 (15:14:20) dnsquery: Performing DNS lookup for talk.l.google.com
 (15:14:20) dnsquery: IP resolved for talk.l.google.com
 (15:14:20) proxy: Attempting connection to 74.125.47.125
 (15:14:20) proxy: Connecting to talk.l.google.com:5222 with no proxy
 (15:14:20) proxy: Connection in progress
 (15:14:20) proxy: Connecting to talk.l.google.com:5222.
 (15:14:20) proxy: Connected to talk.l.google.com:5222.
 (15:14:20) jabber: Sending: <?xml version='1.0' ?>
 (15:14:20) jabber: Sending: <stream:stream to='gmail.com'
 xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams'
 version='1.0'>
 (15:14:20) jabber: Recv (138): <stream:stream from="gmail.com"
 id="852CFBD37EB93740" version="1.0"
 xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client">
 (15:14:20) jabber: Recv (210): <stream:features><starttls
 xmlns="urn:ietf:params:xml:ns:xmpp-tls"><required/></starttls><mechanisms
 xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>X-GOOGLE-
 TOKEN</mechanism></mechanisms></stream:features>
 (15:14:20) jabber: Sending: <starttls xmlns='urn:ietf:params:xml:ns:xmpp-
 tls'/>
 (15:14:20) jabber: Recv (50): <proceed xmlns="urn:ietf:params:xml:ns:xmpp-
 tls"/>
 (15:14:20) nss: subject=CN=gmail.com,O=Google Inc.,L=Mountain
 View,ST=California,C=US issuer=OU=Equifax Secure Certificate
 Authority,O=Equifax,C=US
 (15:14:20) nss: subject=OU=Equifax Secure Certificate
 Authority,O=Equifax,C=US issuer=OU=Equifax Secure Certificate
 Authority,O=Equifax,C=US
 (15:14:20) certificate/x509/tls_cached: Starting verify for gmail.com
 (15:14:20) certificate/x509/tls_cached: Checking for cached cert...
 (15:14:20) certificate/x509/tls_cached: ...Found cached cert
 (15:14:20) nss/x509: Loading certificate from
 C:\Users\Brenda\AppData\Roaming\.purple\certificates\x509\tls_peers\gmail.com
 (15:14:20) certificate/x509/tls_cached: Peer cert matched cached
 (15:14:20) certificate: Successfully verified certificate for gmail.com
 (15:14:20) jabber: XML parser error for JabberStream 03A64D90: Domain 1,
 code 5, level 3: Extra content at the end of the document
 (15:14:20) jabber: Sending (ssl): <stream:stream to='gmail.com'
 xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams'
 version='1.0'>
 (15:14:20) jabber: Recv (ssl)(138): <stream:stream from="gmail.com"
 id="8FEC080A135AC93E" version="1.0"
 xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client">
 (15:14:20) jabber: Recv (ssl)(166): <stream:features><mechanisms
 xmlns="urn:ietf:params:xml:ns:xmpp-
 sasl"><mechanism>PLAIN</mechanism><mechanism>X-GOOGLE-
 TOKEN</mechanism></mechanisms></stream:features>
 (15:14:20) sasl: Mechs found: PLAIN
 (15:14:20) jabber: Sending (ssl): <auth xmlns='urn:ietf:params:xml:ns
 :xmpp-sasl' mechanism='PLAIN'
 xmlns:ga='http://www.google.com/talk/protocol/auth' ga:client-uses-full-
 bind-result='true'>password removed</auth>
 (15:14:21) jabber: Recv (ssl)(77): <failure xmlns="urn:ietf:params:xml:ns
 :xmpp-sasl"><not-authorized/></failure>
 (15:14:21) connection: Connection error on 037CB1C8 (reason: 2
 description: Not Authorized)
 (15:14:21) jabber: Recv (ssl)(16): </stream:stream>
 (15:14:21) account: Disconnecting account 01C96890
 (15:14:21) connection: Disconnecting connection 037CB1C8
 (15:14:21) jabber: Sending (ssl): </stream:stream>
 (15:14:21) connection: Destroying connection 037CB1C8

I followed instructions about checking Force old (port 5223)SSL with several ports with no luck. I do not get the not authorized error anymore but it just sits at connecting, eventually timing out with error SSL Connection failed.

Error Log:

 (15:17:11) account: Connecting to account cicelyshea@gmail.com/.
 (15:17:11) connection: Connecting. gc = 03AD0520
 (15:17:11) dnsquery: Performing DNS lookup for gmail.com
 (15:17:11) dnsquery: IP resolved for gmail.com
 (15:17:11) proxy: Attempting connection to 74.125.79.83
 (15:17:11) proxy: Connecting to gmail.com:5223 with no proxy
 (15:17:11) proxy: Connection in progress
 (15:17:16) util: Writing file accounts.xml to directory
 C:\Users\Brenda\AppData\Roaming\.purple
 (15:17:16) util: Writing file
 C:\Users\Brenda\AppData\Roaming\.purple\accounts.xml
 (15:17:28) facebook: executing callback for
 /x/1251404193/true/p_111200465=1
 (15:17:28) facebook: got new messages:
 for (;;);{"t":"continue"}
 (15:17:28) facebook: getting new messages
 (15:17:28) facebook: getting url /x/1251404248/true/p_111200465=1
 (15:17:28) dnsquery: Performing DNS lookup for 69.63.176.174
 (15:17:28) dnsquery: IP resolved for 69.63.176.174
 (15:17:28) proxy: Attempting connection to 69.63.176.174
 (15:17:28) proxy: Connecting to 69.63.176.174:80 with no proxy
 (15:17:28) proxy: Connection in progress
 (15:17:29) proxy: Connecting to 69.63.176.174:80.
 (15:17:29) proxy: Connected to 69.63.176.174:80.
 (15:17:32) proxy: Connecting to gmail.com:5223.
 (15:17:32) proxy: Error connecting to gmail.com:5223 (Connection timed
 out.).
 (15:17:32) proxy: Connection attempt failed: Connection timed out.
 (15:17:32) connection: Connection error on 03AD0520 (reason: 0
 description: SSL Connection Failed)
 (15:17:33) account: Disconnecting account 01C96890
 (15:17:33) connection: Disconnecting connection 03AD0520
 (15:17:33) connection: Destroying connection 03AD0520

Change History (7)

comment:1 Changed 9 years ago by paperdoll2003

  • Description modified (diff)

comment:2 Changed 9 years ago by darkrain42

  • Description modified (diff)

comment:3 Changed 9 years ago by darkrain42

  • Status changed from new to pending

If you're going to enable "Force old (port 5223) SSL", you need to set the Connect Server to "talk.google.com".

The "Not Authorized" message usually means your password is incorrect; verify you have it set properly in Pidgin. I've also seen Google Talk send that error in situations in which the account is not set up properly to use Google Talk, so you may want to try searching the Google Talk support forum for more information.

It doesn't look like Pidgin is doing anything wrong in those logs.

comment:4 Changed 9 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:5 Changed 8 years ago by yrtimid

Have the same problem, in my case 2 different GTalk accounts with same configurations work nice from Win32 pidgin, but on linux only one works good and other one fails with same "Not Authorized" error.

comment:6 Changed 4 years ago by salinasv

  • Status changed from closed to new

comment:7 Changed 4 years ago by salinasv

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #10334.
Marking it as duplicated since #10334 have the correct answer.

Google is preventing you to connect because it doesn't know your new device, you must go to it's web and tell it that it is you who is trying to connect.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!