Opened 7 years ago

Closed 7 years ago

#10183 closed defect (duplicate)

2.6.1 XMPP won't connect to the OpenFire Server in our company.

Reported by: windbreaker Owned by: deryni
Milestone: Component: XMPP
Version: 2.6.1 Keywords: Openfire xmpp
Cc:

Description

Unable to connect anymore to our OpenFire server on sprtim.support.com. I am forced to use the old 2.5.8 in order to connect.

Change History (3)

comment:1 Changed 7 years ago by darkrain42

  • Status changed from new to pending

Are you on Windows? If so, look at ticket #9956 and install the libpurple.dll linked to from there. If not, please attach the output of the Help->Debug Window.

comment:2 Changed 7 years ago by windbreaker

  • Status changed from pending to new

That link fixed my issue thank you. http://pidgin.im/~nosnilmot/2.6.1/srvfix/libpurple.dll

When are we going to fix the pidgin droppings on openfire servers? Can't pidgin send "keep alive" packets like other clients do? Other clients dont' have this constant dropping/connecting issue. People in the chat rooms complain about pidgin users always dropping out of chat and returning. When you have 50+ ppl in the chat that use pidgin it can really become a problem.

comment:3 Changed 7 years ago by darkrain42

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #9956.
Pidgin sends XEP-0199 pings as keepalives.

It sounds like you may be encountering the issue where Openfire just completely ignores some IQ packets (in clear violation of the XMPP specs). There are some older tickets relating to that (I don't have the #s handy).

Please file a new issue for this and attach the Help->Debug Window output from a computer being disconnected from openfire.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!