Opened 9 years ago

Closed 8 years ago

#10223 closed defect (wontfix)

QQ

Reported by: wordperfect Owned by: csyfek
Milestone: Component: QQ
Version: 2.6.2 Keywords:
Cc: pplwong

Description

I use qq, the Chinese ICQ clone. I used an early qq for almost 9 years then it refused to load, first on Pidgin, but later on qq itself. The problem was qq related, they phased out the old series, i found this from your bug lists and help pages. I now have the lastest QQ and 6.1 pigin, QQ runs fine on the qq client, but the moment or shortly after, i try to use it on Pidgin, it is disabled by Tencent and I need to reapply for a new password as they cite, "security concerns" with my account. I must have reset my p/w about 4 dozen times and am fairly sure the problem is not with qq but with Pidgin. I can run qq for ever as long as i don't have Pidgin try to open it.How can I overcome this please, any ideas?

Change History (8)

comment:1 Changed 9 years ago by QuLogic

  • Component changed from unclassified to QQ
  • Keywords QQ removed
  • Owner changed from rekkanoryo to csyfek

comment:2 Changed 9 years ago by irvine

Same goes for Ubuntu + Pidgin 2.6.3 and QQ. Able to log in, but disconnects after a while. The account will be disabled, and you have to go to http://jihuo.qq.com to enable your account again.

Error that shows (in Chinese, but still): <account number> disabled 您的号码可能存在异常情况,已受到限制登录保护,需激活后才能正常登录。激活网址: http://jihuo.qq.com

comment:3 Changed 9 years ago by pplwong

It happens to me also, for quite a while already. Might it be deal to some new QQ protocol? Or might it be because we have used QQ2009 (which is newer than QQ2008, the newest that's "supported" by pidgin)?Or... might it be the captcha...?

Here's the log (16:48:49) QQ: Select server 'auto' (16:48:49) QQ: Server list has 6 (16:48:49) QQ: Resend interval 3, retries 10 (16:48:49) QQ: Disconnecting... (16:48:49) QQ: Server list has 6 (16:48:49) QQ: set new server to tcpconn6.tencent.com:8000 (16:48:49) QQ: Connect to tcpconn6.tencent.com:8000 (16:48:49) QQ: <== [14896] CMD_GET_SERVER(0x0091), datalen 48 (16:48:50) QQ: ==> [14896] CMD_GET_SERVER 0x0091, source tag 0x115B len 40 (16:48:50) QQ: Get server 121.14.98.158 (16:48:52) QQ: Disconnecting... (16:48:52) QQ: Remove network watcher (16:48:52) QQ: Close socket 924 (16:48:52) QQ_TRANS: Free all 1 packets (16:48:52) QQ: Port not define in 121.14.98.158:0, use default. (16:48:52) QQ: Connect to 121.14.98.158:8000 (16:48:52) QQ: <== [14906] CMD_GET_SERVER(0x0091), datalen 48 (16:48:52) QQ: ==> [14906] CMD_GET_SERVER 0x0091, source tag 0x115B len 24 (16:48:52) QQ: <== [14907] CMD_TOKEN(0x0062), datalen 1 (16:48:52) QQ: ==> [14907] CMD_TOKEN 0x0062, source tag 0x115B len 34 (16:48:52) QQ: <== [14908] CMD_TOKEN_EX(0x00BA), datalen 64 (16:48:53) QQ: ==> [14908] CMD_TOKEN_EX 0x00BA, source tag 0x115B len 56 (16:48:53) QQ: Captcha verified, result 0 (16:48:53) QQ: <== [14909] CMD_CHECK_PWD(0x00DD), datalen 128 (16:48:53) QQ: ==> [14909] CMD_CHECK_PWD 0x00DD, source tag 0x115B len 136 (16:48:53) QQ: Decrypt login packet by random_key, 113 bytes (16:48:53) QQ: Activation required: 您的号码可能存在异常情况,已受到限制登录保护,需激活后才能正常登录。激活网址: http://jihuo.qq.com (16:48:53) QQ: Disconnecting... (16:48:53) QQ: Remove network watcher (16:48:53) QQ: Close socket 1360 (16:48:53) QQ_TRANS: Free all 4 packets (16:48:53) QQ: free server list

comment:4 Changed 9 years ago by dbbolton

I can confirm this on 2.6.3 Debian testing amd64

comment:5 Changed 9 years ago by dbbolton

Also, I now can't log into or "repair" my account. It tells me that my password is wrong, even though I remember it, have checked the caps lock key, and have tried typing it in several times. i don't know whether this is Pidgin's fault though.

comment:6 Changed 8 years ago by shar88

I still get this error running pidgin 2.7.2 on windows. I believe this to be the same issue so I didn't want to open a new ticket. I can log in but after several hours, my account becomes disabled with the message...

<account #> disabled 您的号码可能存在异常情况,已受到限制登录保护,需激活后才能正常登录。激活网址: http://jihuo.qq.com

which roughly translates too

Your number may have unusual circumstances, has been restricted login protection, can be activated the normal login. Activate Website: http://jihuo.qq.com

Upon going to that page I am forced to change my password to re-enabled my account, something I've done about a dozen times already this week. If this belongs in a new ticket let me know. Any help with this would be appreciated.

Also side note, I did change the Client Version to QQ2008, and I believe this should be the default selection for creating a QQ account and possibly have the older ones removed from the list because you can not log in with those selected.

comment:7 Changed 8 years ago by rekkanoryo

  • Resolution set to wontfix

We have decided to discontinue support of the QQ protocol in libpurple and Pidgin as of version 2.8.0. Other implementations are available; please investigate their use if you want to continue using QQ.

comment:8 Changed 8 years ago by rekkanoryo

  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!