Opened 8 years ago

Closed 8 years ago

Last modified 3 years ago

#10334 closed defect

gtalk won't authorize

Reported by: galadriei Owned by: rekkanoryo
Milestone: Component: Google Talk
Version: 2.6.2 Keywords:
Cc: sathyz

Description

I have followed the detailed instructions that can be found in google's help section and various other websites. Nothing lets me connect to gtalk.

(18:43:02) account: Connecting to account 4peacehere@…/. (18:43:02) connection: Connecting. gc = 04E0FEA8 (18:43:02) dnsquery: Performing DNS lookup for talk.google.com (18:43:02) dnsquery: IP resolved for talk.google.com (18:43:02) proxy: Attempting connection to 74.125.65.125 (18:43:02) proxy: Connecting to talk.google.com:5222 with no proxy (18:43:02) proxy: Connection in progress (18:43:02) proxy: Connecting to talk.google.com:5222. (18:43:02) proxy: Connected to talk.google.com:5222. (18:43:02) jabber: Sending: <?xml version='1.0' ?> (18:43:02) jabber: Sending: <stream:stream to='gmail.com' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0'> (18:43:02) jabber: Recv (348): <stream:stream from="gmail.com" id="4F843810D7EA6528" version="1.0" xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client"><stream:features><starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls"><required/></starttls><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>X-GOOGLE-TOKEN</mechanism></mechanisms></stream:features> (18:43:02) jabber: Sending: <starttls xmlns='urn:ietf:params:xml:ns:xmpp-tls'/> (18:43:02) jabber: Recv (50): <proceed xmlns="urn:ietf:params:xml:ns:xmpp-tls"/> (18:43:02) nss: subject=CN=gmail.com,O=Google Inc.,L=Mountain View,ST=California,C=US issuer=OU=Equifax Secure Certificate Authority,O=Equifax,C=US (18:43:02) nss: subject=OU=Equifax Secure Certificate Authority,O=Equifax,C=US issuer=OU=Equifax Secure Certificate Authority,O=Equifax,C=US (18:43:02) certificate/x509/tls_cached: Starting verify for talk.google.com (18:43:02) certificate/x509/tls_cached: Checking for cached cert... (18:43:02) certificate/x509/tls_cached: ...Found cached cert (18:43:02) nss/x509: Loading certificate from C:\Users\steph\AppData?\Roaming\.purple\certificates\x509\tls_peers\talk.google.com (18:43:02) certificate/x509/tls_cached: Peer cert matched cached (18:43:02) certificate: Successfully verified certificate for talk.google.com (18:43:02) jabber: XML parser error for JabberStream? 04EFE910: Domain 1, code 5, level 3: Extra content at the end of the document (18:43:02) jabber: Sending (ssl): <stream:stream to='gmail.com' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0'> (18:43:02) jabber: Recv (ssl)(138): <stream:stream from="gmail.com" id="34EF7B7957E341E4" version="1.0" xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client"> (18:43:02) jabber: Recv (ssl)(166): <stream:features><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>PLAIN</mechanism><mechanism>X-GOOGLE-TOKEN</mechanism></mechanisms></stream:features> (18:43:02) sasl: Mechs found: PLAIN (18:43:02) jabber: Sending (ssl): <auth xmlns='urn:ietf:params:xml:ns:xmpp-sasl' mechanism='PLAIN' xmlns:ga='http://www.google.com/talk/protocol/auth' ga:client-uses-full-bind-result='true'>password removed</auth> (18:43:03) jabber: Recv (ssl)(77): <failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><not-authorized/></failure> (18:43:03) connection: Connection error on 04E0FEA8 (reason: 2 description: Not Authorized) (18:43:03) jabber: Recv (ssl)(16): </stream:stream> (18:43:03) account: Disconnecting account 4peacehere@…/ (02452BD0) (18:43:03) connection: Disconnecting connection 04E0FEA8 (18:43:03) jabber: Sending (ssl): </stream:stream> (18:43:03) connection: Destroying connection 04E0FEA8 (18:43:07) util: Writing file accounts.xml to directory C:\Users\steph\AppData?\Roaming\.purple (18:43:07) util: Writing file C:\Users\steph\AppData?\Roaming\.purple\accounts.xml (18:44:13) util: Writing file accounts.xml to directory C:\Users\steph\AppData?\Roaming\.purple (18:44:13) util: Writing file C:\Users\steph\AppData?\Roaming\.purple\accounts.xml (18:44:14) util: Writing file blist.xml to directory C:\Users\steph\AppData?\Roaming\.purple (18:44:14) util: Writing file C:\Users\steph\AppData?\Roaming\.purple\blist.xml (18:44:17) prefs: /pidgin/filelocations/last_save_folder changed, scheduling save.

Attachments (1)

purple-debug.log (4.0 KB) - added by galadriei 8 years ago.
debug

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by galadriei

debug

comment:1 Changed 8 years ago by sathyz

I face the same issue. I'm on Debian (Linux 2.6.30-1-amd64 x86_64 GNU/Linux). Gtalk is not authorized.

comment:2 Changed 8 years ago by sathyz

I got it working. Seems my account was locked due to malicious/previous problem in login. I had to unlock captcha.

The solution given in gtalk help forum worked. http://www.google.com/support/forum/p/Talk/thread?tid=17d1a20657f85d04&hl=en

Goto https://www.google.com/accounts/DisplayUnlockCaptcha and unlock it.

comment:3 Changed 8 years ago by darkrain42

  • Component changed from unclassified to Google Talk
  • Status changed from new to pending

THe "Not Authorized" error is always some sort of server-side error (in theory wrong password, but in my experience almost never). I recommend searching the Google Talk forum for "Not Authorized" and looking for possible solutions there.

comment:4 Changed 8 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:5 Changed 3 years ago by salinasv

Ticket #10118 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!