Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#10335 closed defect (fixed)

2.6.x input method annoyances on Windows

Reported by: ywliu Owned by: rekkanoryo
Milestone: Component: winpidgin (gtk)
Version: 2.6.2 Keywords:
Cc:

Description

Since moving to 2.6.(1,2), on my localized Traditional Chinese Windows XP , the input method has become very weird.

  1. Now Every time I use input method to type in Chinese characters, they would come with an underline within the input window.
  1. The worst thing is, now if I switch between several windows, and then go back to the , say, MSN chat window in Pidign, the input method is confused. I cannot type in Chinese any more. I have to close the input method and re-launch it by pressing ctrl-shift several times. Looks like the new code has some impact to the input method on Windows XP.

This happened after moving up to 2.6.x. Now I downgrade to 2.5.8 and everything is normal now.

I don't know if this happens only to MSN, since I use MSN on Pidgin most of the time.

ywliu

Attachments (2)

1.jpg (63.4 KB) - added by ywliu 9 years ago.
2.jpg (26.9 KB) - added by ywliu 9 years ago.
Now input method is gone.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by datallah

  • Component changed from unclassified to winpidgin (gtk)
  • Status changed from new to pending

Are you using a different GTK+ version with 2.6.2 than you were with 2.5.8?

comment:2 Changed 9 years ago by ywliu

  • Status changed from pending to new

No, I didn't install any separate GTK+ libraries. I always use the one coming with 2.5.8 or 2.6.2. I believe they are the same version, right?

comment:3 Changed 9 years ago by datallah

  • Status changed from new to pending

Please validate (using Help->About) the GTK+ versions when it is working and when it is isn't.

Changed 9 years ago by ywliu

comment:4 Changed 9 years ago by ywliu

  • Status changed from pending to new

Attachment (1.jpg) added by ticket reporter.

Changed 9 years ago by ywliu

Now input method is gone.

comment:6 Changed 9 years ago by ywliu

Yes, I just confirmed by re-installing both versions. Both are with GTK+ 2.14.7 rev a, the bundled one.

I have attached two screen captured jpeg files. The first one shows the different input screens under both version. In 2.5.8 it's pretty normal as other Windows applications, but in 2.6.2 it's a little different.

The second JPEG shows how 2.6.2 works now. This can be easily reproduced by opening a message window and trying to input some Chinese characters, and simply closing the message window and reopening it by clicking on the contact list. Then the input method was gone as shown in the JPEG. This has been confirmed with MSN and ICQ.

Hope this helps.

ywliu

comment:7 Changed 9 years ago by ywliu

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 9 years ago by ywliu

I just updated to 2.6.4. And looks like this problem was miraculously/silently fixed in this version.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!