Opened 7 years ago

Last modified 6 years ago

#10353 new enhancement

Allow ALT-S to be used for sending message

Reported by: key88sf Owned by: deryni
Milestone: Component: pidgin (gtk)
Version: 2.6.2 Keywords:
Cc:

Description

I'm on Windows, and right now there doesn't seem to be any way to use ALT-S to send an IM message. This is a common shortcut used by most every other IM client.

I have already tried editing my gtkrc file. Alt-S still tries to select a smiley, which is just downright annoying.

As a longtime trillian user, I'm going to stick with Trillian until this ALT-S can be used with Pidgin. I think a lot of other users will be frustrated if they cannot keep their learned shortcuts when switching to pidgin as well.

Change History (6)

comment:1 Changed 7 years ago by deryni

  • Status changed from new to pending

If you disable the formatting toolbar your gtkrc change will take effect. The issue is binding priorities, the gtkrc setting you turn on only sees the keypress if nothing else grabs it first (the toolbar accelerator simply happens to grab it first, I'm not sure there's anything we can do about that and I don't believe it is possible to allow people to modify toolbar/etc. accelerators on-the-fly).

comment:2 Changed 7 years ago by key88sf

  • Status changed from pending to new

Well of course there is something you can do about it:

a) add a line of code to capture ALT-S before it hits the toolbar accelerators
b) add a line to the OnSmileyPressed() handler (or whatever function) to check if the key was ALT-S, and reroute it to Send().
c) change the accelerator of smileys to be something other than ALT-S by default

Guys I've been coding for over 15 years, so an answer like "nothing can be done" for a simple problem like this just doesn't cut it. I think you know it can be done, and probably pretty easily. Thanks.

comment:3 Changed 7 years ago by deryni

  • Status changed from new to pending

You could have chosen to interpret my statement to mean that there is nothing reasonably to be done about this or you could have chosen to interpret it as indicating that there is absolutely no physical way such a thing could ever be possible. One of those would have been much more helpful than the other, I'm sorry you chose the less helpful route, nonetheless you can find my answers below.

The accelerator for smileys is automatically created because of the markup used to make the S underlined, we could change it but that would interfere with someone else's preferred key for something so that isn't likely to happen.

We will not forcibly make alt-s be send since not everyone wants that (imagine if my original response to your request had been "no, we already reserve alt-u for send and we only need the one key for that", and no "well just reserve more in code" isn't an option) also I'm sure a fair number of people like alt-s opening the smiley dialog. The fact that you prefer send to smiley doesn't mean everyone will and doesn't make your preference the right one.

Yes, we could hard grab any key we wanted but that wouldn't be very helpful if someone wanted it for something else. Come on, you know this. We have tried rather hard to hard-grab as few keys as possible (and still get complaints about the few we still grab) adding more is not something we will do lightly.

The closest to reasonable solution to this general sort of problem that I can find is one that would swap out the accelerated toolbar/etc. strings in pidgin for non-accelerated ones so as to not cause GTK+ to grab them at all (but that's only marginally reasonable and not at all trivial to do).

comment:4 Changed 6 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:5 Changed 6 years ago by deryni

  • Component changed from unclassified to pidgin (gtk)
  • Owner rekkanoryo deleted
  • Status changed from closed to new
  • Summary changed from Allow ALT-S to be used for sending message! to Allow ALT-S to be used for sending message
  • Type changed from defect to enhancement

It occurred to me the other day that there is a solution to this problem which will satisfy those people wanting to override the bindings currently used by the formatting toolbar as well as allow people to rebind the actions in the formatting toolbar to other key combinations if they so chose. The solution is to add a Formatting menu to the conversation window and move the key binding to the menu items and out of the toolbar items. This means that while GTK+ will still be grabbing the keys by default the normal menu rebinding functionality will work to clear and change the default bindings. It therefore means that people can bind things like alt-s if they want to.

I noticed one other thing as I was looking into starting to add the new menu, the ungrouped version of the toolbar (right-click in empty space) does not appear to grab any keys, which means one could keep the toolbar active and still be able to use bindings like alt-s.

comment:6 Changed 6 years ago by deryni

  • Owner set to deryni
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!