Opened 12 years ago

Closed 10 years ago

Last modified 9 years ago

#104 closed enhancement (fixed)

Reconnect to network should reconnect chats also

Reported by: fmoo Owned by: sadrul
Milestone: 2.2.1 Component: libpurple
Version: 2.0 Keywords:
Cc:

Description

=Steps to Reproduce=

  1. Join a Chatroom (such as irc://irc.mozilla.org#firefox)
  2. Disconnect from network
  3. Reconnect to network

==Resulting behavior==

The chatroom window becomes disabled and disconnects, and will not handle any further input or output.

==Expected behavior==

The chatroom should automatically /join or reconnect, or at least allow the user to enter /join #channel.

Attachments (1)

purple-debug.log (5.0 KB) - added by charding 9 years ago.
Pidgin debug log

Download all attachments as: .zip

Change History (13)

comment:1 Changed 12 years ago by lschiere

  • Owner set to elb

#346 marked duplicate of this.

comment:2 Changed 12 years ago by sadrul@…

(In 99f8d517ae6588b2dba3527cb0951f32e640ff57) If there's a chat open when an account gets disconnected because of an error, then try to rejoin that chat after the account gets back online. I'll see how this goes here, if it goes well, we can do the same in pidgin. References #104.

comment:3 Changed 12 years ago by sadrul@…

  • Milestone set to 2.2.1
  • Resolution set to fixed
  • Status changed from new to closed

(In abd68a0284028e1f6620c0f7ef517a13458d49d1) Fix #104 (Reconnect to network should reconnect chats also). This has been working OK in finch. I think it's going to work in Pidgin too. If you are in a chat when an account disconnects due to some error, then you will rejoin the chats when the account signs back on.

comment:4 Changed 10 years ago by charding

This does not work in pidgin 2.5.3. The chat rooms are not re-connected.

comment:5 Changed 10 years ago by charding

Can this be re-opened since it does not reconnect chat/irc-rooms in 2.6.2 if disconnected and reconnected to network.

comment:6 Changed 10 years ago by sadrul

  • Resolution fixed deleted
  • Status changed from closed to new

comment:7 Changed 10 years ago by sadrul

  • Owner changed from elb to sadrul

At least the "at least allow the user to enter /join #channel." bit should be fixed, since that's a bug.

Rejoining an open chat room after a successful account reconnect (irrespective of whether it was disconnected manually or due to an error) sounds OK to me. Any objections?

comment:8 Changed 10 years ago by rekkanoryo

I always wondered why we didn't rejoin open chats unconditionally when it was possible to rejoin.

comment:9 Changed 10 years ago by sadrul

Looks like 957d8b98b97eb5f2d3f58208e8ad28a55f3f81b8 takes care of executing commands in a left-chat.

So, always rejoining open chats after a reconnect ... let's do it. I will try to get something going later tonight (if someone doesn't get to it by then).

charding: ... or may be you can submit a patch real quick? ;)

comment:10 Changed 10 years ago by sadrul

  • Resolution set to fixed
  • Status changed from new to closed

Changed 9 years ago by charding

Pidgin debug log

comment:11 follow-up: Changed 9 years ago by charding

This is still a problem in 2.7.0

At 9:14:24 I am doing a manual '/join #pidgin' before disconnecting (9:14:46) and reconnecting (9:15:18).

See attached debug log above. Let me know if you need any other info.

comment:12 in reply to: ↑ 11 Changed 9 years ago by darkrain42

Replying to charding:

This is still a problem in 2.7.0

At 9:14:24 I am doing a manual '/join #pidgin' before disconnecting (9:14:46) and reconnecting (9:15:18).

See attached debug log above. Let me know if you need any other info.

This ticket is old enough that you should file a new ticket, please.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!