Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#105 closed defect (fixed)

Annoying desktop refresh in gnome when hovering over a contact

Reported by: mirceade Owned by: seanegan
Milestone: 2.2.1 Component: pidgin (gtk)
Version: 2.0 Keywords: desktop refresh redraw
Cc:

Description

I've noticed that apps and the gnome desktop does some kind of a weird full refresh (the windows and desktop redraws) when hovering with my mouse over a contact in gaim's contact list. This is really annoying.

Change History (12)

comment:1 Changed 12 years ago by mirceade

This happens in gaim 2.0.0 beta6 on a Ubuntu Feisty beta machine (forgot to add).

comment:2 Changed 12 years ago by lschiere

  • Milestone Go public with Pidgin 2.0.0 deleted

comment:3 Changed 12 years ago by lschiere

  • Owner set to seanegan

comment:4 Changed 12 years ago by seanegan

  • Status changed from new to assigned

Can you give more information? Or be more descriptive? What X server are you running?

comment:5 Changed 12 years ago by mirceade

The X server info: Package: xorg Status: install ok installed Priority: optional Section: x11 Installed-Size: 52 Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@…> Architecture: i386 Version: 1:7.2-0ubuntu11 Provides: x-window-system, x-window-system-core Depends: xserver-xorg, libgl1-mesa-glx, libgl1-mesa-dri, libglu1-mesa, xfonts-base (>= 1:1.0.0-1), xfonts-100dpi (>= 1:1.0.0-1), xfonts-75dpi (>= 1:1.0.0-1), xfonts-scalable (>= 1:1.0.0-1), xbase-clients (>= 1:1.0.1-1), xutils (>= 1:1.0.1-1), xkb-data, xterm | x-terminal-emulator Description: X.Org X Window System

fglrxinfo display: :0.0 screen: 0 OpenGL vendor string: ATI Technologies Inc. OpenGL renderer string: RADEON 9550/X1050 Series OpenGL version string: 2.0.6334 (8.34.8)

HOW TO REPRODUCE:

  1. Run glxgears (or any open gl based game).
  2. Hover over an unconnected contact in the contact list.

The whole desktop and the windows will refresh.

comment:6 Changed 12 years ago by mirceade

After further investigation I've noticed that this happens only if I MANUALLY ASSIGNED an avatar photo to that contact that I am currently hovering over. And this seems to be UNRELATED TO WHETHER I'M RUNNING AN OPEN-GL APP or not.

comment:7 Changed 12 years ago by seanegan

I cannot reproduce this to save my life. Are the custom icons you're setting really, really, huge? Larger than your screen resolution? That would make sense.

comment:8 Changed 12 years ago by mirceade

Well, you're on to something... Screen res: 1280x1024 px Image size: Width: 1280 pixels Height: 960 pixels

Thanks for reading my report. Does this still qualify as a bug? I guess gaim should resize the avatar image correctly just as it does in the conversation window.

comment:9 Changed 12 years ago by mirceade

I mean users are just used to drag some photo they've taken and drop it over an avatar... Anyway, gaim, pidgin or whatever really, really rulz.

comment:10 Changed 12 years ago by mirceade

I see that the conversation window allows in some cases big, really big avatar images. If you don't pay attention they might fill up the screen. So this is my conclusion:

The avatar images should be limited (rescaled) in both the contacts list tool tip and in the conversation window. While this is a great feature (I've always hated y!messenger for limiting the size of avatar pictures) I strongly believe the avatar pictures SHOULD NEVER TAKE OVER THE WHOLE SCREEN AREA.

P.S.: Excuse me for being so verbose but I'm trying to make the most of wasting a pidgin developer's time. :=)

comment:11 Changed 12 years ago by seanegan

  • Milestone set to 2.2.1
  • Resolution set to fixed
  • Status changed from assigned to closed

comment:12 Changed 12 years ago by seanegan@…

(In 9521cfad2bc3a5d2f6a20e537b9f962df6c4e5da) Make 200px the upper-bound for buddy icons. Prevents problems when people try using their 7megapixel digital camera images as custom icons. Fixes #105

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!