Opened 10 years ago

Closed 9 years ago

#10520 closed defect

Cannot Paste a 2nd URL from Web Browser

Reported by: Offlein Owned by: rekkanoryo
Milestone: Component: pidgin (gtk)
Version: 2.6.2 Keywords:
Cc: vostok4, hobit, Citrus, dendron, clacke

Description

If I open up Pidgin new, have a conversation with someone, and paste a URL from my browser's location bar (noticed this using Firefox) it will paste correctly.

If I later copy another URL from the location bar, when I paste it into my Pidgin chat message the old URL appears. This is a problem if I paste and hit enter fast (...which I have learned not to do).

If I right-click the text area and choose "Paste as Plain Text" the new (correct) URL will be pasted.

I am using Firefox 3.5, but the same problem occurs in Internet Explorer 8 as well. Interestingly, Google Chrome does not seem to give me this problem. The Operating System is Windows Vista x64 Ultimate. I do not experience this in my Ubuntu machine.

Change History (14)

comment:1 Changed 10 years ago by vostok4

Same thing happens to me in 2.6.2, Win7 x64, and I can confirm that Google Chrome works fine whereas FF3.5 breaks.

comment:2 Changed 10 years ago by hobit

I wanted to bypass this issue by changing the default keybinding of Ctrl-V in my .gtkrc from "paste" to "paste as plain text", but I can not find out how. Is it possible? How?

comment:3 Changed 10 years ago by deryni

Unfortunately, I don't believe you can do that. If you could find a way to inspect the Windows clipboard at the time this works and when it fails that might be helpful in terms of figuring out what is going on (unfortunately I'm not aware of any good ways to do that offhand).

comment:4 Changed 9 years ago by hobit

I can't inspect the clipboard, but I believe that the problem happens only with addressed copied from address bar of browsers (not text from the body of the page) - even parts of them - and text from Lotus Notes. No problems with plain text or MS Word. Affects more versions of pidgin (possibly all) including the 2.6.3. May be specific to Windows (or not, I can't tell)

comment:5 Changed 9 years ago by Citrus

This seems to me to be a gtk-related issue, where it's not playing 100% nicely with the windows clipboard. I'm currently using 2.6.3 on Windows Vista.

This was not an issue in 2.5.4 .

  • This only happens when copying/pasting URLs.
  • This will happen with any valid URL, whether copied from a browser or from notepad.
  • After using "paste as plain text", the correct URL is pasted, and further attempts to use C-v paste the "correct" URL. However, the next time you copy a URL, pasting it using C-v pastes again the last URL that you successfully pasted, and not what's on the clipboard. Curiously, this happens even when you copy and paste non-URL text in between (which works fine). It's almost as if pidgin is "remembering" the last URL that you pasted, and is refusing to "forget" it, even though the clipboard data has since changed, and the only thing that flushes this memory is using "paste as plain text".
  • I've used two different clipboard viewers, and the URL on the clipboard is always plain text, and what I expect it to be. The only application that's pasting incorrectly is pidgin.

comment:6 Changed 9 years ago by dendron

I confirm this bug with Pidgin 2.6.4 on Windows 2003 Server.

comment:7 Changed 9 years ago by clacke

Confirm Pidgin 2.6.4 on Windows XP. It's not just Firefox. It's really weird.

  1. Start Pidgin
  2. Open a conversation window
  3. Start Notepad
  4. Type "mouhaha" in Notepad, select, copy
  5. Paste in conversation window. Pasted text is "mouhaha"
  6. Type "asdf" in Notepad, select, copy
  7. Pasted text is "mouhaha"!
  8. Start Google Chrome
  9. Go to any page
  10. Select the URL bar in Google Chrome, copy
  11. Paste in conversation window. Pasted text is the expected URL.
  12. Type "qwer" in Chrome URL bar, select, copy.
  13. See 7 (!)
  14. Paste as plain text. Pasted text is the expected "qwer"
  15. Paste. Pasted text is still "qwer".
  16. Go back to Chrome, type "zxcv" in URL bar, select, copy.
  17. See 15.
  18. Repeat steps 9-11. Works every time.
  19. Type whatever you like in the Chrome URL bar, select, copy.
  20. See 15.

Hope this helps shed another glimpse of light on things.

comment:8 Changed 9 years ago by clacke

Plugins: Enabled
SSL: SSL support is present.
GTK+ Runtime: 2.16.6
Glib Runtime: 2.20.5

comment:9 Changed 9 years ago by clacke

Problem solved by downgrading GTK+. Keeping my fingers crossed that neither Pidgin, Inkscape nor WireShark actually needs GTK+ 2.16.

Plugins: Enabled
SSL: SSL support is present.
GTK+ Runtime: 2.14.7
Glib Runtime: 2.18.4

comment:10 Changed 9 years ago by rossmeissl

This is still an issue

comment:11 Changed 9 years ago by darkrain42

  • Status changed from new to pending

This may be fixed in Pidgin 2.7.0 (please re-test when it is released).

comment:12 Changed 9 years ago by darkrain42

  • Component changed from unclassified to pidgin (gtk)

comment:13 Changed 9 years ago by clacke

Confirm FIXED with Pidgin 2.7.0. Great work, folks!

comment:14 Changed 9 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!