Opened 10 years ago

Closed 2 years ago

#10575 closed defect (out of date)

MSN messages failling

Reported by: Mathon Owned by: QuLogic
Milestone: Component: MSN
Version: 2.6.3 Keywords:
Cc: kastel, Piratmac, rhduncan, Surrogard, bshckd

Description (last modified by Mathon)

Sometimes some of my contacts who are using the official MSN inform me that they have to send messages to me multiple times as they get a message stating "The following message could not be delivered to all recipients:" I know of three of my contacts who reported having this problem with me.

Issue appears to be in 2.5.9 and newer

Attachments (2)

debug.log (5.4 KB) - added by Surrogard 9 years ago.
Debuglog including chatlogs from both sides
purple-debug.log (103.5 KB) - added by TechnoSwiss 8 years ago.

Download all attachments as: .zip

Change History (62)

comment:1 Changed 10 years ago by Mathon

  • Description modified (diff)

comment:2 follow-up: Changed 10 years ago by kastel

I can confirm this problem with Pidgin 2.6.3 installed through the Ubuntu PPA (Karmic).

comment:3 in reply to: ↑ 2 Changed 10 years ago by HippoGlouton

Same problem here under windows XP

comment:4 Changed 10 years ago by Mathon

Another friend of mine who switched from msn, to pidgin is having the same issue messaging me, but he reports its happening more frequently.

comment:5 Changed 10 years ago by ilNebbioso

I can confirm this issue both on Vista 64 and XP 32 since 2.6.2 (maybe also 2.6.1). No crash are experienced, just some messages are not delivered to my Pidgin client from others Vista 64/XP 32 official MSN clients.

Please note that as messages are first delivered to me and then NOT delivered, they restart to be delivered correctly without any reason.

Please also note my messages sent to them are ALWAYS delivered to my contacts.

comment:6 Changed 10 years ago by HippoGlouton

I tested with an alternative client : emesene. And there is exactly the same problem, so it's not coming from pidgin itself (which you probably already knew).

comment:7 Changed 10 years ago by Mathon

So where is the issue coming from? I never had my friends complaining so much about failed messages...

comment:8 Changed 10 years ago by kastel

I'm using Kopete currently, and I don't have this problem anymore.

comment:9 follow-up: Changed 10 years ago by ilNebbioso

I agree with Mathon, the problem comes from PidGin? itself because using official MSN client we do not loose ANY message.

comment:10 in reply to: ↑ 9 Changed 10 years ago by HippoGlouton

Replying to ilNebbioso:

I agree with Mathon, the problem comes from PidGin? itself because using official MSN client we do not loose ANY message.

What I meant by "not pidgin itself" was "other ALTERNATIVE clients have the same problem". So it's probably a modification coming with the latest versions of MSN, of course the official one has no problem.

comment:11 Changed 10 years ago by HippoGlouton

Oh, and I ticked the box "Use HTTP protocol" in my account settings as it was the only way to connect from work. Did you all tick this box ? Or is it unrelated ?

comment:12 Changed 10 years ago by Mathon

By default the box "Use HTTP Method" is selected but i don't see an option for "Use HTTP protocol"

comment:13 Changed 10 years ago by ilNebbioso

Account > MSN account > modify/edit > Advanced Here testing with suggested setting.

comment:14 Changed 10 years ago by Mathon

Yes, i looked there and it states "Use HTTP Method" which for me was on by default... Are you suggesting trying to use it without it ticked?

comment:15 Changed 10 years ago by ilNebbioso

Mathon, HippoGlouton? asked if it is related to that option. So, today I tried turning it off. I'll surely tell my opinion during next days. Until now no problems found (but I used for just a little bit MSN today).

comment:16 Changed 9 years ago by darkfly

I can also confirm this. I don't use msn that much, but when I do talk to people that are not using Pidgin, they will get that error and I won't see anything. However Pidgin to Pidgin seems fine.

comment:17 Changed 9 years ago by darkfly

*Edit I ment to add I'm running Windows 7 64 Bit, if thats of any help.

comment:18 Changed 9 years ago by TechnoSwiss

I've been having this problem since 2.6.1 as well (just tried 2.6.4) running on XP fully patched. All of my contacts are running the MSN client.

comment:19 Changed 9 years ago by Mathon

Just wanted to add i tried another client meebo, and offical msn, both DO NOT have issues. Only issues seem to be in pidgin. Running latest build of pidgin

comment:20 Changed 9 years ago by TechnoSwiss

Just tried 2.6.6 and still getting the "The following message could not be delivered to all recipients:" error when people try to message me over MSN.

Going back to a pre-2.6.1 version. :(

comment:21 Changed 9 years ago by Mathon

So no problems in 2.6.1 if so im changing to that version.

comment:22 Changed 9 years ago by TechnoSwiss

2.6.1 is the version where I started having the problem. 2.5.8 is the latest version I have a copy of that works.

comment:23 Changed 9 years ago by Mathon

can you upload it, i cant seem to find a copy of it.

Can the dev's look into this issue, there seems to be quite a few with this issue.

comment:25 Changed 9 years ago by Mathon

After a two days of testing it seems "Pidgin 2.5.8" has no problems and all messages go threw...

comment:26 in reply to: ↑ description Changed 9 years ago by Mathon

  • Description modified (diff)
  • Milestone set to 2.7.0

Replying to Mathon:

Sometimes some of my contacts who are using the official MSN inform me that they have to send messages to me multiple times as they get a message stating "The following message could not be delivered to all recipients:" I know of three of my contacts who reported having this problem with me.

Issue appears to be in 2.6.2 and 2.6.3

comment:27 Changed 9 years ago by Mathon

Just wanted to update, after a week of using Pidgin 2.5.8 no messages fail... if i use 2.6.2 or newer quite often messages fail

comment:28 Changed 9 years ago by darkrain42

  • Milestone 2.7.0 deleted
  • Owner changed from khc to QuLogic

Don't adjust the Milestone, please.

comment:29 follow-up: Changed 9 years ago by kastel

For some months pidgin seemed to work, but today (for the first time) I had incoming messages failing, pidgin-to-pidgin, linux-to-win. Version is 2.6.6 for both.

comment:30 in reply to: ↑ 29 ; follow-up: Changed 9 years ago by kastel

I'm sorry. Forgot to add that I was using an HTTP connection.

Replying to kastel:

For some months pidgin seemed to work, but today (for the first time) I had incoming messages failing, pidgin-to-pidgin, linux-to-win. Version is 2.6.6 for both.

comment:31 in reply to: ↑ 30 Changed 9 years ago by vbap

I am using Pidgin 2.6.6 on Windows 7 Experience the same behaviour as documented here (MSN users report getting "message to delivered to all recipients" - happening on around 1 in 5 messages sent)

Was using HTTP method (no proxy)

after unchecking HTTP method, tested with one MSN buddy and there were no more undelivered messages (over about 100 msgs sent).

Hope this helps

comment:32 Changed 9 years ago by TechnoSwiss

Good to know it looks like the problem is confined to the HTTP method.

Unfortunately for me, because of the company firewall I have to use the HTTP method.

comment:33 Changed 9 years ago by DaffyDuck

I've been seeing this with both http and the non-http method. It's unfortunately not only confined to the the http method.

I've had to go back to 2.5.7.

comment:34 Changed 9 years ago by salinasv

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.

comment:35 Changed 9 years ago by salinasv

Ticket #10642 has been marked as a duplicate of this ticket.

comment:36 Changed 9 years ago by Robby

#10642 has a debug log unless I'm mistaken.

comment:37 Changed 9 years ago by salinasv

I can't find anything there in a quick view. I would like to get some other more useful log.

comment:38 Changed 9 years ago by DaffyDuck

Did anyone simply try to diff 2.5.8 (which appears to be the last version without the problem(?)) with the version following it, to see what changes were made to the MSN plugin? I'll be doing it myself, but I would like some 100% confirmation that the problem appeared in between 2.5.8 and the version following it. And I need to set up and figure out monotone first.

One observation which may, or may not, be interesting: The error/warning message doesn't seem to appear straight away. It takes a few messages for it to start behaving that way, but once it does, it's quite reproducible (yet, doesn't seem to appear for every message). Restarting pidgin "resets" the behavior, and it works ok for a while.

comment:39 Changed 9 years ago by Robby

DaffyDuck?, I think if you provided the debug log salinasv asked for that would more helpful. :)

comment:40 Changed 9 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:41 Changed 9 years ago by Robby

Ticket #11742 has been marked as a duplicate of this ticket.

comment:42 Changed 9 years ago by Robby

Ticket #11395 has been marked as a duplicate of this ticket.

comment:43 Changed 9 years ago by Robby

Ticket #11212 has been marked as a duplicate of this ticket.

comment:44 Changed 9 years ago by Robby

  • Status changed from closed to new

comment:45 Changed 9 years ago by Robby

Also reported in #a13908. This does seem quite common. Hopefully, someone can supply the needed debug log.

comment:46 Changed 9 years ago by DaffyDuck

I use pidgin to chat with people who aren't very understanding with regards to "Yes, I'm going to try to provoke an error, generate a debug log, so ...", and I'm guessing this is true for many others since it's taken this long time, and no debug logs have been produced.

Anyone feel like letting me add them so we can get those debug logs?

comment:47 Changed 9 years ago by Mathon

Sorry guys, just got back from vacation...

Will the log record only crashes? or other stuff aswell... cause the program is not crashing... just messages fail...

DaffyDuck?, if you would like me to test with you let me know...

comment:48 Changed 9 years ago by salinasv

The log will help us find what is going on and why the messages are being loose. They just log almost everything it's happening inside pidgin.

You can get it from Help->Debug Window or executing pidgin with the -d flag.

comment:49 Changed 9 years ago by Mathon

Just installed 2.7.1 will report if there are any issues, none noticed so far...

comment:50 Changed 9 years ago by DaffyDuck

Mathon,

Please email me at jan.m.danielsson@… (It's not my MSN address; but we'll discuss the details more in email).

comment:51 Changed 9 years ago by DaffyDuck

Sweet! It censored it. gmail.

comment:52 Changed 9 years ago by rhduncan

Any relevance to ticket #10281, where pidgin also fails to receive messages, sometimes with the remote contact getting "message could not be delivered to all recipients" errors.

I believed #10281 was slightly different due to the http proxy aspect. Perhaps both are due to a problem with the 'Use HTTP method' option, and not creation of the proxy connection. If so, they could be duplicates.

Any thoughts?

comment:53 Changed 9 years ago by Mathon

From a quick look it looks very similar, daffyduck and i are working on getting some logs...

Also on the newer versions of pidgin (currently using 2.7.1) the other user doesn't receive a message not delivered, the message is dropped with no message, thus no one knows if the message goes threw or not

comment:54 Changed 9 years ago by Surrogard

Same problem here, messages get dropped without further notice.
my side: Pidgin 2.7.3, using HTTP-method
Testpersons side: Windows Live Messenger
Have made a debug log not showing anything when these messages should arrive. I even made a dump with WireShark? which isn't showing any sign of this lost messages at all. Is the "original" MSN messenger using another Gateway?
If the WireShark?-dump is needed I'll clean it up a bit and upload it.

This bug is really annoying! I hope it can be fixed soon, it's allready in there too long ;)

Changed 9 years ago by Surrogard

Debuglog including chatlogs from both sides

comment:55 Changed 8 years ago by Yogiz

I have the same problem. The sick thing about this bug is that it happens intermittently. I tested for several minutes until I could replicate it, then it was fine again for a few minutes, then happened again and so on. I'm using Pidgin 2.73. I have several MSN accounts here and the test cases were done by communicating between two accounts on the same computer.

Test case #1

Writing user:

(07:14:03 PM) Sander: 1
(07:14:03 PM) Sander: 2
(07:14:04 PM) Sander: 3
(07:14:04 PM) Sander: 4
(07:14:05 PM) Sander: 5
(07:14:05 PM) Sander: 6
(07:14:06 PM) Sander: 7
(07:14:07 PM) Sander: 8
(07:14:07 PM) Sander: 9
(07:14:08 PM) Sander: 0

Receiving user:

(07:14:06 PM) test: 1
(07:14:07 PM) test: 1
(07:14:07 PM) test: 1
(07:14:07 PM) test: 1
(07:14:08 PM) test: 1
(07:14:08 PM) test: 1
(07:14:09 PM) test: 2
(07:14:09 PM) test: 4
--- loads of other chat that worked fine---
(07:16:51 PM) test: 6
(07:16:51 PM) test: 6
(07:16:53 PM) test: 7
(07:16:57 PM) test: 9

Test case #2

Writing user:
(07:16:49 PM) Sander: hello
(07:16:51 PM) Sander: there
(07:16:53 PM) Sander: how
(07:16:55 PM) Sander: do
(07:16:57 PM) Sander: you
(07:16:57 PM) Sander: do
(07:19:19 PM) Sander: This is an urgent message and must not get lost.

Receiving user:
[several minutes of silence after start of chat]
(07:19:21 PM) test: hello
[nothing else]

As you can see, some messages are lost, some are duplicated. Meanwhile, nothing abnormal appears in debug window.

comment:56 Changed 8 years ago by TechnoSwiss

Well, I can report that the bug is still here, and in fact has gotten worse, but I do have some more information this time.

I just installed 2.10.0 (also had tried 2.9.0 and noticed the same problem, but wasn't able at the time to spend much time futzing with it). I've got a second system on a different network now so I can try sending messages, both are running Pidgin.

Previously (prior to 2.7.11) when sending messages from the MSN client, buddies would get a "message not delivered to some recipients), as of 2.9.0 the messages just fail. The sender gets no errors that the messages are not getting through, and the receiver doesn't know any messages are getting dropped.

This only happens when I have the HTTP method selected (I have to do this in order to get around the firewall at work) if I turn this off, no problems.

I'm running 2.10.0 at work on a Windows XP box, fully patched, and 2.9.0-1.fc15 on Fedora 15 at home. I can pretty reliably get the messages to fail, by quickly sending messages to the account using HTTP method. I'll send 0-30 as individual messages as fast as I can, then send a couple of sentences, if I do it quickly messages start dropping usually by the first or second sentence (it actually looks like very short messages aren't a problem, but larger messages in quick succession do it, but I haven't tried to see how short of a message it takes). One the messages start getting dropped, everything gets dropped until I send a message FROM the account using HTTP method, then messages start flowing again.

So, I think I've got a setup now that can reliably cause the problem, if I can send some debug messages please just let me know what would be helpful.

Thanks.

comment:57 Changed 8 years ago by salinasv

Yes, please attach a debug log from the account failing. I need to see if we are getting some error from the connection.

Just to be safe, set the PURPLE_VERBOSE_DEBUG env variable.

Changed 8 years ago by TechnoSwiss

comment:58 Changed 8 years ago by TechnoSwiss

Thank you for the quick response, sorry for my delay I was out of town visiting family.

I have a verbose debug file, with 2 instances of stopped messages.

The 1st instance, the last message that came through was at 19:05:42, followed by sending the message back 'are you still there?' which re-established the connection.

The 2nd instance, the last message that came through was 19:06:13, followed by sending the message back 'are we there again?' to re-establish the connection.

One thing I noticed while trying to create this debug log, when I was trying to create the problem, I was watching the "<user> is typing..." message, and on the failing account, the message would disappear, while I was still typing on the other end, and that was it, no more messages would come through.

comment:59 Changed 8 years ago by Med

Yes, happening here on 2.10.0 as well and for god knows how long. Pleeeease fix this. It's a serious bug! Thank you

comment:60 Changed 2 years ago by dx

  • Resolution set to out of date
  • Status changed from new to closed

Closing all MSN tickets, since it has been removed in pidgin 2.12.0 after being broken for a couple of years (see http://ismsndeadyet.com/). The skypeweb plugin can be used as an alternative (yes, it supports MSN logins too)

If this issue is still present in any other protocols supported by pidgin, please leave a comment and we will reopen it.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!