Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#10633 closed defect (fixed)

ICQ Invisible mode set custom status text to "Invisible"

Reported by: marq Owned by: MarkDoliner
Milestone: 2.7.4 Component: ICQ
Version: 2.6.3 Keywords: invisible custom status ICQ SoC
Cc:

Description

As I reported on Adium Trac Invisible mode in ICQ sets custom status text to "Invisible" so all users can see I am invisible. Adium developers closed defect with a cantfix result and say it's a problem in libpurple.

Original adium trac:

http://trac.adium.im/ticket/12839

Howto:

  • Have other ICQ account online in Adium (uses libpurple)
  • Both accounts can see each other as online.
  • In Adium switch account to "Invisible" mode.
  • In go.icq.com account appears offline BUT custom status text is set to "Invisible" which is displayed next to the name in go.icq.com.
  • Any user can read this "Invisible" text at this moment, so he can realize I am invisible.

Attachments (1)

InvisibleBug.png (503.2 KB) - added by marq 9 years ago.
Graphical howto :)

Download all attachments as: .zip

Change History (14)

comment:1 Changed 10 years ago by darkrain42

  • Component changed from libpurple to ICQ
  • Keywords invisible custom added; ICQ Invisible Custom removed
  • Owner set to MarkDoliner

comment:2 Changed 10 years ago by MarkDoliner

  • Status changed from new to pending

I can't reproduce this in Pidgin 2.6.5devel trunk as of right now.

What makes you think that anyone can see that you're invisible? In Pidgin the list of users in the privacy dialog for "Allow only the users below" functions as the ICQ "visible" list. That is, anyone in that list will be able to see your status even when you're invisible. Could that be the cause of this?

Changed 9 years ago by marq

Graphical howto :)

comment:3 Changed 9 years ago by marq

  • Status changed from pending to new

Attachment (InvisibleBug?.png) added by ticket reporter.

comment:5 Changed 9 years ago by marq

I know about visibility lists and it has nothing to do with it. I installed Ubuntu on VM and Pidgin, so I made screenshots of what is it doing.

On the left there is one account (Marq) in the Pidgin on the right there is other account (marqtest) in the official ICQ client from go.icq.com.

1) first I am online (available) in both clients - everything is OK. Custom status of pidgin account says "Available".
2) then I switch to "Invisible" in Pidgin. Now that account appears offline in go.icq.com, but custom status text is changed to "Invisible". This is the point where everyone can see I am invisible by reading this text.
3) last screenshot shows how it should look. I switched to "offline" in go.icq.com and it appears as Offline in Pidgin with no custom status[[BR]]
Please check the attached screenshot.

Hope this helps. Thank You

comment:6 Changed 9 years ago by MarkDoliner

Ahhh, I see. I should have understood this based on your original description--thanks for the clarification.

We do send a slightly different series of requests than ICQ 6.5 when we go invisible. I took a stab at making us more similar to ICQ 6.5 but it didn't seem to help. I'll try to take another look at it.

Something I thought was interesting: ICQ 2003b (the newest version of ICQ that runs on Windows 2000) has this same bug.

comment:7 Changed 9 years ago by AllesMeins

As an addition. Something similar happens when you block a user. In the official ICQ-Client the blocked user sees you as "offline" but the status-text changes everytime you change your status ("Away", "Occupied", "Invisible","Availible" etc.) making it possible for the blocked user to detect that you blocked him.

comment:8 Changed 9 years ago by ivan.komarov@…

  • Resolution set to fixed
  • Status changed from new to closed

(In 021e6a7b4ba46230e93812c39268259f8c6bc7fe):
"Invisibility mode" improvements.

  1. Removed the code for setting the status message to the status name (like "Available" or "Invisible") when no message is set by user. This should fix #10633, since now no one will see our status change to "Invisible" if we go invisible with no message set.
  2. Got rid of sending superfluous packets on server.
    • There's no need to call oscar_set_extended_status() from oscar_set_status_icq(), because in all cases it has already been called before that. The only thing oscar_set_status_icq() does except setting the extended status is setting the permit/deny setting, so I renamed it accordingly.
    • No need to call oscar_set_icq_permdeny() in purple_ssi_parseerr() (it will be called in purple_ssi_parselist() anyway).
    • Combined setting the extended status and the status message (as per TODO). This should fix the problem when client like QIP see us as Invisible for some (quite long) time before we appear as Offline.

Also, I removed the code for setting the "itmsurl" status attribute, as there was no way to set this iTunes Store URL from the UI.

comment:9 Changed 9 years ago by Robby

  • Keywords ICQ SoC added

I'm adding these keywords a milestone can be assigned more easily whenever the ICQ SoC branch gets merged. :)

comment:10 Changed 9 years ago by MarkDoliner

Ticket #12320 has been marked as a duplicate of this ticket.

comment:11 Changed 9 years ago by MarkDoliner

Ticket #10967 has been marked as a duplicate of this ticket.

comment:12 Changed 9 years ago by MarkDoliner

Ticket #10075 has been marked as a duplicate of this ticket.

comment:13 Changed 9 years ago by MarkDoliner

Ticket #10916 has been marked as a duplicate of this ticket.

comment:14 Changed 9 years ago by MarkDoliner

  • Milestone set to 2.7.4
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!