Opened 8 years ago

Closed 6 years ago

#10845 closed enhancement (duplicate)

One-Windows GUI for Tiling Window Managers

Reported by: Majic Owned by: rekkanoryo
Milestone: Plugin Suggested Component: unclassified
Version: 2.6.4 Keywords: gui
Cc: Peter17

Description

Hello, I was wondering if it would be possible to have everything in one windows, much like how Gajim looks? I'd like to pretend that this request comes purely from how nice everything is organized into one window with the user list at left and the chat window at the right, but with how the current interface is, Pidgin is difficult to tile on window managers that organize windows side-by-side, maximized, in their region of space. I currently use the "awesome" window manager, and before that I was using dwm. Having one window for everything pidgin-specific would make keeping track of the application is bit easier... This sounds a bit disorganized, but I hope it would be something easily implemented if someone thinks it's a good enough idea...

Regards :>

Change History (7)

comment:1 Changed 8 years ago by rekkanoryo

  • Milestone set to Plugin Suggested

It would be possible to do so, but we have never had the desire to make it happen.

comment:2 follow-up: Changed 7 years ago by Peter17

Well, it is not only about how the window manager deals with the windows.

When you join chat rooms, they are opened in a new window. Then, if you want to hide this window, the only way is to close it, which makes you leave the chat rooms.

For people (like me) that are always connected to chat rooms, this is very annoying. This is the reason why I use Pidgin only for instant messaging with contacts. I use Konversation for IRC chat rooms and Gajim for XMPP chat rooms.

So, I always have the 3 softwares running, just because Pidgin does not allow me to hide the chat rooms window. Having a single window for the contact list + chat rooms would be a great improvement IMHO. It would allow you to hide the chat rooms with a simple click on the tray icon, as it is for Gajim.

I have made an illustration to show how it could look like (Gajim-like).

http://lesitemai.free.fr/NEW/Pidgin1b.png

comment:3 in reply to: ↑ 2 ; follow-up: Changed 7 years ago by rekkanoryo

Replying to Peter17:

So, I always have the 3 softwares running, just because Pidgin does not allow me to hide the chat rooms window. Having a single window for the contact list + chat rooms would be a great improvement IMHO. It would allow you to hide the chat rooms with a simple click on the tray icon, as it is for Gajim.


You can "hide" single chat rooms by adding them to the buddy list, right clicking on them, and marking them as "persistentm" then closing that chat. You'll remain in the room, but you can then close the conversation at will. If you do that for all your chats you should be able to simply close the tabbed window with all those chats in it.

comment:4 in reply to: ↑ 3 Changed 7 years ago by Peter17

Replying to rekkanoryo:


You can "hide" single chat rooms by adding them to the buddy list, right clicking on them, and marking them as "persistentm" then closing that chat. You'll remain in the room, but you can then close the conversation at will. If you do that for all your chats you should be able to simply close the tabbed window with all those chats in it.

Ok, thanks, I didn't know this function.

I think it is better than keeping the tabbed window opened but still less practical than having the tabs inside the main window (if I want to consult the messages in several chat rooms, I must do a double click for each of them to open them + 1 click to close them; having the tabs in the window allows to do that in 1 scroll per tab...)

comment:5 Changed 6 years ago by BW~Merlin

I believe this is the same request as 5782

comment:6 Changed 6 years ago by Peter17

BW~Merlin: I agree. I didn't know the other report. Thanks for signaling.

comment:7 Changed 6 years ago by salinasv

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #5782.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!