Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#10967 closed defect (fixed)

Simply INCORRECT invisibility settings for ICQ

Reported by: randomperson Owned by: MarkDoliner
Milestone: 2.7.4 Component: ICQ
Version: 2.6.4 Keywords: visible invisible icq list ICQ SoC
Cc:

Description (last modified by randomperson)

This is NOT a copy of ticket #466, that one speaks only of a single issue with invisibility.

The whole ICQ invisibility settings for pigdin are wrong.

Pigdin differs people to "blocked" and "unblocked", but this is not enough for icq. Now when someone using pigdin sets someone "unblocked", he sees you even thought you are in invisible mode

But ICQ differs people to 4 kind of users

"regular users"- users that see you when you are online, don't see you when you are invisible

"always visible to users"-users that see you when you are online AND when you are invisible ...this is equivalent of "unblocked" in pigdin

"always invisible to users"- users who don't see you neither when you are just online, NOR when you are invisible

"ignore list"- users who don't see you neither when you are just online, NOR when you are invisible, NOR can send messages to you (messages will get blocked) ..this is i guess equivalent of "blocked" in pigdin

-- pigdin simply does not have normal users group. people who would see you when you are visible and don't see you when you are invisible. you have to MANUALLY remove "Blocked" icon everytime you want to come back from "invisible mode" otherwise you won't be receiving ANY messages from them!

this is absolute mess and unacceptable

Change History (12)

comment:1 Changed 10 years ago by randomperson

  • Description modified (diff)

comment:2 Changed 10 years ago by randomperson

  • Description modified (diff)

comment:3 Changed 10 years ago by randomperson

  • Description modified (diff)

comment:4 Changed 10 years ago by randomperson

  • Description modified (diff)

comment:5 Changed 9 years ago by MarkDoliner

  • Keywords ICQ SoC added
  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #10633.
The ability to add buddies to your visible and invisible lists has been added in a branch, and will be merged into trunk sometime in the next few months. I'm gonna mark this as a duplicate of 10633 and close this for now.

comment:6 Changed 9 years ago by MarkDoliner

  • Resolution duplicate deleted
  • Status changed from closed to new

Oh, this isn't really a duplicate of #10633 (the rest of my comment is still true). You may also be interested in this blog post, by the author of the changes: http://dfyz.livejournal.com/142411.html

comment:7 Changed 9 years ago by MarkDoliner

  • Resolution set to fixed
  • Status changed from new to closed

Will hopefully be released sometime in the next few months. It will be mentioned in the ChangeLog when it is.

comment:8 Changed 9 years ago by MarkDoliner

Ticket #10916 has been marked as a duplicate of this ticket.

comment:9 Changed 9 years ago by MarkDoliner

Ticket #12320 has been marked as a duplicate of this ticket.

comment:10 Changed 9 years ago by MarkDoliner

Ticket #10075 has been marked as a duplicate of this ticket.

comment:11 Changed 9 years ago by randomperson

great, thanks

i shall install pidgin back when it's out!

comment:12 Changed 9 years ago by MarkDoliner

  • Milestone set to 2.7.4
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!