Opened 9 years ago

Last modified 5 years ago

#10998 new defect

Pidgin gets temporary authentication failure when connecting to hyves.nl

Reported by: hanshom Owned by: deryni
Milestone: Component: XMPP
Version: 2.6.4 Keywords: xmpp authentication failure hyves kwekker
Cc: clickwir

Description

When connecting to chat service "kwekker" of hyves.nl I get message message "temporary authentication failure". It works with the proprietary IM (ofcourse) but also with PSI and Miranda. Cause I prefer Pidgin as it works very nice with other IM services, I'm keen on getting this issue solved. I'd appreciate help, debug log is attached.

Attachments (3)

purple-debug.log (2.9 KB) - added by hanshom 9 years ago.
psi-hyves-logon.txt (2.6 KB) - added by hanshom 9 years ago.
with-ip.log (3.1 KB) - added by hanshom 9 years ago.
Requested debug with IP instead of name of connect server

Download all attachments as: .zip

Change History (25)

Changed 9 years ago by hanshom

comment:1 Changed 9 years ago by hanshom

Please not a similar problem with adagium: http://trac.adium.im/ticket/10265

It states in the problem closing message: "Restored libpurple_jabber_use_builtin_digestmd5 patch, which was used in adium 1.2.x and removed in 1.3svn. It's still needed to be able to connect to certain old servers, as cyrus-sasl's digest-md5 doesn't agree with them, and I'd rather us just work than try to convince network admins to upgrade their jabber servers given that that the workaround does quite well."

Can such a solution be applied for pidgin as well ??

comment:2 Changed 9 years ago by deryni

  • Status changed from new to pending

Do you have a connect server specified for this account? Can you get the digest-md5 traffic from a current fixed version of adium and/or one of the other clients that works?

Is this still happening with pidgin 2.6.6?

Changed 9 years ago by hanshom

comment:3 Changed 9 years ago by hanshom

  • Status changed from pending to new

Attachment (psi-hyves-logon.txt) added by ticket reporter.

comment:5 Changed 9 years ago by hanshom

  1. The connect server is specified
  2. I cannot provide Adium info as that one is mac-only as far as I can see
  3. I have attached first part of xml log of PSI v0.13, having a succesfull logon

Hope this is helpful. It is still happening in pidgin 2.6.6

comment:6 follow-up: Changed 9 years ago by deryni

  • Status changed from new to pending

What connect server do you have specified? Do you need the connect server manually specified to connect? Do things work if you remove the connect server?

comment:7 in reply to: ↑ 6 Changed 9 years ago by hanshom

  • Status changed from pending to new

I have specified "chatslave.hyves.org". Without this an error message states the dutch equivalent for "unable to connect". This is expected behaviour as the domain of my account is "hyves.nl". Other: non-ssl, non-legacyssl,port 5222. accept plain text auth.

comment:8 Changed 9 years ago by deryni

  • Status changed from new to pending

If you specify the IP address of 'chatslave.hyves.org' in the connect server field does pidgin connect correctly?

comment:9 Changed 9 years ago by hanshom

  • Status changed from pending to new

OK, tried 94.100.119.196, but alas with the same result: temp auth failure. I think that it is the general name/address of a load-balanced serverpark. However I don't see why this would impact the application level handshake / authentication.

comment:10 Changed 9 years ago by deryni

  • Status changed from new to pending

Can you get the debug window output of the connection attempt with the IP connect server? And it will affect things since pidgin was including the connect server in one of the auth fields in the digest-md5 calculations (while psi was using the jid domain). I was hoping that was the problem and that pidgin would not use an IP there and so fall back to the jid domain and "fix" things.

Changed 9 years ago by hanshom

Requested debug with IP instead of name of connect server

comment:11 Changed 9 years ago by hanshom

  • Status changed from pending to new

Attachment (with-ip.log) added by ticket reporter.

comment:13 Changed 9 years ago by hanshom

Sorry, uploaded the file twice by mistake, but can't remove the second one anymore. Please ignore one of them ;-)

comment:14 Changed 9 years ago by deryni

  • Status changed from new to pending

I see only two differences between that new output and the psi output and I cannot possibly imagine how either of them could be the cause of the problem (well I can, but only if the server was really really broken). I don't suppose you have any contact with the administrators of the server and can ask them if there are any helpful/interesting server logs generated when you try to log in which might shed some light on the situation here?

For the record the differences are in the order of the key/value pairs in the digest message and that pidgin sends an extra "maxbuf=4096" pair.

comment:15 Changed 9 years ago by hanshom

  • Status changed from pending to new

I can't understand either why the order of the arguments or a double parameter would make a difference. Indeed I do not have contact with the administrator(s), but I've send a kind request to support explaining this issue in detail. I hope it will catch their interest. I'll keep you posted.

comment:16 Changed 9 years ago by deryni

Neither should be cause for this to happen, but they appear to be problematic. In a quick test pidgin built with the internal mechanisms seemed to work, unfortunately I didn't think to check if only one or both of the differences was missing.

comment:17 Changed 9 years ago by darkrain42

  • Cc darkrain42 added

comment:18 Changed 9 years ago by darkrain42

For reference (so I don't have to keep decoding it):

Psi:

username="hanshom",realm="hyves.nl",nonce="864cae1a51a0d0ac867d35702e70a21b",cnonce="8iRegW+sKbed3Nma9iMCSSP9WZBWbHhfIzBALVLU0aw=",nc=00000001,digest-uri="xmpp/hyves.nl",qop=auth,response=3be60f2710be7188e0a780b436556f9f,charset=utf-8

Pidgin w/ cyrus (not working):

username="hanshom",realm="hyves.nl",nonce="5e7213d8ff3a5c94093fc09a2c510d05",cnonce="Ngl7VxNwaUoYFmg8E0BdMyNIV2BcPA8vagRCVDYNeXU=",nc=00000001,qop=auth,maxbuf=4096,digest-uri="xmpp/hyves.nl",response=7f7649f94f50268348ab93463ba5853a,charset=utf-8

Pidgin w/o cyrus (working):

username="deryni",realm="hyves.nl",nonce="86204f5aa6ba6a9d38b1ec162ffc6f44",cnonce="74c84e6e12682911987f156d40",nc=00000001,qop=auth,digest-uri="xmpp/hyves.nl",response=feda6f8d7098660c7843527c2389bfd6,charset=utf-8 

Pidgin w/o cyrus (modified, but still working -- AFAICT this is exactly the same as the Cyrus response):

username="deryni",realm="hyves.nl",nonce="566f3a45c3194cc0a15443a63c8b5304",cnonce="29df03bd1268291483e55a0ab9",nc=00000001,qop=auth,maxbuf=4096,digest-uri="xmpp/hyves.nl",response=96ab69524b2e217e26bb59db8ba91e99,charset=utf-8

comment:19 Changed 9 years ago by darkrain42

Deryni, I tested the order modification as well as compiling in cyrus sasl, and I was able to log in under all conditions.

hanshom, do you have any exotic (non-ASCII) characters in your password?

comment:20 Changed 9 years ago by hanshom

darkrain42, This password contains uppercase/lowercase and digits only, so nothing exotic. Did you test with the "with-ip.log" instead of the the "purple-debug.log" ? The purple one cannot work anymore as the password did change meanwhile, so please use the with-ip one.

comment:21 Changed 9 years ago by darkrain42

I was testing with a test account deryni set up.

comment:22 Changed 9 years ago by hanshom

Hyves support reacted. They did not send me any log (yet) but did have interesting info.

One of them uses pidgin 2.6.2 with success. Two minor differences in settings (apart from user/password): server by ip-address and resource. So I tested with those again without succes.

The first difference is version. I detected the problem using 2.6.4 and kept in after upgrading to 2.6.6. It works using 2.6.2. Second difference may be the language. Mine is dutch and the info I received suggested their version is English. However I assume language is isolated from the protocol handshake ;-)

The similar problem with adium (see previous comment) is related to version, see http://trac.adium.im/ticket/10265.

comment:23 Changed 9 years ago by hanshom

I have a working setup now.

Hyves support reacted with: "we upgraded our 2.6.2 to 2.6.6 and it still works with our settings".

So I fiddled around with settings, even accounts, without result.

After that I downgraded to 2.6.2 without result. I upgraded again tot 2.6.6 and I got different behaviour when addressing the server with ip-address or dns name. Using IP-address works.

I hope this info is usefull to you.

As for me, I thank you very much for your efforts in trying to help me. I consider this as a rare incident where software versions and specific sever requirements cross over wrong. Your feedback helped me to get things back on track.

Regards, Hans

comment:24 Changed 5 years ago by clickwir

4 years since an update on this ticket, guess not many people are having issues with this then. Well I am, kinda.

Windows 7 Pro 32bit. Pidgin 2.10.7 fails to connect. If I simply install 2.10.6 right over it, it connects fine. I believe the XMPP server is an IceWarp? server. I fought with 2.10.7 and tried dozens of different settings and made no progress.

Other people in the office kept saying "Just use PSI, it's so much easier and just works!". I was 1 step away from switching to it, but I like Pidgin and installed the older version, now it connects and seems to be working fine.

I'd like to be able to know I can use newer versions as they come out, but I'm worried I'll be stuck on an old version of Pidgin or have to move to something else.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!