Opened 9 years ago

Closed 9 years ago

#11068 closed defect (duplicate)

Pidgin crash while i get a message from someone "offline" / invisible

Reported by: Kakarott Owned by: MarkDoliner
Milestone: Component: AIM
Version: 2.6.5 Keywords:
Cc: hoffie

Description

My Pidgin crashed because of someone who wrote me a message while he was showed as "offline".

Attachments (4)

pidgin_crash (12.3 KB) - added by Kakarott 9 years ago.
gdb-pidgin.txt (13.7 KB) - added by hoffie 9 years ago.
Backtrace from Kubuntu Karmic, Pidgin 2.6.6-1~getdeb2
debug.log (443.5 KB) - added by dj_zx 9 years ago.
pidgin.RPT (5.2 KB) - added by dj_zx 9 years ago.

Download all attachments as: .zip

Change History (16)

Changed 9 years ago by Kakarott

comment:1 Changed 9 years ago by QuLogic

  • Component changed from unclassified to AIM
  • Owner changed from rekkanoryo to MarkDoliner

comment:2 follow-up: Changed 9 years ago by MarkDoliner

  • Status changed from new to pending

Hmm, there may be some memory corruption in this backtrace. In step #4 name is NULL, but in step #3 the second argument to purple_normalize is something other than NULL.

Kakarott: Does this happen a lot for you? Are you able to reproduce this problem reliably?

comment:3 in reply to: ↑ 2 Changed 9 years ago by Kakarott

  • Status changed from pending to new

Replying to MarkDoliner:

Hmm, there may be some memory corruption in this backtrace. In step #4 name is NULL, but in step #3 the second argument to purple_normalize is something other than NULL.

Kakarott: Does this happen a lot for you? Are you able to reproduce this problem reliably?

Not a lot because a told my friends that they please should not do that with me. And yes, i am able to reproduce -- even with version 2.6.5 -- so it did not change with that version. (Should i change the version in this ticket to 2.6.5 ?)

comment:4 follow-up: Changed 9 years ago by MarkDoliner

  • Version changed from 2.6.4 to 2.6.5

Yeah, I'll change the version. It's nice to have the version number in the ticket point to the most recent version of Pidgin which exhibits the crash.

I realized that I think bug #11239 is a duplicate of this one. And they both might be related to #10833.

I'm wondering if non-English characters somehow contribute to the crash... do you know if the messages that people sent to you contained non-English or non-ASCII characters? Like characters with accent marks, or characters in a non-English alphabet?

comment:5 in reply to: ↑ 4 Changed 9 years ago by Kakarott

Replying to MarkDoliner:

Yeah, I'll change the version. It's nice to have the version number in the ticket point to the most recent version of Pidgin which exhibits the crash.

I realized that I think bug #11239 is a duplicate of this one. And they both might be related to #10833.

I'm wondering if non-English characters somehow contribute to the crash... do you know if the messages that people sent to you contained non-English or non-ASCII characters? Like characters with accent marks, or characters in a non-English alphabet?

Invisible only is not bad for me. Just in combination with when he is shown as offline. The "someone is typing..." message comes without problems. And a message i received was: "der fehler ist so geil " and another one: "sprich ich bin unter ubuntu (pidgin) invisible" I don't see any non-english or non_ascii characters in it.

I crashed myself with 2 pidgin instances and 2 icq numbers. So maybe you could try that to see it for yourself.

comment:6 Changed 9 years ago by Kakarott

Oh,

I just found something out:

1) it don't appear with yahoo!

2) if I get a fresh message pidgin does not crash. I need to write something back. And if I get back something then - pidgin crashes ...

Just to mention ...

comment:7 Changed 9 years ago by MarkDoliner

Ticket #11406 has been marked as a duplicate of this ticket.

comment:8 follow-up: Changed 9 years ago by MarkDoliner

I'm still unable to reproduce this. If you have exact steps to reproduce the problem I suspect I would be able to fix it. Short of that, a new backtrace might help (but if the crash is due to memory corruption then it might be hard to get a good backtrace).

comment:9 in reply to: ↑ 8 Changed 9 years ago by hoffie

I am able to reproduce the problem as well.

Replying to MarkDoliner:

I'm still unable to reproduce this. If you have exact steps to reproduce the problem I suspect I would be able to fix it. Short of that, a new backtrace might help (but if the crash is due to memory corruption then it might be hard to get a good backtrace).

Well, I don't know, if it reproduces the problem for you, but that's exactly what I did:

My chat partner's setup: Kubuntu Karmic 64bit, Kubuntu's Pidgin 2.6.6 (libpurple 2.6.6) My setup: Gentoo 64bit, Pidgin 2.6.6 (libpurple 2.6.6), but that shouldn't matter

  1. I am invisible, my chat partner changes his status from offline to online
  2. I'm sending a message to my partner
  3. The partner replies
  4. I send yet another message
  5. My partner's pidgin instance has crashed

So.. the problem happens on my chat partner's machine, on mine it is not reproducible (might be related to the Ubuntu built or specific pidgin settings). I'll upload a complete backtrace in a minute, in the hope it will be helpful. If you need any more information, I'll happily try to provide it.

Changed 9 years ago by hoffie

Backtrace from Kubuntu Karmic, Pidgin 2.6.6-1~getdeb2

comment:10 Changed 9 years ago by rohieb

Same with me here, same backtrace. My partner was using Adium 1.3.10, I was using 2.6.6-1ubuntu3~pidgin2.09.10 from Ubuntu Karmic PPA.

I tried at least four times to reproduce the bug, and the last lines before the crash were always the following:

(01:57:33) oscar: incomingim_ch1: unknown TLV 0x0013 (len 1)
(01:57:33) oscar: Received IM from 207049xxx with 1 parts
(01:57:33) oscar: Sending buddy icon to 207049xxx (1705 bytes)
(01:57:33) oscar: Parsing IM part, charset=0x0002, charsubset=0x0000, datalen=192, choice1=UTF-16BE, choice2=UTF-8, choice3=
(01:57:33) oscar: rate change (param ID 0x0001): curavg = 4901, maxavg = 6000, alert at 2000, clear warning at 2500, limit at 1500, disconnect at 800, delta is 42932, dropping is 0 (window size = 80)
(01:57:33) oscar: icbm error: received response from request without a buddy name!
(01:57:33) oscar: Message error with data H�l$�L�d$��( and reason 4 and errcode 0

Changed 9 years ago by dj_zx

Changed 9 years ago by dj_zx

comment:11 Changed 9 years ago by dj_zx

same crash after upgrade from 2.6.6 to 2.7.0

comment:12 Changed 9 years ago by darkrain42

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #11863.
While this ticket is older, #11863 contains conversation between myself and nosnilmot about the cause of the issue (it will be fixed in 2.7.1)

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!