Opened 8 years ago

Closed 5 years ago

Last modified 17 months ago

#11075 closed enhancement (fixed)

Windows Voice and Video Support

Reported by: puzzles Owned by: datallah
Milestone: 3.0.0 Component: winpidgin (gtk)
Version: 2.6.4 Keywords: voice video windows
Cc: Maiku, BigBrownChunx, _be, bird.dandruff, Dawudd, olden, yann, frasten, Harui, haridsv, NeoJS, cordylus

Description

After lots of Googling and searching through tickets, I couldn't find any place on the web with information on the Windows port of VV. This should be a place to gather information on what needs to be done to finalize the port.

Change History (38)

comment:1 Changed 8 years ago by darkrain42

  • Cc Maiku BigBrownChunx added

comment:2 Changed 8 years ago by darkrain42

Ticket #11366 has been marked as a duplicate of this ticket.

comment:3 Changed 8 years ago by flayola32

Yeeeeaaaah...

I will like to know why there are no support of the audio and video in the Windows version of Pidgin and especially when we will have this support! =D

comment:4 Changed 8 years ago by francolo

At least, for XMPP.

comment:5 Changed 8 years ago by james.bromberger

This would be really useful to get sorted for XMPP on Windows. Would tie in nicely to Ignite's Openfire IM server with video... (random (registered) viewers of this bug, please vote for it with the up arrow above).

comment:6 Changed 8 years ago by BigBrownChunx

comment:7 Changed 8 years ago by mam_boc

No! Not for the normal and stable version!

comment:8 Changed 8 years ago by bird.dandruff

I think VV support for XMMP in Windows would be absolutely sufficient as a first step. VV support for other protocols could be added later..

comment:9 Changed 8 years ago by schwalalalalala

Where are we in the integration of the videoconference under Windows?

comment:10 Changed 8 years ago by golane

Yes! XMPP for the Windows version!

comment:11 Changed 7 years ago by yann

Dear all, I just tested Pidgin on Windows Vista : I found no options for webcam/audio calls, even with XMPP.

I understood that VV is in development, and I am willing to help by testing and reporting bugs. Is there a Pidgin wiki page explaining how to instal this unstable vv-version ?

comment:12 Changed 7 years ago by Harui

2.7.2 is out - any change for Video support under windows?

Thanks for your feedback!

comment:13 Changed 7 years ago by datallah

  • Milestone set to Patches welcome

If there is any progress, this ticket will be updated accordingly.

Nobody is actively working on this - if anyone is interested in making it happen, patches are always welcome.

comment:14 Changed 7 years ago by ao2

Hi, it looks like farsight and gstreamer now work fine under windows: http://sourceforge.net/mailarchive/forum.php?thread_name=4B674CC7.1050708%40collabora.co.uk&forum_name=farsight-devel

Regards,

Antonio

comment:15 Changed 7 years ago by ThePianoGuy

We put up SVN repository for the hacking weekend in Slovenia for pidgin vv windows at http://jekovec.net/svn/pidgin

Basically, the 3 commits contain the missing Makefile.mingw for gstreamer and farsight to compile with and link. Unfortunately, when you make a call, vv doesn't work (error in xmpp console). We didn't have time to track this out.

comment:16 Changed 7 years ago by johnzooi

Any news? I would really like Voice in the windows version!

comment:17 Changed 7 years ago by salinasv

  • Type changed from defect to enhancement

comment:18 Changed 7 years ago by fahhem

I'm pretty close on this, but I need some finalization help. http://fahhem.com/pidgin/

If anybody can help me debug that error, email me!

comment:19 follow-up: Changed 6 years ago by BW~Merlin

Duplicate of 9736 but I would love to see this implemented.

comment:20 in reply to: ↑ 19 Changed 6 years ago by mcepl

Replying to BW~Merlin:

Duplicate of 9736 but I would love to see this implemented.

No, it isn't ... this is for a general support of VV on Windows for all protocols, the other bug is for just for MSN protocol on any platform.

comment:21 Changed 5 years ago by nalkmd

Yes PLEASE PLEASE PLEASE make this. Also lets add some voip securety.

ZRTP is an excellent option. ZORG have an open encryption engine that could be used to speed up the process. http://www.zrtp.org/

Last edited 5 years ago by nalkmd (previous) (diff)

comment:22 Changed 5 years ago by datallah

Ticket #15339 has been marked as a duplicate of this ticket.

comment:23 Changed 5 years ago by Tomasz Wasilczyk <tomkiewicz@…>

(In [b6c9e5dd95d1]):
VV: win32 support. No runtimes dependencies in dep-bundle yet. Refs #11075

comment:24 Changed 5 years ago by tomkiewicz

  • Milestone changed from Patches welcome to 3.0.0
  • Resolution set to fixed
  • Status changed from new to closed

comment:25 Changed 5 years ago by rubo77

Great! fixed, does it mean, that there is already a beta- or pre-alpha-version to test voice chat on windows?

comment:26 Changed 5 years ago by rekkanoryo

No. It means that when we decide to release 3.0.0 it will include voice and video support.

comment:27 Changed 5 years ago by Robby

That said, there will probably be a beta but Pidgin 3 isn't ready for that yet.

You can compile the code yourself for testing purposes and at your own risk.

comment:28 follow-up: Changed 5 years ago by rubo77

so If I would compile pidgin for Windows on my own risk with these instructions: https://developer.pidgin.im/wiki/BuildingWinPidgin I could test voice chat with other users that use the stable release on Linux?

And if so, maybe someone has compiled this already for windows and will give me the compiled test-version? ;)

comment:29 Changed 5 years ago by Robby

I am not sure, I'm not a Pidgin user at all so I haven't compiled the code myself.

comment:30 in reply to: ↑ 28 Changed 4 years ago by lameventanas

Replying to rubo77:

so If I would compile pidgin for Windows on my own risk with these instructions: https://developer.pidgin.im/wiki/BuildingWinPidgin I could test voice chat with other users that use the stable release on Linux?

And if so, maybe someone has compiled this already for windows and will give me the compiled test-version? ;)

The build I made didn't work, it doesn't even start. I will try another build when I have some free time.

Last edited 4 years ago by lameventanas (previous) (diff)

comment:31 Changed 4 years ago by imsys

Hey, the current dev, Tomasz Wasilczyk, made a build with video support. :) https://blog.wasilczyk.pl/en/2013/pidgin-with-video-finally-for-windows/

You can download the binaries here: https://dl.dropboxusercontent.com/u/5448886/pidgin-builds/pidgin-vv-d44a3e57992c.exe

The problem is that the OTR plugin do not work on that version, but I think Tomasz's next build will include OTR and video support. :)

Last edited 4 years ago by imsys (previous) (diff)

comment:32 follow-up: Changed 4 years ago by rubo77

shouldn't this be reopened then?

Or as an alternative, you can use Jitsi , which supports OTR on video and voice chat over jabber already on all devices (apart from iOS by now)

comment:33 in reply to: ↑ 32 Changed 4 years ago by tomkiewicz

Replying to rubo77:

shouldn't this be reopened then?

Because of missing OTR? No - it's absolutely not related to Voice and Video. There is a separate ticket for that: #15513.

comment:34 Changed 4 years ago by bird.dandruff

to avoid confusion: encryption of video/audio-stream would be implemented with ZRTP, and there is already a feature request: #11221 (OTR is for text encryption only)

comment:35 Changed 3 years ago by psuter

Could someone please update the FAQ When will voice and video be implemented on Windows? It still says:

The Pidgin build process needs to be updated appropriately to enable the functionality. Patches to make this happen are welcome.

If I understand correctly this was finished in comment:23, and the new status is that this feature is ready and waiting for release 3. Any idea when that will be?

Thanks.

comment:36 Changed 3 years ago by tomkiewicz

This turned out not to be stable enough to treat as "ready". It seems to be a problem with gst 0.10 win32 build. I put a lot of effort in win32 gst 1.x build (and webkitgtk 2.x) maybe three months ago, but it's not ready yet.

comment:37 Changed 3 years ago by psuter

Too bad. Thanks for the effort. Is there an upstream ticket? Should this ticket be reopened?

comment:38 Changed 17 months ago by cordylus

Any updates on this? What is the current status? Thanks.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!