Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11239 closed defect

Segmentation fault liboscar.so.0

Reported by: Nekroman Owned by: MarkDoliner
Milestone: Component: ICQ
Version: 2.6.4 Keywords: segfault, liboscar, icq, crash
Cc:

Description (last modified by Nekroman)

If someone write me, pidgin will crash with segmentation fault. Not always but often. gdb output:

Program received signal SIGSEGV, Segmentation fault.
0xb660f3b9 in ?? () from /usr/lib/purple-2/liboscar.so.0
(gdb) bt full
#0  0xb660f3b9 in ?? () from /usr/lib/purple-2/liboscar.so.0
No symbol table info available.
#1  0xb66059e4 in ?? () from /usr/lib/purple-2/liboscar.so.0
No symbol table info available.
#2  0xb66047d8 in ?? () from /usr/lib/purple-2/liboscar.so.0
No symbol table info available.
#3  0x080af733 in ?? ()
No symbol table info available.
#4  0xb780e48b in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#5  0xb77d7b38 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
No symbol table info available.
#6  0xb77db3d0 in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#7  0xb77db83f in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#8  0xb7ad6f09 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#9  0x080c9f6a in main ()
No symbol table info available.

edit: I found that if a man is invisible and he write me and I write to him too, pidgin will crash. (sorry for bad english) I've attached file with complete output from gdb

Attachments (2)

output.txt (31.6 KB) - added by Nekroman 9 years ago.
Complete output
output2.txt (4.5 KB) - added by Nekroman 9 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 9 years ago by datallah

  • Status changed from new to pending

Please follow the instructions to get a backtrace and attach it to this ticket.
Without debug symbols, there isn't a lot we can do.

Changed 9 years ago by Nekroman

Complete output

comment:2 Changed 9 years ago by Nekroman

  • Status changed from pending to new

Attachment (output.txt) added by ticket reporter.

comment:4 Changed 9 years ago by Nekroman

  • Description modified (diff)

comment:5 Changed 9 years ago by Nekroman

  • Description modified (diff)

Changed 9 years ago by Nekroman

comment:6 Changed 9 years ago by datallah

  • Status changed from new to pending

Please follow the instructions to get a backtrace and attach it to this ticket.
Your backtrace isn't useful to us unless it you have debug symbols installed - please read the instructions for how to install them for your OS.

comment:7 Changed 9 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:8 Changed 9 years ago by MarkDoliner

FYI I wasn't able to reproduce this crash just now, testing between two ICQ accounts--the one using Meebo was invisible.

comment:9 Changed 9 years ago by MarkDoliner

This sounds like a duplicate of #11068. I'm wondering if non-ASCII characters contributes to the crash (I tested with only ASCII).

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!