Opened 9 years ago

Closed 9 years ago

#11406 closed defect (duplicate)

crash during ICQ session

Reported by: waschk Owned by: MarkDoliner
Milestone: Component: AIM
Version: 2.6.6 Keywords:
Cc:

Description

This crashdump was created by bug-buddy after the upgrade to pidgin 2.6.6 on Mandriva Cooker with gtk+ 2.19.5 and glib 2.23.3. I was contacted via ICQ, then it crashed:

Backtrace was generated from '/usr/bin/pidgin'

[Thread debugging using libthread_db enabled]
0xffffe424 in __kernel_vsyscall ()
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6d91c73 in __waitpid_nocancel () from /lib/i686/libpthread.so.0
#2  0xb6d2fb23 in IA__g_spawn_sync (working_directory=0x0, argv=0x87bfc10, 
    envp=0x0, flags=G_SPAWN_SEARCH_PATH, child_setup=0, user_data=0x0, 
    standard_output=0x0, standard_error=0x0, exit_status=0x0, error=
    0xbfc9920c) at gspawn.c:386
#3  0xb6d2fe54 in IA__g_spawn_command_line_sync (command_line=
    0xa9f32b8 "bug-buddy --appname=\"Pidgin\" --pid=10768", standard_output=
    0x0, standard_error=0x0, exit_status=0x0, error=0xbfc9920c)
    at gspawn.c:700
#4  0xb63152ec in run_bug_buddy (appname=<value optimized out>, 
    pid=<value optimized out>, minidump_path=0x0) at gnome-breakpad.cc:369
#5  0xb6315b0a in check_if_gdb () at gnome-breakpad.cc:440
#6  bugbuddy_segv_handle () at gnome-breakpad.cc:223
#7  <signal handler called>
#8  0xffffe424 in __kernel_vsyscall ()
#9  0xb6b7ca71 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#10 0xb6b7e3c2 in abort () at abort.c:92
#11 0x080c83ff in sighandler (sig=11) at gtkmain.c:192
#12 <signal handler called>
#13 0xb546cbb5 in purple_parse_msgerr (od=0xa8b8798, conn=0xa9009b8, fr=
    0xa9009f8) at oscar.c:3325
#14 0xb5462f68 in generror (bs=<value optimized out>, 
    snac=<value optimized out>, frame=<value optimized out>, 
    mod=<value optimized out>, conn=<value optimized out>, 
    od=<value optimized out>) at misc.c:121
#15 snachandler (bs=<value optimized out>, snac=<value optimized out>, 
    frame=<value optimized out>, mod=<value optimized out>, 
    conn=<value optimized out>, od=<value optimized out>) at misc.c:134
#16 0xb5461d89 in parse_snac (frame=<value optimized out>, 
    conn=<value optimized out>, od=<value optimized out>)
    at flap_connection.c:765
#17 parse_flap (frame=<value optimized out>, conn=<value optimized out>, 
    od=<value optimized out>) at flap_connection.c:851
#18 flap_connection_recv (frame=<value optimized out>, 
    conn=<value optimized out>, od=<value optimized out>)
    at flap_connection.c:986
#19 0x080acdd3 in pidgin_io_invoke (source=0x86dd850, condition=G_IO_IN, data=
    0xa8ffd48) at gtkeventloop.c:78
#20 0xb6d2d69e in g_io_unix_dispatch (source=0xa8e7bb0, callback=
    0x80acd90 <pidgin_io_invoke>, user_data=0xa8ffd48) at giounix.c:162
#21 0xb6cf0d7e in g_main_dispatch (context=<value optimized out>)
    at gmain.c:1960
#22 IA__g_main_context_dispatch (context=<value optimized out>)
    at gmain.c:2513
#23 0xb6cf4a88 in g_main_context_iterate (context=0x83835f8, 
    block=<value optimized out>, dispatch=1, self=0x837d008) at gmain.c:2591
#24 0xb6cf4fb7 in IA__g_main_loop_run (loop=0xa8b9788) at gmain.c:2799
#25 0xb73c26b9 in IA__gtk_main () at gtkmain.c:1219
#26 0x080c7f09 in main (argc=1, argv=0xbfc9c274) at gtkmain.c:978

Thread 1 (Thread 0xb65556c0 (LWP 10768)):
#0  0xffffe424 in __kernel_vsyscall ()
No symbol table info available.
#1  0xb6d91c73 in __waitpid_nocancel () from /lib/i686/libpthread.so.0
No symbol table info available.
#2  0xb6d2fb23 in IA__g_spawn_sync (working_directory=0x0, argv=0x87bfc10, 
    envp=0x0, flags=G_SPAWN_SEARCH_PATH, child_setup=0, user_data=0x0, 
    standard_output=0x0, standard_error=0x0, exit_status=0x0, error=
    0xbfc9920c) at gspawn.c:386
        outpipe = -1
        errpipe = -1
        pid = 10999
        fds = {__fds_bits = {0, 142343196, 177834064, -1227810993, 8, 
    177834064, 4, -1227345932, 0, 142343196, 177834064, -1227824392, 
    177834064, -1227909456, 0, -1227345932, 0, -1077309024, -1077309096, 
    -1077309084, 0, 138119992, -1238294028, 178130272, -1227214860, 
    178130320, -1227344128, 142343184, 3, 177834064, -1077309096, 
    -1077309092}}
        ret = <value optimized out>
        outstr = 0x0
        errstr = 0x0
        failed = 0
        status = <value optimized out>
        __PRETTY_FUNCTION__ = "IA__g_spawn_sync"
#3  0xb6d2fe54 in IA__g_spawn_command_line_sync (command_line=
    0xa9f32b8 "bug-buddy --appname=\"Pidgin\" --pid=10768", standard_output=
    0x0, standard_error=0x0, exit_status=0x0, error=0xbfc9920c)
    at gspawn.c:700
        retval = 0
        argv = 0x87bfc10
        __PRETTY_FUNCTION__ = "IA__g_spawn_command_line_sync"
#4  0xb63152ec in run_bug_buddy (appname=<value optimized out>, 
    pid=<value optimized out>, minidump_path=0x0) at gnome-breakpad.cc:369
        res = <value optimized out>
        warning_file = <value optimized out>
        exec_str = 0xa9f32b8 "bug-buddy --appname=\"Pidgin\" --pid=10768"
        args_str = 0xa9e0d90
        error = 0x0
#5  0xb6315b0a in check_if_gdb () at gnome-breakpad.cc:440
        gdb = 0x87bcf88 "/usr/bin/gdb"
        pid = 10768
        mypath = 0xaaa4568 "\250Ĭ\n\260T˶/pidgin"
        has_debug_symbols = true
        appname = 0x837e838 "Pidgin"
#6  bugbuddy_segv_handle () at gnome-breakpad.cc:223
        in_segv = 1
#7  <signal handler called>
No symbol table info available.
#8  0xffffe424 in __kernel_vsyscall ()
No symbol table info available.
#9  0xb6b7ca71 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = <value optimized out>
        pid = -1228193804
        selftid = 0
#10 0xb6b7e3c2 in abort () at abort.c:92
        act = {__sigaction_handler = {sa_handler = 0x1, sa_sigaction = 0x1}, 
          sa_mask = {__val = {3077963764, 3217659696, 3077966520, 3217659652, 
    3077883832, 3217659636, 134544152, 3217659624, 3077966428, 0, 3059057808, 
    1, 0, 1, 3077966080, 0, 0, 0, 0, 0, 0, 0, 0, 3217659696, 3217659624, 
    3217659636, 0, 3077966080, 134601540, 0, 0, 0}}, sa_flags = 0, 
          sa_restorer = 0}
        sigs = {__val = {32, 0 <repeats 31 times>}}
#11 0x080c83ff in sighandler (sig=11) at gtkmain.c:192
        written = <value optimized out>
#12 <signal handler called>
No symbol table info available.
#13 0xb546cbb5 in purple_parse_msgerr (od=0xa8b8798, conn=0xa9009b8, fr=
    0xa9009f8) at oscar.c:3325
        gc = 0xa8b80b0
        reason = <value optimized out>
        errcode = 0
        data = 0x6 <Address 0x6 out of bounds>
        reason_str = 0xa8b8798 ""
        buf = <value optimized out>
#14 0xb5462f68 in generror (bs=<value optimized out>, 
    snac=<value optimized out>, frame=<value optimized out>, 
    mod=<value optimized out>, conn=<value optimized out>, 
    od=<value optimized out>) at misc.c:121
        ret = <value optimized out>
        error = -1224671244
        userfunc = 0
        snac2 = 0x0
#15 snachandler (bs=<value optimized out>, snac=<value optimized out>, 
    frame=<value optimized out>, mod=<value optimized out>, 
    conn=<value optimized out>, od=<value optimized out>) at misc.c:134
No locals.
#16 0xb5461d89 in parse_snac (frame=<value optimized out>, 
    conn=<value optimized out>, od=<value optimized out>)
    at flap_connection.c:765
        cur = 0xa8b8968
        snac = {family = 4, subtype = 1, flags = 0, id = 52}
#17 parse_flap (frame=<value optimized out>, conn=<value optimized out>, 
    od=<value optimized out>) at flap_connection.c:851
No locals.
#18 flap_connection_recv (frame=<value optimized out>, 
    conn=<value optimized out>, od=<value optimized out>)
    at flap_connection.c:986
        buf = <value optimized out>
        buflen = <value optimized out>
        read = <value optimized out>
#19 0x080acdd3 in pidgin_io_invoke (source=0x86dd850, condition=G_IO_IN, data=
    0xa8ffd48) at gtkeventloop.c:78
        purple_cond = PURPLE_INPUT_READ
#20 0xb6d2d69e in g_io_unix_dispatch (source=0xa8e7bb0, callback=
    0x80acd90 <pidgin_io_invoke>, user_data=0xa8ffd48) at giounix.c:162
        buffer_condition = <value optimized out>
#21 0xb6cf0d7e in g_main_dispatch (context=<value optimized out>)
    at gmain.c:1960
        dispatch = 0xb6d2d650 <g_io_unix_dispatch>
        user_data = 0xa8ffd48
        callback = 0x80acd90 <pidgin_io_invoke>
        cb_funcs = 0xb6d8333c
        cb_data = 0xa8d2f78
        current_source_link = {data = 0xa8e7bb0, next = 0x0}
        source = 0xa8e7bb0
        current = 0x874c640
        i = 0
#22 IA__g_main_context_dispatch (context=<value optimized out>)
    at gmain.c:2513
No locals.
#23 0xb6cf4a88 in g_main_context_iterate (context=0x83835f8, 
    block=<value optimized out>, dispatch=1, self=0x837d008) at gmain.c:2591
        max_priority = 2147483647
        timeout = 473
        some_ready = 1
        nfds = <value optimized out>
        allocated_nfds = <value optimized out>
        fds = <value optimized out>
        __PRETTY_FUNCTION__ = "g_main_context_iterate"
#24 0xb6cf4fb7 in IA__g_main_loop_run (loop=0xa8b9788) at gmain.c:2799
        self = 0x837d008
        __PRETTY_FUNCTION__ = "IA__g_main_loop_run"
#25 0xb73c26b9 in IA__gtk_main () at gtkmain.c:1219
        tmp_list = 0x0
        functions = 0x0
        init = 0x0
        loop = 0xa8b9788
#26 0x080c7f09 in main (argc=1, argv=0xbfc9c274) at gtkmain.c:978
        opt_force_online = 0
        opt_help = 141316672
        opt_login = 0
        opt_nologin = 0
        opt_version = 0
        opt_si = 1
        opt_config_dir_arg = 0x0
        opt_login_arg = 0x0
        opt_session_arg = 0x0
        accounts = <value optimized out>
        sig_indx = <value optimized out>
        sigset = {__val = {82951, 0 <repeats 31 times>}}
        prev_sig_disp = <value optimized out>
        errmsg = 
    "\000\000\000\000\000\000\000\000\364\377u\267\240\363t\267\364\377u\267\000\242ɿ\002\000\000\000ܡɿ\005\177u\267\b\000\000\000\024\000\000\000`\201U\266\b\000\000\000N\372t\267l\201U\266`\201U\266\b\000\000\000\000\000\000\000\360\242ɿآɿ6\016u\267 Hڶ\000\000\000\000\006\256\215\266\223c̶\213\300ɿ\204\300ɿ\200\300ɿL\bv\267\341}u\267\223c̶\000\000\000\000\000\000\000\000\364\377u\267\240\363t\267\360\242ɿ\364\377u\267\200\242ɿ\002\000\000\000\\\242ɿ\005\177u\267\b\000\000\000\024\000\000\000H\201U\266\b\000\000\000N\372t\267T\201U\266H\201U\266\b\000\000\000\000\000\000\000\370D\216\001\000\000\000\000\200\243ɿ Hڶ\000\000\000\000h\300ɿ", '\000' <repeats 12 times>"\213, \300ɿ\341}u\267\200\300ɿL\bv\267", '\000' <repeats 16 times>"\364, \377u\267\360\242ɿ\005\000\000\000آɿ\005\177u\267\b\000\000\000,\000\000\000\030\201U\266\024\000\000\000N\372t\267\060\201U\266\030\201U\266"...
        signal_channel = <value optimized out>
        signal_status = <value optimized out>
        error = 0x0
        opt = <value optimized out>
        gui_check = <value optimized out>
        debug_enabled = 0
        migration_failed = 141316672
        active_accounts = <value optimized out>
        long_options = {{name = 0x8119a0a "config", has_arg = 1, flag = 0x0, 
            val = 99}, {name = 0x810719e "debug", has_arg = 0, flag = 0x0, 
            val = 100}, {name = 0x8115524 "force-online", has_arg = 0, flag = 
    0x0, val = 100}, {name = 0x8109c39 "help", has_arg = 0, flag = 0x0, val = 
    104}, {name = 0x81152d4 "login", has_arg = 2, flag = 0x0, val = 108}, {
            name = 0x8115531 "multiple", has_arg = 0, flag = 0x0, val = 109}, 
    {name = 0x811553a "nologin", has_arg = 0, flag = 0x0, val = 110}, {name = 
    0x8119a00 "session", has_arg = 1, flag = 0x0, val = 115}, {name = 
    0x810cc25 "version", has_arg = 0, flag = 0x0, val = 118}, {name = 
    0x8119a13 "display", has_arg = 1, flag = 0x0, val = 68}, {name = 
    0x8115542 "sync", has_arg = 0, flag = 0x0, val = 83}, {name = 0x0, 
            has_arg = 0, flag = 0x0, val = 0}}
A debugging session is active.

	Inferior 1 [process 10768] will be detached.

Quit anyway? (y or n) [answered Y; input not from terminal]

Change History (4)

comment:1 Changed 9 years ago by QuLogic

  • Component changed from unclassified to AIM
  • Owner changed from rekkanoryo to MarkDoliner

comment:2 Changed 9 years ago by waschk

This is the debug output from oscar from a crash:

(21:06:34) oscar: incomingim_ch1: unknown TLV 0x0013 (len 1)
(21:06:34) oscar: Received IM from 111111111 with 1 parts
(21:06:34) oscar: 111111111 has an icon
(21:06:34) oscar: Sending buddy icon to 111111111 (1338 bytes)
(21:06:34) oscar: Parsing IM part, charset=0x0000, charsubset=0x0000, datalen=31, choice1=ASCII, choice2=ISO-8859-1, choice3=
(21:06:34) cap: Cancelling timeout callback
(21:06:34) cap: SELECT * FROM cap_msg_count WHERE buddy='111111111' AND account='267237836' AND protocol='prpl-icq' AND minute_val=1266;
(21:06:34) cap: SELECT * FROM cap_status_count WHERE buddy='111111111' AND account='111111111' AND protocol='prpl-icq' AND status='offline';
(21:06:34) oscar: rate change (param ID 0x0001): curavg = 4796, maxavg = 6000, alert at 2000, clear warning at 2500, limit at 1500, disconnect at 800, delta is 96086, dropping is 0 (window size = 80)
(21:06:34) oscar: icbm error: received response from request without a buddy name!

The chat contact is invisible.

comment:3 Changed 9 years ago by waschk

I have told my chat contact to switch from invisible to visible, then the crash does not happen.

comment:4 Changed 9 years ago by MarkDoliner

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #11068.
This sounds like a duplicate of #11068.

Does this crash still happen for you?

Have you tried disabling the Contact Availability Prediction plugin?

If you're able to, a backtrace from this crash would be helpful in tracking it down. There is information at GetABacktrace.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!