Opened 9 years ago

Closed 2 years ago

#11686 closed defect (out of date)

MSN ping timeout not enforced or too high

Reported by: kastel Owned by: khc
Milestone: Component: MSN
Version: 2.6.6 Keywords: ping timeout
Cc: Taemojitsu

Description

I'm running Pidgin version 2.6.6. Sometimes I'm connected through a low quality proxy, which keeps sockets open even if connection with IM server is broken.

However, Pidgin should acknowledge that and retry the connection, but it does not, even when pings are unanswered for 30 seconds.

Change History (5)

comment:1 Changed 9 years ago by rekkanoryo

  • Component changed from unclassified to MSN
  • Keywords MSN removed
  • Owner changed from rekkanoryo to khc

comment:2 Changed 9 years ago by QuLogic

Ticket #11698 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by Taemojitsu

I believe this is a different bug than 11698. When my router restarts, approximately 15 minutes later Pidgin disconnects me from MSN presumably due to conversation timeout or something. But when switching from wireless to ethernet or from one wired connection to another, the timeout is never enforced and I tested this before by letting it remain for over an hour in a 'falsely connected' state and changing my Away status to see if the connection to the server was valid. An hour after changing interfaces, changes were still not showing up but Pidgin had not displayed the connection as having broken. This is even when the original interface is still available, but no longer the default route for the system.

It seems like a different error than when the connection is broken somewhere other than the local computer.

comment:4 Changed 9 years ago by Taemojitsu

#11686 does not seem to be a problem with Pidgin, but rather with Ubuntu, as the same problem exists even with 'ping'. See this thread: http://ubuntuforums.org/showthread.php?p=9584971#post9584971

#11698 works differently, and while it might also be a problem with the OS, is not the same as #11686. A flood ping that has been 'broken' in Ubuntu 10.04 can be restarted by changing the network interface (i.e. unplugging an Ethernet cable after connecting to a wireless network), while a Pidgin connection to MSN that has been previously 'broken' is not made to work by doing this, and stops working.

comment:5 Changed 2 years ago by dx

  • Resolution set to out of date
  • Status changed from new to closed

Closing all MSN tickets, since it has been removed in pidgin 2.12.0 after being broken for a couple of years (see http://ismsndeadyet.com/). The skypeweb plugin can be used as an alternative (yes, it supports MSN logins too)

If this issue is still present in any other protocols supported by pidgin, please leave a comment and we will reopen it.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!