Opened 9 years ago

Closed 8 years ago

#11726 closed defect (duplicate)

Excess Flood on reconnect

Reported by: cwickert Owned by: elb
Milestone: Component: IRC
Version: 2.6.6 Keywords:
Cc: 80686

Description

After a connection breakdown pidgin tries to reconnect to IRC servers multiple times causing an excess flood. This seems to be a duplicate Ticket #11306 "Pidgin 2.6.5 connects to IRC channels twice on rejoin", but unlike the original reporter I'm able to provide the debug log. The problems started at about 18:45 in that log.

Attachments (1)

debug.log (1.2 MB) - added by cwickert 9 years ago.
debug log

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by cwickert

debug log

comment:1 Changed 9 years ago by cwickert

When I closed pidgin after the excess flood problems, it crashed, see ticket # 11727.

comment:2 Changed 9 years ago by 80686

I have the same problem here on Freenode.

According my understanding the problem is that Pidgin is joining to quickly on reconnect, so Freenode suspects flooding if you have to many autojoin-channels in Pidgin due to the amount of /join commands within a short period of time.

A possible solution might be if autojoin is slowed down by a delay, maybe adjustable in the preferences.

Some IRC clients offers a flooding protection by using a general delay which is triggered by n messages withing a specific time period.

comment:3 follow-up: Changed 9 years ago by jnd

There is missing some settings to send max n commands (or bytes) per second. Also it's impossible to disable autojoin on channels in some network unless you're actually conneted. At least I haven't found a way do show them in the list. So now I can't do nothing but use another client with better IRC support.

comment:4 in reply to: ↑ 3 Changed 9 years ago by darkrain42

Replying to jnd:

There is missing some settings to send max n commands (or bytes) per second. Also it's impossible to disable autojoin on channels in some network unless you're actually conneted. At least I haven't found a way do show them in the list. So now I can't do nothing but use another client with better IRC support.

As I mentioned in IRC, you can massage the set of autojoin chats by closing Pidgin and editing blist.xml by hand. Before anyone suggests otherwise, I'm simply offering this as a workaround to restore your IRC account to a functioning state -- I'm not suggesting it's the be-all, end-all solution.

comment:5 Changed 9 years ago by ville

This looks like a duplicate of #11089

comment:6 Changed 8 years ago by elb

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #11089.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!