Opened 9 years ago

Closed 8 years ago

#11807 closed defect (invalid)

MSN high memory usage for particular user

Reported by: hanzz Owned by: QuLogic
Milestone: Component: MSN
Version: 2.6.6 Keywords:
Cc: salinasv

Description

Hi, I'm using libpurple for my XMPP - libpurple transport. For few particular users libpurple uses 10MB+ per one connection. I have log from this situation. The problem is that memory is not "freed" anywhere. In log MSN emails are replaced by random names and corrupted just because of privacy.

There are also few lines which informs about current memory usage ([04/06/10 13:26:02] <MEMORY USAGE BEFORE ADDING BUDDY> 20360). That information is read from /proc/self/stat by transport itself and it's in MBs.

I think this is bug in libpurple, because it happens only when transport runs with prpl-msn.

Attachments (1)

test5.log.tgz (260.8 KB) - added by hanzz 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by hanzz

comment:1 Changed 9 years ago by hanzz

  • Component changed from unclassified to MSN
  • Owner changed from rekkanoryo to QuLogic

comment:2 Changed 8 years ago by hanzz

  • Resolution set to invalid
  • Status changed from new to closed

Finally got motivation to track this down. It's caused by libxml2. Check last paragraph at http://xmlsoft.org/xmlmem.html. I've added malloc_trim(0); into my app (for Linux only) and it works great.

Closing this, because it's not libpurple bug, but expected libxml2/kernel behaviour.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!