Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11836 closed defect (fixed)

HTML tags in ICQ messages

Reported by: Komanche Owned by: MarkDoliner
Milestone: 2.7.2 Component: ICQ
Version: 2.7.0 Keywords: ICQ html tags in message
Cc: Tyde, flokli, zeroo, delirium, cvine, jens

Description

After upgrade to 2.7.0 there are html tags in ICQ messages...
In previous version it was ok.

It look like this:

<HTML><BODY dir="ltr"><FONT face="Arial" color="#000000" size="2"><B><FONT sml="MEtvbG9ib2tTZXQz">test</FONT></B></FONT></BODY></HTML>

Change History (46)

comment:1 Changed 9 years ago by MarkDoliner

Do you know what ICQ client the other person is using?

comment:2 Changed 9 years ago by Komanche

6.5 another user with version 7.1 is ok (he is also using formatting)

comment:3 follow-up: Changed 9 years ago by Komanche

update: 7.1 with diacritic has also problem, 7.1 without diacritic is ok...

<HTML><BODY dir="ltr"><FONT face="Arial" color="#000000" size="2">ěščřžýáíé</FONT></BODY></HTML>

comment:4 in reply to: ↑ 3 Changed 9 years ago by cyb3rwulf

Same Problem here, also on Win Pidgin. I used before the Update Pidgin Version 2.6.5, it works there without this kind of Problem.

comment:5 Changed 9 years ago by Robby

Ticket #11835 has been marked as a duplicate of this ticket.

comment:6 Changed 9 years ago by Robby

  • Milestone set to 2.7.1

comment:7 Changed 9 years ago by darkrain42

Ticket #11840 has been marked as a duplicate of this ticket.

comment:8 Changed 9 years ago by datallah

Ticket #11853 has been marked as a duplicate of this ticket.

comment:9 Changed 9 years ago by datallah

  • Summary changed from 2.7.0 win - ICQ - html tags in message to HTML tags in ICQ messages

comment:10 Changed 9 years ago by datallah

Ticket #11865 has been marked as a duplicate of this ticket.

comment:11 Changed 9 years ago by stshadow

The same when other IM client is qip 2010. My pidgin is 2.7.0. Previous 2.6.5 worked fine.

comment:12 Changed 9 years ago by variolars

same here, partner has icq 6.5

comment:13 Changed 9 years ago by variolars

problem solved, when partner updates to icq 7.0

comment:14 follow-up: Changed 9 years ago by SpeedProg

Plugin just unescapes HTML. http://forum.pidgin-im.de/showthread.php?tid=1002&pid=6018#pid6018 icq65fixer.zip => contain source + win32 .dll Load the Plugin. Is you see getting those html-stuff display, right click on the Buddy-List-Node and set "Set ICQ 6.5 user". Messages should behave fine then. Please don't forgett to remove the plugin wenn 2.7.1 is pulled out.

comment:15 Changed 9 years ago by markdoliner@…

(In 8869d33452d0640a21f39ab5bf0f05d452764d1e):
I propagated im.pidgin.soc.2010.icq-tlc to im.pidgin.pidgin. This includes Ivan Komarov's fix for HTML being displayed on incoming messages from ICQ 6.5 and various other clients. Ivan is our ICQ TLC summer of code student.

Thanks, Ivan!

Refs #11836

comment:16 Changed 9 years ago by Majkl578

Same problem here, partner is using ICQ 6.5. Running on Debian SID.

comment:17 Changed 9 years ago by darkrain42

Ticket #11910 has been marked as a duplicate of this ticket.

comment:18 in reply to: ↑ 14 ; follow-up: Changed 9 years ago by SpeedProg

Replying to SpeedProg:

Plugin just unescapes HTML. http://forum.pidgin-im.de/showthread.php?tid=1002&pid=6018#pid6018 icq65fixer.zip => contain source + win32 .dll Load the Plugin. Is you see getting those html-stuff display, right click on the Buddy-List-Node and set "Set ICQ 6.5 user". Messages should behave fine then. Please don't forgett to remove the plugin wenn 2.7.1 is pulled out.

Update: Download Attachment pidgin-2-7-0_20100515_fix.zip and copy liboscar.dll to [Pidgin-installationDir]\

comment:19 follow-up: Changed 9 years ago by MarkDoliner

comment:20 Changed 9 years ago by rekkanoryo

Ticket #11927 has been marked as a duplicate of this ticket.

comment:21 in reply to: ↑ 19 Changed 9 years ago by Motg

Replying to MarkDoliner:

In case anyone wants to manually apply a diff and compile yourself to fix this, you can use this: http://developer.pidgin.im/viewmtn/revision/rawdiff/0e263caa5d687101e436029f2f8d09053ae06e23/with/fbaa1535e48551cdf9b0bb2234f992c3d94a7526/libpurple/protocols/oscar/oscar.c

it works!

comment:22 Changed 9 years ago by Phagos

Recieving messages from ICQ 6.5 and both sending and recieving links work fine with patch applied

comment:23 follow-up: Changed 9 years ago by flokli

are there clients out there which wont send html messages?

when someone with such a client wants to send "escaped" html code (like "hey! look at my html code here: <pasted code> is it correct?") it will always get rendered inside pidgin with this patch, or do i understand sth. wrong?

comment:24 in reply to: ↑ 18 ; follow-up: Changed 9 years ago by SpeedProg

Replying to SpeedProg:

Replying to SpeedProg:

Plugin just unescapes HTML. http://forum.pidgin-im.de/showthread.php?tid=1002&pid=6018#pid6018 icq65fixer.zip => contain source + win32 .dll Load the Plugin. Is you see getting those html-stuff display, right click on the Buddy-List-Node and set "Set ICQ 6.5 user". Messages should behave fine then. Please don't forgett to remove the plugin wenn 2.7.1 is pulled out.

Update: Download Attachment pidgin-2-7-0_20100515_fix.zip and copy liboscar.dll to [Pidgin-installationDir]\

Update: Windows Only: Download Attachment icq-fix-2-7-0_20100518.zip and copy liboscar.dll to [Pidgin-installationDir]\ (This one uses both fixes (the diff posted above), the one for sending and that for receiving formatted messages over ICQ.

comment:25 in reply to: ↑ 24 ; follow-up: Changed 9 years ago by xTM

Replying to SpeedProg:

Replying to SpeedProg:

Replying to SpeedProg:

Plugin just unescapes HTML. http://forum.pidgin-im.de/showthread.php?tid=1002&pid=6018#pid6018 icq65fixer.zip => contain source + win32 .dll Load the Plugin. Is you see getting those html-stuff display, right click on the Buddy-List-Node and set "Set ICQ 6.5 user". Messages should behave fine then. Please don't forgett to remove the plugin wenn 2.7.1 is pulled out.

Update: Download Attachment pidgin-2-7-0_20100515_fix.zip and copy liboscar.dll to [Pidgin-installationDir]\

Update: Windows Only: Download Attachment icq-fix-2-7-0_20100518.zip and copy liboscar.dll to [Pidgin-installationDir]\ (This one uses both fixes (the diff posted above), the one for sending and that for receiving formatted messages over ICQ.

works fine!

comment:26 in reply to: ↑ 25 Changed 9 years ago by MarG

Replying to xTM:

works fine!

Yep, confirmed on Win7 x86!

comment:27 Changed 9 years ago by Robby

Ticket #11970 has been marked as a duplicate of this ticket.

comment:28 in reply to: ↑ 23 Changed 9 years ago by ivan.komarov

Replying to flokli:

are there clients out there which wont send html messages?

when someone with such a client wants to send "escaped" html code (like "hey! look at my html code here: <pasted code> is it correct?") it will always get rendered inside pidgin with this patch, or do i understand sth. wrong?

Yes, there are clients that send and receive plain-text messages only, such as Miranda or QIP, and yes, Pidgin will render their messages as HTML. The official clients (ICQ 6.5 and 7.0) also do that. I couldn't find a quick and reliable way to determine if an incoming IM is in HTML or plain-text (without resorting to hacks), so I decided to leave it as is.

comment:29 Changed 9 years ago by Nemesis13

This issue is really annoying. Can we expect this fixed in 2.7.1?

comment:30 Changed 9 years ago by MarkDoliner

  • Resolution set to fixed
  • Status changed from new to closed

Yes

comment:31 Changed 9 years ago by Nemesis13

YAY. thank you :)

comment:32 follow-up: Changed 9 years ago by sergio

Hey guys, sorry but I'm now have Pidgin 2.7.1devel (libpurple 2.7.1devel) efcc3c52b219fcb621302901bd34047fd384395a from frasten PPA, and this bug is still not solved, is it ok? How can I finally fix the problem? Thank you.

comment:33 in reply to: ↑ 32 ; follow-up: Changed 9 years ago by ivan.komarov

Replying to sergio:

Hey guys, sorry but I'm now have Pidgin 2.7.1devel (libpurple 2.7.1devel) efcc3c52b219fcb621302901bd34047fd384395a from frasten PPA, and this bug is still not solved, is it ok? How can I finally fix the problem? Thank you.

It's definitely not OK. Could you elaborate a little on the issue so that I can reproduce it? Who's receiving HTML tags in messages, you or your buddies? Are you seeing this problem with all of your buddies or only with some of them? If the latter, what ICQ client do they use? Thanks.

comment:34 in reply to: ↑ 33 ; follow-up: Changed 9 years ago by SpeedProg

Replying to ivan.komarov:

Replying to sergio:

Hey guys, sorry but I'm now have Pidgin 2.7.1devel (libpurple 2.7.1devel) efcc3c52b219fcb621302901bd34047fd384395a from frasten PPA, and this bug is still not solved, is it ok? How can I finally fix the problem? Thank you.

It's definitely not OK. Could you elaborate a little on the issue so that I can reproduce it? Who's receiving HTML tags in messages, you or your buddies? Are you seeing this problem with all of your buddies or only with some of them? If the latter, what ICQ client do they use? Thanks.

You can reproduce it by using ICQ 6.5 Client and Pidgin. Send a formatted message using pidgin, then you will se html in the ICQ 6.5 Client. Thats couse you guys did not apply the patch that was allready there.

Diff where you see what should have been merged in but was removed :(

AND HERE IT HAPPENED

This is the diff that should be merged in to fix both outgoing and incoming HTML http://developer.pidgin.im/ticket/11836#comment:19 but only half has be merged in :(

comment:35 in reply to: ↑ 34 Changed 9 years ago by ivan.komarov

Replying to SpeedProg:

This is the diff that should be merged in to fix both outgoing and incoming HTML http://developer.pidgin.im/ticket/11836#comment:19 but only half has be merged in :(

Yeah, that was unfortunate. The whole patch has now been merged to the main branch, but it looks like it won't go into 2.7.1, since it's just about to release. You'll have to wait for 2.7.2. Sorry for the inconvenience.

comment:36 Changed 9 years ago by datallah

Ticket #12060 has been marked as a duplicate of this ticket.

comment:37 Changed 9 years ago by QuLogic

Ticket #12070 has been marked as a duplicate of this ticket.

comment:38 Changed 9 years ago by rekkanoryo

Ticket #12075 has been marked as a duplicate of this ticket.

comment:39 Changed 9 years ago by fabian

My new ticket #12070 specifically focused on the outhoing HTML problem and was marked as a dup of this ticket, but this isn't exactly true...

But maybe the milestone for this ticket here should be set to 2.7.2 and it should be re-opened?

comment:40 Changed 9 years ago by yoku86

I have the same problem like fabian, but my chat partner has ICQ 6.5 and gets HTML Tags.

comment:41 Changed 9 years ago by MarkDoliner

  • Milestone changed from 2.7.1 to 2.7.2

fabian: I think we've been treating this ticket as if it applied for both issues (seeing HTML in incoming messages, and other people seeing HTML in messages that you've sent).

The first issue was fixed in 2.7.1, the second issue will be fixed in 2.7.2.

comment:42 Changed 9 years ago by sergio

So there is no solution to fix the second issue? That's pretty sad.

comment:43 Changed 9 years ago by MarkDoliner

Er, the solution is checked in... http://developer.pidgin.im/viewmtn/revision/info/913a8d73fc8635dab66f0c26561d1ec9fe366b09

I agree that it's sad it didn't make it into 2.7.1.

comment:44 Changed 9 years ago by rekkanoryo

Ticket #12093 has been marked as a duplicate of this ticket.

comment:45 Changed 9 years ago by Robby

Ticket #12119 has been marked as a duplicate of this ticket.

comment:46 Changed 9 years ago by cvine

This bug isn't really fixed even for incoming messages.

If you have the "Show formatting on incoming messages" option picked (the default), the font size and family of the message text will be wrong when the incoming message is displayed - it will adopt the font size and family of the "xxx typing ..." text which is displayed beforehand, instead of the program's chosen font family and size for message text.

Can the bug be reopened please?

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!