Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#11842 closed defect (fixed)

Flash window when IMs are received no longer works on Windows

Reported by: douglaswth Owned by: datallah
Milestone: 2.7.1 Component: winpidgin (gtk)
Version: 2.7.0 Keywords:
Cc: thewinternet, tmeader, ATimson, kobach, RiperSnifle, zachweinberg, alitrix

Description

After upgrading to 2.7.0 there IM and chat windows have stopped flashing when new messages are received.

Attachments (3)

purple-debug.log (1.5 KB) - added by NishaKitty 9 years ago.
purple-debug.2.log (1014 bytes) - added by tmeader 9 years ago.
Debug log after requesting that "xxx" send a message to their minimized window on my ("yyy") Win2K3 system.
pidgin-debug3.log (1.0 KB) - added by Feurigel 9 years ago.

Download all attachments as: .zip

Change History (77)

comment:1 Changed 9 years ago by Phagos

Same for me: taskbar button doesn't flash any more on new messages (Windows 7)

comment:2 Changed 9 years ago by Robby

Ticket #11844 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by NishaKitty

Confirming this bug was about to post my own report yay ;p 2.7.0 is effected for me I am using Windows Vista Home Premium x64. I tried disabling all my plugins no difference, I tried using the Message Notification plugin, no luck. Seems completely broken, I hear the sound I get the Buddy list notification I icon I get the tray notification icon, just no window flash x.x

I really hopethis can be fixed cause it is by far the biggest part of an IM client for me.

comment:4 Changed 9 years ago by NishaKitty

Some extra info about my two PCs I use Pidgin on...

Pidgin v2.7.0 GTK v2.16.6

Windows XP Pro x86 Buddy List Icon: Shows new message icon, does not flash, expected behavior Tray Icon: Shows new message icon, flashes, expected behavior Taskbar Item: does not flash, unexpected behavior

Windows Vista Home Premium x64 Buddy List Icon: Shows new message icon, does not flash, expected behavior Tray Icon: Shows new message icon, does not flash, unexpected behavior Taskbar Item: does not flash, unexpected behavior

comment:5 Changed 9 years ago by Robby

Ticket #11847 has been marked as a duplicate of this ticket.

comment:6 follow-up: Changed 9 years ago by thewinternet

Workaround: Use offline installer!

comment:7 in reply to: ↑ 6 Changed 9 years ago by NishaKitty

Replying to thewinternet:

Workaround: Use offline installer!

This is NOT an install issue...

comment:8 follow-up: Changed 9 years ago by thewinternet

I'm sorry about that. Robby closed my incident and added it as a duplicate to this one. Looks like someone made a mistake.

http://developer.pidgin.im/ticket/11847#comment:1

comment:9 in reply to: ↑ 8 Changed 9 years ago by NishaKitty

Replying to thewinternet:

I'm sorry about that. Robby closed my incident and added it as a duplicate to this one. Looks like someone made a mistake.

http://developer.pidgin.im/ticket/11847#comment:1

Sorry for the um slightly hostile reply mistakes happen ;

comment:10 Changed 9 years ago by Robby

Ticket #11849 has been marked as a duplicate of this ticket.

comment:11 Changed 9 years ago by djsolidsnake86

sorry for the ticket, there will be soon a fix in the nightlies? is a bad problem this

comment:12 Changed 9 years ago by thewinternet

Ironically enough I have this issue as well. Heh.

comment:13 Changed 9 years ago by NishaKitty

Guys please if you can post you OS versions so we can help figure out if this is OS specific or not.

comment:14 Changed 9 years ago by djsolidsnake86

win764bit ultimate here

comment:15 Changed 9 years ago by yoku86

Same problem. My OS is Win7 32 Bit Ultimate.

comment:16 Changed 9 years ago by Feurigel

Windows 7 Home Premium, 64bit

comment:17 Changed 9 years ago by datallah

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.
Someone please post the debug log from when the flashing should have occurred.

Changed 9 years ago by NishaKitty

comment:18 Changed 9 years ago by NishaKitty

Please note I changed my email address to asterixes for privacy, hope this helps, the log is from my Windows XP Pro SP3 x86 'puter.

comment:19 Changed 9 years ago by dsueltenfuss

Happening on Windows 7 64Bit Professional

comment:20 Changed 9 years ago by tmeader

Also happening on Windows Server 2003 R2.

Changed 9 years ago by tmeader

Debug log after requesting that "xxx" send a message to their minimized window on my ("yyy") Win2K3 system.

comment:21 Changed 9 years ago by kobach

Also happening here on XP PRO SP3

comment:22 Changed 9 years ago by datallah

Ticket #11857 has been marked as a duplicate of this ticket.

comment:23 Changed 9 years ago by darkrain42

  • Status changed from pending to new

It's not at all necessary for anyone to add further "me too, I'm using Windows blah blah blah".

Thanks.

(unsetting pending due to debug logs)

Changed 9 years ago by Feurigel

comment:24 Changed 9 years ago by djsolidsnake86

guys this problem will be fixed soon? at this time, i can't chat well because i can't see when a new msg arrive :(

comment:25 Changed 9 years ago by zachweinberg

Is there a way to revert to 2.6.6 in the interim?

comment:26 Changed 9 years ago by datallah

Ticket #11862 has been marked as a duplicate of this ticket.

comment:27 Changed 9 years ago by kalzor

http://sourceforge.net/projects/pidgin/files/Pidgin/2.6.6/pidgin-2.6.6.exe/download

DL for 2.6.6

replaced filehippo link with link to official Sourceforge page --darkrain42

comment:28 follow-ups: Changed 9 years ago by fafer

Workaround for Windows7:

  1. Activate Message Notification plugin
  2. Set the action to "Show IM-Window"

If your IM-window is not minimized Windows 7 will flash the Taskbar-Icon instead of showing the window.

comment:29 in reply to: ↑ 28 Changed 9 years ago by Feurigel

Replying to fafer:

Workaround for Windows7:

  1. Activate Message Notification plugin
  2. Set the action to "Show IM-Window"

If your IM-window is not minimized Windows 7 will flash the Taskbar-Icon instead of showing the window.

Yeah! That's works! Thank you.

comment:30 Changed 9 years ago by datallah

Ticket #11864 has been marked as a duplicate of this ticket.

comment:31 in reply to: ↑ 28 Changed 9 years ago by racoq

Replying to fafer:

Workaround for Windows7:

  1. Activate Message Notification plugin
  2. Set the action to "Show IM-Window"

If your IM-window is not minimized Windows 7 will flash the Taskbar-Icon instead of showing the window.

that doesnt work here.

comment:32 Changed 9 years ago by datallah@…

  • Milestone set to 2.7.1
  • Resolution set to fixed
  • Status changed from new to closed

(In 54b2ac9fc179bd46065882041bbaa7b4b6bafce6):
Fix a regression in 2.7.0 that caused window flashing not to work on Windows. The sad part is that this change has been sitting in my tree for a couple months. :( Fixes #11842

comment:33 Changed 9 years ago by RiperSnifle

@datallah: OK, thanks for the info... is there a chance to have nightly with this error fixed? thx

comment:34 Changed 9 years ago by rekkanoryo

We do not build nightlies, and we don't support users running development code.

comment:35 Changed 9 years ago by RiperSnifle

OK, thx... going back to 2.6.6 now...

comment:36 Changed 9 years ago by racoq

So does that mean that users will have to wait till the devs want to launch 2.7.1, to have a basic function in any IM like taskbar blinking?

Who use in its sanity, an IM client without this function?

Thats lame, and big fail!

comment:37 follow-up: Changed 9 years ago by djsolidsnake86

comment:38 Changed 9 years ago by Robby

Ticket #11868 has been marked as a duplicate of this ticket.

comment:39 Changed 9 years ago by Robby

Ticket #11869 has been marked as a duplicate of this ticket.

comment:40 Changed 9 years ago by Robby

Ticket #11870 has been marked as a duplicate of this ticket.

comment:41 Changed 9 years ago by Robby

Ticket #11876 has been marked as a duplicate of this ticket.

comment:42 in reply to: ↑ 37 Changed 9 years ago by datallah

Replying to djsolidsnake86:

http://achton.net/projects/pidgin/ these aren't nightly?

They may be, but they aren't built or supported by us.

comment:43 follow-ups: Changed 9 years ago by datallah

We don't provide nightlies, but I have uploaded a replacement pidgin.dll that contains the flashing fix for people to use until 2.7.1 is released.

comment:44 Changed 9 years ago by Robby

Ticket #11896 has been marked as a duplicate of this ticket.

comment:45 Changed 9 years ago by datallah

Ticket #11903 has been marked as a duplicate of this ticket.

comment:46 in reply to: ↑ 43 ; follow-ups: Changed 9 years ago by PidginGuy

Replying to datallah:

We don't provide nightlies, but I have uploaded a replacement pidgin.dll that contains the flashing fix for people to use until 2.7.1 is released.

This worked for me. Thanks, but I'm still a bit angry that you guys could have missed this when giving us all a new version.

I'm still confused about my previous question though: is there a way to make the input text area of the IM window taller?

comment:47 in reply to: ↑ 46 ; follow-up: Changed 9 years ago by NishaKitty

Replying to PidginGuy:

Replying to datallah:

We don't provide nightlies, but I have uploaded a replacement pidgin.dll that contains the flashing fix for people to use until 2.7.1 is released.

This worked for me. Thanks, but I'm still a bit angry that you guys could have missed this when giving us all a new version.

I'm still confused about my previous question though: is there a way to make the input text area of the IM window taller?

Perhaps you're looking for Tools -> Preferances -> Conversations -> Minimum input area height in lines.

Also commenting on the Flashing thing while I agree the patch is nice and thanks for making it datallah :) such an obvious bug and one that makes using the client a very large task on Windows should've been picked up in some sort of testing...

comment:48 in reply to: ↑ 46 ; follow-ups: Changed 9 years ago by datallah

Replying to PidginGuy:

This worked for me. Thanks, but I'm still a bit angry that you guys could have missed this when giving us all a new version.

Wow... you're angry that something that is given to you for free has a bug, that's great. I'll be sure to keep that in mind for future reference. This type of response really makes all the volunteer work pay off!

comment:49 Changed 9 years ago by datallah

Ticket #11906 has been marked as a duplicate of this ticket.

comment:50 Changed 9 years ago by datallah

Ticket #11904 has been marked as a duplicate of this ticket.

comment:51 in reply to: ↑ 48 Changed 9 years ago by pit

Replying to datallah:

Replying to PidginGuy:

This worked for me. Thanks, but I'm still a bit angry that you guys could have missed this when giving us all a new version.

Wow... you're angry that something that is given to you for free has a bug, that's great. I'll be sure to keep that in mind for future reference. This type of response really makes all the volunteer work pay off!

I'm not angry so much as surprised. But a fix is already in, there is a patch and that's all that matters for me. (:

comment:52 in reply to: ↑ 48 ; follow-up: Changed 9 years ago by tuberbob

Replying to datallah:

Replying to PidginGuy:

This worked for me. Thanks, but I'm still a bit angry that you guys could have missed this when giving us all a new version.

Wow... you're angry that something that is given to you for free has a bug, that's great. I'll be sure to keep that in mind for future reference. This type of response really makes all the volunteer work pay off!

First, I'd like to thank you for the effort and the fix. This was a pretty stark oversight, and it's great to have the functionality back.

Second, datallah, your comment here is just about the most unbelievably arrogant thing I have read in a long time, and I am amazed that you, as a developer, would lash out at a user the way you did. Sure, it's free, but does that change the fact that a lot of people use and depend on Pidgin? You were called out on a major oversight, something that a minimal amount of testing would have caught right away, and your response is to be condescending and rude? Bravo sir. Glad to know open source truly represents the moral high road with folks like you leading the charge. Well played.

comment:53 follow-up: Changed 9 years ago by Robby

tuberbob, PidginGuy?,

please fix your FSUES issues.

comment:55 Changed 9 years ago by darkrain42

Ticket #11911 has been marked as a duplicate of this ticket.

comment:56 Changed 9 years ago by darkrain42

Ticket #11915 has been marked as a duplicate of this ticket.

comment:57 in reply to: ↑ 48 Changed 9 years ago by PidginGuy

Replying to datallah:

Replying to PidginGuy:

This worked for me. Thanks, but I'm still a bit angry that you guys could have missed this when giving us all a new version.

Wow... you're angry that something that is given to you for free has a bug, that's great. I'll be sure to keep that in mind for future reference. This type of response really makes all the volunteer work pay off!

I couldn't agree more. And yes, I WAS angry. Like he said, a lot of people love and depend on Pidgin every single day around the entire planet. We even rely on it at work. We talk about it in casual conversations and try to get others to use it -- that's how much we enjoy it. And then to see an official update include a huge bug, that suggests it wasn't even tested at all, and makes the entire Pidgin team look very unprofessional.

I greatly appreciate you spending personal time out of your day to provide us with a patch . . . but that's honestly not good enough -- why is the front page not patched with a 2.7.1 version that includes that .dll? You're continuing to provide a bad product on your front page to 1000s of people each day. We expect better from such a great program, that we've used for years.

I won't stop using Pidgin, but you might want to rethink why you're doing what you're doing. For gratification from users? Or to help create the best dang IM service on the entire Internet? I'll admit your bug submission process is fantastic and very efficient. It's just a shame that the pre-upgrade user testing process isn't as fantastic.

Don't worry, we all have a bad day. I just would like to see you guys pump up your beta testing. Thanks again for the .dll file.

@NishaKitty??: Thanks!

comment:58 Changed 9 years ago by PidginGuy

Meant to reply to Tuberbob.

comment:59 Changed 9 years ago by darkrain42

Ticket #11918 has been marked as a duplicate of this ticket.

comment:60 Changed 9 years ago by Robby

Ticket #11919 has been marked as a duplicate of this ticket.

comment:61 in reply to: ↑ 52 ; follow-up: Changed 9 years ago by datallah

Replying to tuberbob:

Replying to datallah:

Replying to PidginGuy:

This worked for me. Thanks, but I'm still a bit angry that you guys could have missed this when giving us all a new version.

Wow... you're angry that something that is given to you for free has a bug, that's great. I'll be sure to keep that in mind for future reference. This type of response really makes all the volunteer work pay off!

Second, datallah, your comment here is just about the most unbelievably arrogant thing I have read in a long time, and I am amazed that you, as a developer, would lash out at a user the way you did. Sure, it's free, but does that change the fact that a lot of people use and depend on Pidgin? You were called out on a major oversight, something that a minimal amount of testing would have caught right away, and your response is to be condescending and rude? Bravo sir. Glad to know open source truly represents the moral high road with folks like you leading the charge. Well played.

I'm not interested in continuing an unrelated discussion on this ticket, so this will be my last reply on the subject here because it isn't the right venue for this type of thing.

I just want to point out that this type of thing will happen - there will be bugs and hopefully they will be fixed in a timely manner.

If you feel like complaining that the release wasn't tested adequately, please direct the complaints at yourself for not taking the initiative to make that happen. All development, testing and support is conducted by volunteers - if you think that any such area is lacking, you're certainly welcome to step forward and put some effort into improving it. That is how the project works.

comment:62 Changed 9 years ago by djsolidsnake86

on msn chat with more people the flash don't work!

comment:63 in reply to: ↑ 61 ; follow-up: Changed 9 years ago by PidginGuy

Replying to datallah:

Replying to tuberbob:

Replying to datallah:

Replying to PidginGuy:

This worked for me. Thanks, but I'm still a bit angry that you guys could have missed this when giving us all a new version.

Wow... you're angry that something that is given to you for free has a bug, that's great. I'll be sure to keep that in mind for future reference. This type of response really makes all the volunteer work pay off!

Second, datallah, your comment here is just about the most unbelievably arrogant thing I have read in a long time, and I am amazed that you, as a developer, would lash out at a user the way you did. Sure, it's free, but does that change the fact that a lot of people use and depend on Pidgin? You were called out on a major oversight, something that a minimal amount of testing would have caught right away, and your response is to be condescending and rude? Bravo sir. Glad to know open source truly represents the moral high road with folks like you leading the charge. Well played.

I'm not interested in continuing an unrelated discussion on this ticket, so this will be my last reply on the subject here because it isn't the right venue for this type of thing.

I just want to point out that this type of thing will happen - there will be bugs and hopefully they will be fixed in a timely manner.

If you feel like complaining that the release wasn't tested adequately, please direct the complaints at yourself for not taking the initiative to make that happen. All development, testing and support is conducted by volunteers - if you think that any such area is lacking, you're certainly welcome to step forward and put some effort into improving it. That is how the project works.

I'm shocked that the homepage still hasn't been updated with a 2.7.1 version that contains the necessary .dll file. I've beta tested before, and I'm giving thought to joining Pidgin's beta testing group to help out, but honestly, if it's so unorganized that once a problem is fixed, and three days later the update still isn't posted on the front page, then why even bother?

I feel bad for everyone else out there who still has 2.7.0 and isn't aware that this .dll patch exists.

comment:64 in reply to: ↑ 63 Changed 9 years ago by rekkanoryo

Replying to PidginGuy:

I'm shocked that the homepage still hasn't been updated with a 2.7.1 version that contains the necessary .dll file. I've beta tested before, and I'm giving thought to joining Pidgin's beta testing group to help out, but honestly, if it's so unorganized that once a problem is fixed, and three days later the update still isn't posted on the front page, then why even bother?


I am the reason a 2.7.1 has not been released yet. There are more important bugs than this one that were waiting for a fix. The majority of those more important bugs have been solved, and there are still a couple more that need to be fixed. (By "more important", I mean they cause crashes. Something as simple as taskbar flashing, while annoying, is not critical.) I have set a release schedule for 2.7.1 that will include this fix and all the others I mentioned. I don't think 2-3 weeks is an unreasonable amount of time to wait for this.


I feel bad for everyone else out there who still has 2.7.0 and isn't aware that this .dll patch exists.


A simple search on this trac for "taskbar flash" (without quotes) returns a number of useful results. Sure, the first several results are duplicates, but by clicking through them, you get here. This ticket is the second to the last result on the first page of results, as well. It's not terribly difficult to find.

comment:65 in reply to: ↑ 53 Changed 9 years ago by tuberbob

Replying to Robby:

tuberbob, PidginGuy?,

please fix your FSUES issues.

LOL - seriously. That was actually pretty funny! I like that you think my comment had something to do with entitlement issues. Are you implying that people using free software are not entitled to support?

@datallah - thanks for the response. I appreciate what you all do as developers, and I hope you understood that. I'm with PidginGuy? here, in that I tell everyone I know who uses a chat app to use this one. I guess what happened, in my mind, is similar to what my dad used to tell me when I was in school...doing a good job is akin to screwing up by proving you CAN do it! You guys have had a pretty solid track record of awesome releases. Naturally crashes take precedence over an annoyance. Perhaps the fact that this annoyance happens to be so visible (to Windows users, at least)caused a higher level of response, and the fact that this bump in the road comes on the heels of a string of quality updates makes it a little extra frustrating for us users. Whatever, it's all good now, and thanks for the explanation of the process; I admit, I honestly overlooked the fact that the devs are not the only testers, and for that, I apologize. Keep up the good work! (btw, in case it is not clear, the .dll worked for me too.)

comment:66 Changed 9 years ago by rekkanoryo

Ticket #11938 has been marked as a duplicate of this ticket.

comment:67 in reply to: ↑ 43 Changed 9 years ago by ivanatpr

Replying to datallah:

We don't provide nightlies, but I have uploaded a replacement pidgin.dll that contains the flashing fix for people to use until 2.7.1 is released.

Thanks for the workaround. Don't let the FSUES sufferers get to you; they are far outnumbered by those of us who are simply grateful for your help.

Once thing I'd suggest to make this a bit easier to find is changing the link to this ticket in the main support page (http://pidgin.im/support/) to link directly to your comment with the dll. (http://developer.pidgin.im/ticket/11842#comment:43).

comment:68 Changed 9 years ago by Robby

Ticket #11956 has been marked as a duplicate of this ticket.

comment:69 Changed 9 years ago by Robby

Ticket #11961 has been marked as a duplicate of this ticket.

comment:70 Changed 9 years ago by datallah

Ticket #11976 has been marked as a duplicate of this ticket.

comment:71 in reply to: ↑ 47 Changed 9 years ago by pit

Replying to NishaKitty:

Replying to PidginGuy:

Replying to datallah:

We don't provide nightlies, but I have uploaded a replacement pidgin.dll that contains the flashing fix for people to use until 2.7.1 is released.

This worked for me. Thanks, but I'm still a bit angry that you guys could have missed this when giving us all a new version.

I'm still confused about my previous question though: is there a way to make the input text area of the IM window taller?

Perhaps you're looking for Tools -> Preferances -> Conversations -> Minimum input area height in lines.

Also commenting on the Flashing thing while I agree the patch is nice and thanks for making it datallah :) such an obvious bug and one that makes using the client a very large task on Windows should've been picked up in some sort of testing...

There is also a plugin (via guifications IIRC) that allows you to just drag and resize on the fly. Very nice.

comment:72 Changed 9 years ago by Robby

Ticket #11991 has been marked as a duplicate of this ticket.

comment:73 Changed 9 years ago by darkrain42

Ticket #12019 has been marked as a duplicate of this ticket.

comment:74 Changed 9 years ago by datallah

Ticket #12027 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!