Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11846 closed defect (fixed)

Notification are does not show icons

Reported by: schmatzler Owned by: QuLogic
Milestone: 2.7.1 Component: pidgin (gtk)
Version: 2.7.0 Keywords:
Cc: spatz, HekMek, xihr

Description

I have build the new Pidgin and now it doesn't show any icons in the notification area. All I see is a red cross.

Attachments (4)

pidgin.jpg (9.8 KB) - added by schmatzler 9 years ago.
ubuntu804lts-xfce4-pidgin270-bug.png (7.5 KB) - added by fwolf 9 years ago.
centos-theme-files.tar.gz (5.0 KB) - added by nosnilmot 9 years ago.
Centos theme files
index.theme (454 bytes) - added by QuLogic 9 years ago.

Download all attachments as: .zip

Change History (38)

Changed 9 years ago by schmatzler

comment:1 Changed 9 years ago by darkrain42

  • Component changed from unclassified to pidgin (gtk)
  • Owner changed from rekkanoryo to QuLogic

comment:2 Changed 9 years ago by QuLogic

  • Status changed from new to pending

Do you have <prefix>/share/pixmaps/pidgin/tray/hicolor/<size>x<size>/* for size=16,22,32,48?

comment:3 Changed 9 years ago by spatz

I have this bug and all the tray icon files exist where you said. I use KDE, if that makes any difference.

comment:4 follow-up: Changed 9 years ago by timo

I have this on Centos 5.X running gnome. This is my fix,

sudo ln -s <prefix>/share/pixmaps/pidgin/tray/hicolor <prefix>/share/pixmaps/pidgin/tray/gnome

Adjust for your <prefix> accordingly.

comment:5 Changed 9 years ago by QuLogic

What version of GTK+ are you using?

comment:6 Changed 9 years ago by QuLogic

Also, does CentOS not have /usr/share/icons/hicolor/?

comment:7 follow-up: Changed 9 years ago by fwolf

I've encountered the same problem. Using XFCE 4.3 and libgtk 2.12 on Ubuntu 8.04.04 LTS. Also see attached screenshot (ubuntu804lts-xfce4-pidgin270-bug.png).

Mentioned fix didnt work.

Thus, I'm going to dl the packages and take a look at their guts. After that, we know a bit more what part of the install process has been fucked up, to promptly get this bug fixed ;)

cu, w0lf.

Changed 9 years ago by fwolf

comment:8 Changed 9 years ago by schmatzler

  • Status changed from pending to new

Fix didn't work for me either.

I am using GTK+ 2.12.9

comment:9 in reply to: ↑ 7 ; follow-up: Changed 9 years ago by fwolf

Replying to fwolf:

Thus, I'm going to dl the packages and take a look at their guts. After that, we know a bit more what part of the install process has been fucked up, to promptly get this bug fixed ;)

I've compared the structures of the related (Ubuntu) packages with 2.6.6 and 2.5.5 and they seem to be equal - I guess it must be a bug inside the coding itself. Maybe some fuck up during GTK+ replacements for windows?

cu, w0lf.

comment:10 in reply to: ↑ 9 ; follow-ups: Changed 9 years ago by darkrain42

Replying to fwolf:

Replying to fwolf:

Thus, I'm going to dl the packages and take a look at their guts. After that, we know a bit more what part of the install process has been fucked up, to promptly get this bug fixed ;)

I've compared the structures of the related (Ubuntu) packages with 2.6.6 and 2.5.5 and they seem to be equal - I guess it must be a bug inside the coding itself. Maybe some fuck up during GTK+ replacements for windows?

cu, w0lf.

Which 2.6.6 package -- 2.6.6 vanilla (i.e. the tarball from us) and from the PPA did not include the GtkStatusIcon, and Ubuntu's version of it used a number of links to place the icons in the proper place where the GtkStatusIcon would look for them.

Pidgin 2.7.0 and the PPA package for 8.04 (instructions) place the icons in the proper place and should work properly.

comment:11 in reply to: ↑ 10 Changed 9 years ago by fwolf

Replying to darkrain42:

Replying to fwolf:

Replying to fwolf:

Thus, I'm going to dl the packages and take a look at their guts. After that, we know a bit more what part of the install process has been fucked up, to promptly get this bug fixed ;)

Pidgin 2.7.0 and the PPA package for 8.04 (instructions) place the icons in the proper place and should work properly.

well, _I AM USING_ the PPA package - this release was installed directly from the PPA repository, as were its predecessors.

cu, w0lf.

comment:12 follow-up: Changed 9 years ago by darkrain42

What version is installed?

comment:13 in reply to: ↑ 12 Changed 9 years ago by fwolf

Replying to darkrain42:

What version is installed?

2.7.0.

cu, w0lf.

comment:14 Changed 9 years ago by darkrain42

No, the full debian package version, not just the version of Pidgin (perhaps you should join #pidgin on Freenode, where this would be a lot easier)

comment:15 Changed 9 years ago by darkrain42

fwolf was using the first version of packages uploaded to the PPA, which exhibited this issue (my bad! Thanks go to Cobalt for noticing very quickly), which I've subsequently fixed. That likely won't impact most of the others on this ticket, though.

comment:16 in reply to: ↑ 10 Changed 9 years ago by fwolf

Replying to darkrain42:

Replying to fwolf:

Replying to fwolf:

Thus, I'm going to dl the packages and take a look at their guts. After that, we know a bit more what part of the install process has been fucked up, to promptly get this bug fixed ;)

I've compared the structures of the related (Ubuntu) packages with 2.6.6 and 2.5.5 and they seem to be equal - I guess it must be a bug inside the coding itself. Maybe some fuck up during GTK+ replacements for windows?

cu, w0lf.

Which 2.6.6 package -- 2.6.6 vanilla (i.e. the tarball from us) and from the PPA did not include the GtkStatusIcon, and Ubuntu's version of it used a number of links to place the icons in the proper place where the GtkStatusIcon would look for them.

Pidgin 2.7.0 and the PPA package for 8.04 (instructions) place the icons in the proper place and should work properly.

Seems to be fixed in the by now uploaded PPA package (2.7.0-0ubuntu1.1~pidgin1.08.04 that is).

cu, w0lf.

comment:17 in reply to: ↑ 4 ; follow-up: Changed 9 years ago by fwolf

Replying to timo:

I have this on Centos 5.X running gnome. This is my fix,

sudo ln -s <prefix>/share/pixmaps/pidgin/tray/hicolor <prefix>/share/pixmaps/pidgin/tray/gnome

Adjust for your <prefix> accordingly.

Note: Right after updating my installed version with the newer one in the PPA, the icons did change into some crude bigger version of the usual icons (approx. twice of the regular size). Maybe indeed just some path problems? So the next steps probably would be:

a) Where does Pidgin expect to find its tray icons? b) What function / method call is used to fetch the tray icon? c) What is this function / method call relaying onto? GTK+? direct file i/o? Some alias / wrapper function?

cu, w0lf.

comment:18 in reply to: ↑ 17 Changed 9 years ago by schmatzler

I don't know if it helps, but other Status icon themes also don't work, for example this one:

http://ebupof.deviantart.com/art/Old-Pidgin-Status-icon-theme-144392384

comment:19 Changed 9 years ago by darkrain42

Ticket #11974 has been marked as a duplicate of this ticket.

comment:20 Changed 9 years ago by xihr

The symlink fix above works for me as well, CentOS 5.5 running GNOME.

comment:21 Changed 9 years ago by nosnilmot

If on CentOS 5 and you are experiencing this issue, do you have librsvg2 installed?

If not, does installing it (yum install librsvg2) fix the tray icon?

(I'm not sure why the fallback to fixed sized icons is not working, but it clearly isn't)

Edit: Ignore those questions, I was distracted by an unrelated log message.

comment:22 Changed 9 years ago by QuLogic

Can someone on CentOS please attach /usr/share/icons/hicolor/index.theme and /usr/share/icons/gnome/index.theme?

Changed 9 years ago by nosnilmot

Centos theme files

comment:23 follow-up: Changed 9 years ago by QuLogic

Can you try placing the attached index.theme in /usr/share/pixmaps/pidgin/tray/hicolor/?

Changed 9 years ago by QuLogic

comment:24 in reply to: ↑ 23 ; follow-up: Changed 9 years ago by nosnilmot

Replying to QuLogic:

Can you try placing the attached index.theme in /usr/share/pixmaps/pidgin/tray/hicolor/?

That didn't help, and from strace it doesn't look like it is looking there.

comment:25 in reply to: ↑ 24 ; follow-up: Changed 9 years ago by QuLogic

Replying to nosnilmot:

That didn't help, and from strace it doesn't look like it is looking there.

Hmm, you're right. If you run gtk-update-icon-cache for that directory, does it work then?

From my strace, it does attempt to check the cache file, at least. Whether it uses that cache to load the files, I don't know, though.

comment:26 in reply to: ↑ 25 Changed 9 years ago by nosnilmot

Replying to QuLogic:

Replying to nosnilmot:

That didn't help, and from strace it doesn't look like it is looking there.

Hmm, you're right. If you run gtk-update-icon-cache for that directory, does it work then?

No, that doesn't help.

From my strace, it does attempt to check the cache file, at least. Whether it uses that cache to load the files, I don't know, though.

I didn't see it checking for the .../tray/hicolor/icon-theme.cache but it was trying to open .../tray/icon-theme.cache, but moving the index.theme up a level and recreating the cache there didn't work either.

comment:27 follow-up: Changed 9 years ago by nosnilmot

The problem is the hicolor-icon-theme package on CentOS 5 is too old (0.9) to support the "Status" context, from here:

If your system is using the version 0.9 of hicolor, you can install your icons in $prefix/share/<appname>/icons/hicolor/<size>/status, but those icons will be ignored at runtime, 'cause the list of directories to watch in system or local hicolor directories is defined in the index.theme provided by hicolor-icon-theme.

I'm not sure what the best thing to do is. The symlink trick works because gnome-icon-theme does define the "Status" context directories, but this will only work for themes that inherit the "gnome" theme.

comment:28 in reply to: ↑ 27 Changed 9 years ago by schmatzler

Replying to nosnilmot:

The problem is the hicolor-icon-theme package on CentOS 5 is too old (0.9) to support the "Status" context

I just installed hicolor-icon-theme 0.12 (previously I had 0.10) and the notification area is working again :) Thank you.

I am on KDE 3.5 using Vectorlinux 6.

comment:29 Changed 9 years ago by QuLogic

Ticket #11959 has been marked as a duplicate of this ticket.

comment:30 follow-up: Changed 9 years ago by clh

I have the same effect under Solaris. For me the issue seems to be that pidgin is not installed under a default system path, but does not look for icons in the path it is installed in.

From truss on pidgin: 25994: stat64("/home/clemens/.icons/hicolor/index.theme", 0xFFBFD040) Err#2 ENOENT 25994: stat64("/home/clemens/.local/share/icons/hicolor/index.theme", 0xFFBFD040) Err#2 ENOENT 25994: stat64("/usr/local/share/icons/hicolor/index.theme", 0xFFBFD040) Err#2 ENOENT 25994: stat64("/usr/share/icons/hicolor/index.theme", 0xFFBFD040) = 0

However, pidgin is installed in some weird path under /sw/...

Linking the /sw/... icons path to /home/clemens/.local/share/icons fixes the issue for me. Unfortunately i do not have access to either /usr/share nor /usr/local, so every user has to fix this himself.

comment:31 in reply to: ↑ 30 ; follow-up: Changed 9 years ago by nosnilmot

Replying to clh:

I have the same effect under Solaris.

What version of hicolor-icon-theme do you have?

comment:32 in reply to: ↑ 31 Changed 9 years ago by clh

Replying to nosnilmot:

Replying to clh:

I have the same effect under Solaris.

What version of hicolor-icon-theme do you have?

I'm using a self compiled GTK+ 2.14.7 in a nonstandard location with the standard gnome coming with S10. I don't know how to get at the theme version, but its probably very old.

I now found a workaround to set

export XDG_DATA_DIRS=</my/pidgin/and/gtk/path>:/usr/local/share/:/usr/share/

Since i use a wrapper script anyways, this is an acceptable workaround for me.

comment:33 Changed 9 years ago by qulogic@…

  • Milestone set to 2.7.1
  • Resolution set to fixed
  • Status changed from new to closed

(In 3083d5a5d5b46193be6849e67ddef5bb26111789):
Add a configure option --enable-trayicon-compat which installs tray icons into a directory compatible with older versions of hicolor-icon-theme. Use this option on distros that don't have a new enough copy. If you actually have a new enough copy, this option should not have any adverse effects.

Fixes #11846.

comment:34 Changed 9 years ago by QuLogic

Ticket #12073 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!