Opened 9 years ago

Closed 7 years ago

#11848 closed defect (fixed)

Can't send file via ICQ with drag'n'drop

Reported by: Phagos Owned by: datallah
Milestone: 2.10.7 Component: winpidgin (gtk)
Version: 2.7.0 Keywords:
Cc:

Description

Pidgin doesn't accept file for transfer via ICQ by drag'n'drop

P.S. Windows 7

Attachments (1)

pidgin-installer.nsi.patch (2.6 KB) - added by Phagos 9 years ago.
first run issue solver

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by Phagos

It looks like it was some sort of gtk misbehavior, because everything works fine now (including some other things that have not previously)... Can anybody verify this?

comment:2 follow-up: Changed 9 years ago by Phagos

This misbehaviour occurs when app was launched by installer's "Run Pidgin" option. When launched by shortcut everything's ok.

P.S. It also applies to automatic keyboard layout switcher I use. It doesn't work neither in automatic mode, nor with hotkeys when pidgin was launched by installer.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 9 years ago by darkrain42

  • Component changed from unclassified to winpidgin (gtk)
  • Owner changed from rekkanoryo to datallah

Replying to Phagos:

This misbehaviour occurs when app was launched by installer's "Run Pidgin" option. When launched by shortcut everything's ok.

I wonder if this is related to UAC. If Pidgin is run via the installer, it's going to be running as a privileged application (either as a different user or elevated), and there might be OS-level differences in DnD behavior for said applications.

Or I could be completely off base.

comment:4 Changed 9 years ago by darkrain42

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.

comment:5 in reply to: ↑ 3 ; follow-up: Changed 9 years ago by Phagos

  • Status changed from pending to new

Replying to darkrain42:

I wonder if this is related to UAC. If Pidgin is run via the installer, it's going to be running as a privileged application (either as a different user or elevated), and there might be OS-level differences in DnD behavior for said applications.


I've checked this. Yes, it is. Running file manager or switcher with administrator's rights solves the problem.

Also I've found an article (unfortunately it's in russian) which states there're following issues when installing by non-admin account:

  • user's shortcuts, private files and so on could be placed in admins accont directories;
  • when app is run via the installer (i.e. with admin's rights) changes are made with admin's files (e.g. pidgin's log seems to be written in admin's account directory instead of user's one) and therefore they are lost.

The solution is to use UAC plug-in for NSIS, but unfortunately I get "This installer requires admin access, aborting!" error using modified pidgin's installer on Windows 7 x86.
Installer is run under the admin's account, UAC's prompt appears, but nevertheless this error does occur.

comment:6 in reply to: ↑ 5 Changed 9 years ago by Phagos

Replying to Phagos:

The solution is to use UAC plug-in for NSIS, but unfortunately I get "This installer requires admin access, aborting!" error using modified pidgin's installer on Windows 7 x86.

Using ANSI-version of plugin solved this problem.
UAC_RealWorldFullyLoadedDualModeExample.nsi gives the desired result. I'll try to adopt it for our needs.

comment:7 Changed 9 years ago by Phagos

I've solved the first run issue but haven't tested other ones that could be caused by UAC

Changed 9 years ago by Phagos

first run issue solver

comment:8 Changed 7 years ago by Phagos

  • Milestone set to 2.10.7
  • Resolution set to fixed
  • Status changed from new to closed

As there's no more "Run Pidgin" option due to ticket:12443#comment:5, I see no reason for leaving #11848 opened.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!