Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11850 closed patch (fixed)

2.7.0: media/backend-fs2.h:62:21: error: gst/gst.h: No such file or directory

Reported by: Polynomial-C Owned by:
Milestone: 2.7.1 Component: libpurple
Version: 2.7.0 Keywords:
Cc: Maiku, salinasv, pva

Description

Although I disabled gstreamer via configure, compilation still fails. Please see attached logfile of the build process. I can also provide a possible fix.

Attachments (2)

build.log (176.4 KB) - added by Polynomial-C 7 years ago.
This is the logfile of the failed build.
pidgin-2.7.0-fix-build-without-gst.patch (497 bytes) - added by Polynomial-C 7 years ago.
pidgin-2.7.0-fix-build-without-gst.patch

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by Polynomial-C

This is the logfile of the failed build.

Changed 7 years ago by Polynomial-C

pidgin-2.7.0-fix-build-without-gst.patch

comment:1 Changed 7 years ago by darkrain42

  • Milestone set to 2.7.1
  • Type changed from defect to patch

comment:2 Changed 7 years ago by darkrain42

  • Cc Maiku added

Possibly related patch (solving the same issue in a different way?)

It's unclear to me why media/backend-fs2.c is being built if gstreamer is not available.

comment:3 Changed 7 years ago by pva

This is rather important issue for Gentoo, since people use pidgin without gstreamer. Could anybody review suggested solutions? Thanks in advance.

comment:4 Changed 7 years ago by rekkanoryo

If things actually *work* with this patch (i.e. the build succeeds and nothing crashes), then I see no reason not to apply this patch.

comment:5 Changed 7 years ago by MarkDoliner

  • Resolution set to fixed
  • Status changed from new to closed

I applied the change from this ticket. Thanks!

comment:6 Changed 7 years ago by markdoliner@…

(In 8bed7d7fb4c6f9b50345dee72e2c4ecea574dba6):
Apply Polynomial-C's suggestion for fixing a compile error with --disable-gstreamer and --disable-vv. I think there will be a compiler errow with --disable-gstreamer and vv enabled, but that doesn't seem important. I'm guessing most people who use vv also use gstreamer? Is that ALWAYS true?

Fixes #11850

comment:7 Changed 7 years ago by QuLogic

Ticket #12039 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!