Opened 9 years ago

Closed 9 years ago

#11877 closed defect (duplicate)

Segmentation fault, oscar_normalize()

Reported by: msschlt Owned by:
Milestone: Component: libpurple
Version: 2.7.0 Keywords: Segmentation fault oscar_normalize
Cc:

Description

If i receive an ICQ msg sent via Adium 1.3.10 (Mac OSX 10.6.3) I get these:

Program received signal SIGSEGV, Segmentation fault.

#0 0x00007ffff4a99ca0 in strcpy_chk () from /lib/libc.so.6

#1 0x00007fffe595d846 in oscar_normalize () from /usr/lib/purple-2/liboscar.so.0

pidgin 2.7.0, libpurple/protocols/oscar/oscar.c, oscar_normalize():

tmp1 = g_utf8_strdown(buf, -1);

tmp2 = g_utf8_normalize(tmp1, -1, G_NORMALIZE_DEFAULT);

g_utf8_normalize(), man: Returns : NULL if str is not valid UTF-8.

strcpy(buf, tmp2); crash, because tmp2 = NULL

My workaround:

tmp1 = g_utf8_strdown(buf, -1);

if(!g_utf8_validate(tmp1, -1, NULL)) {

g_free(tmp1);

return NULL;

}

tmp2 = g_utf8_normalize(tmp1, -1, G_NORMALIZE_DEFAULT);

strcpy(buf, tmp2);

Attachments (1)

pidgin-backtrace.log (8.1 KB) - added by msschlt 9 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by Robby

  • Version changed from 2.7.0 to 2.5.9

comment:2 Changed 9 years ago by darkrain42

  • Status changed from new to pending

Please follow the instructions to get a backtrace and attach it to this ticket.
Please get a complete backtrace.

comment:3 Changed 9 years ago by darkrain42

  • Version changed from 2.5.9 to 2.7.0

Robby, I think the reporter is saying that an IM from Adium 1.3.10 crashes Pidgin, not that the reporter is using that version of Adium. (I may be mistaken)

comment:4 Changed 9 years ago by Robby

Oops, sorry, Paul, you're right, I misread.

Changed 9 years ago by msschlt

comment:5 Changed 9 years ago by msschlt

  • Status changed from pending to new

Attachment (pidgin-backtrace.log) added by ticket reporter.

comment:7 Changed 9 years ago by darkrain42

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #11863.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!