Opened 7 years ago

Closed 5 years ago

Last modified 4 years ago

#11886 closed defect (fixed)

added word in dictionary are not saved after Pidgin restart

Reported by: Dirtsa Owned by: datallah
Milestone: 2.10.4 Component: winpidgin (gtk)
Version: 2.7.0 Keywords: dictionary
Cc: Dawudd, crmsystem

Description (last modified by Dirtsa)

i added a new word to dictionary. After restart Pidgin it is marked as unknown word again. It seems that new words are first saved in %appdata%\enchant\language.dic and after a Pidgin restart it is away. All files in %appdata%\enchant\language.dic have 0 KB again.

Attachments (1)

gtkspell.jpg (61.9 KB) - added by Dirtsa 7 years ago.

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by Dirtsa

comment:1 Changed 7 years ago by datallah

  • Component changed from unclassified to winpidgin (gtk)
  • Owner changed from rekkanoryo to datallah

comment:2 Changed 7 years ago by Dirtsa

  • Description modified (diff)
  • Keywords dictionary added; dictonary removed

comment:3 Changed 7 years ago by datallah

I have been able to recreate this.

It appears to be an enchant bug.

comment:4 Changed 7 years ago by datallah

I'm pretty sure the cause is this enchant bug. I'll try to get a 1.6.0 build to see if that resolves it.

comment:5 Changed 6 years ago by datallah

Ticket #14902 has been marked as a duplicate of this ticket.

comment:6 Changed 5 years ago by diamon4

I love Pidgin, but the inability to have or save custom dictionaries is starting to make me a bit crazy. Bug has persisted through 2.10.3 now. Is there any word on a fix? I can't seem to locate an updated DLL file for libenchant.dll 1.5.0, and trying to use libenchant 1.6.0's dll didn't work.

To update the info, for the record... I can add a word to the dictionary and it gets added to my personal dictionary file. When I close Pidgin the file has contents. When I run Pidgin again, the custom dictionary gets zeroed out. Closing Pidgin again will of course save the 0-byte file.

OS is Windows XP. Thank you for your time!

comment:7 Changed 5 years ago by datallah@…

  • Milestone set to 2.10.4
  • Resolution set to fixed
  • Status changed from new to closed

(In c5b3879b829a5067b2189e4393ca3b80f6fd96c3):
Upgrade win32 version of enchant to 1.6.0. Fixes #11886

comment:8 follow-up: Changed 4 years ago by crmsystem

I'm still seeing this issue in the latest release. Maybe i'm misunderstanding the concept. We are building a crm system and using pidgin for the build in chat in the crm system. When a client is writing new words they are not automaticly stored in the crm systems dictionary. Do we need to make some costum code for this in the crm system. I think pidgin would take care of this for us with this patch, so that there is no need to add specific code in the crm system for this.

Best regards crm system

comment:9 in reply to: ↑ 8 Changed 4 years ago by crmsystem

Never mind it was my mistake. It works fine after installing the "correct" latest version.

Kind regards. Crm system.


Replying to crm system:

I'm still seeing this issue in the latest release. Maybe i'm misunderstanding the concept. We are building a crm system and using pidgin for the build in chat in the crm system. When a client is writing new words they are not automaticly stored in the crm systems dictionary. Do we need to make some costum code for this in the crm system. I think pidgin would take care of this for us with this patch, so that there is no need to add specific code in the crm system for this.

Best regards crm system

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!