Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11889 closed defect (fixed)

Pidgin installs incorrectly because GTK download always fails on dialup

Reported by: bigbadsteve Owned by: datallah
Milestone: 2.7.1 Component: winpidgin (gtk)
Version: 2.7.0 Keywords: pidgin GTK windows installation install
Cc: pidgin.20.bigbadsteve@…

Description

Pidgin 2.7.0 [for Windows] installation fails on dialup. I tried installation four times, including a few hours after the first attempt, and it failed the same way every time with message "Error Downloading the GTK+ runtime: [url]".

The options given in the popup message box are 'Retry' and 'Cancel'. When the latter is selected, the installer merrily proceeds anyway, leaving a bollixed Pidgin installed which aborts when it is run.

I managed to separately download GTK using the url displayed in the error message as a workaround, but it has no installer so I don't know what to do with it.

Had no problems installing recent versions of Pidgin prior to this release.

Attachments (1)

Pidgin_aborts_during_GTK_download.png (19.1 KB) - added by bigbadsteve 9 years ago.
Abort error message

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by bigbadsteve

Abort error message

comment:1 Changed 9 years ago by datallah@…

  • Milestone set to 2.7.1
  • Resolution set to fixed
  • Status changed from new to closed

(In 2a7ad9dd15f080096423a10b56336b0f1c25783a):
Allow the GTK+ Runtime to be unselected when there is no existing runtime (but not when there is an existing runtime that is too old). This allows "advanced" users to more easily reuse a global GTK+ runtime if they choose to do so.

Additionally, this provides some additional alerts and hints about what to do when downloading the GTK+ Runtime or Spellchecking dictionary fails.

Fixes #11852, #11889

comment:2 Changed 9 years ago by datallah

Ticket #11905 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by datallah

Ticket #11923 has been marked as a duplicate of this ticket.

comment:4 Changed 9 years ago by datallah

Ticket #11966 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!