Opened 9 years ago

Closed 8 years ago

#11895 closed patch (fixed)

Selecting "none" ICQ x-status is works only after re-login to server

Reported by: xorik Owned by: ivan.komarov
Milestone: 2.8.0 Component: ICQ
Version: 2.7.0 Keywords: icq x-status
Cc:

Description

When I select Accounts -> ICQ -> Set mood -> "none", nothing happens. X-status is disables after logout and login to ICQ server again.

Attachments (1)

xstatus-unset_mood.patch (663 bytes) - added by dustin 8 years ago.
Fix to make unsetting the x-status mood work

Download all attachments as: .zip

Change History (11)

comment:1 Changed 9 years ago by rekkanoryo

  • Component changed from unclassified to ICQ
  • Keywords status removed
  • Owner changed from rekkanoryo to MarkDoliner

Changed 8 years ago by dustin

Fix to make unsetting the x-status mood work

comment:2 Changed 8 years ago by dustin

This patch allows unsetting a status.

In oscar_set_status(), only activating a status was possible, but no deactivation.

This is fine for exclusive statuses (like availability), but doesn't consider the case of moods, which are independent statuses that can also be deactivated (i.e., set to "none").

(Even with this patch applied, deactivating the x-status does not work with Miranda for some reason.)

comment:3 Changed 8 years ago by rekkanoryo

  • Milestone set to Patches Needing Review
  • Type changed from defect to patch

comment:4 Changed 8 years ago by ivan.komarov

  • Owner changed from MarkDoliner to ivan.komarov

comment:5 Changed 8 years ago by rekkanoryo

Ticket #13526 has been marked as a duplicate of this ticket.

comment:6 follow-up: Changed 8 years ago by MarkDoliner

This looks good to me.

dustin: Do you I have a name I can use for you in our ChangeLog and COPYRIGHT file?

comment:7 in reply to: ↑ 6 Changed 8 years ago by dustin

Replying to MarkDoliner:

This looks good to me.

dustin: Do you I have a name I can use for you in our ChangeLog and COPYRIGHT file?

Of course. Full name is Dustin Gathmann.

comment:8 Changed 8 years ago by dustin

From current Changelog:

	ICQ:
	* Fix unsetting your mood when "None" is selected. (#7431)

Should be this ticket, #11895.

comment:9 Changed 8 years ago by Robby

  • Milestone changed from Patches Needing Review to 2.8.0

comment:10 Changed 8 years ago by rekkanoryo

  • Resolution set to fixed
  • Status changed from new to closed

I committed this patch. I don't know the revision offhand, but it will be in 2.8.0 when it is released in a few weeks.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!