Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11922 closed defect

System tray icon is way too small

Reported by: johnpatcher Owned by: QuLogic
Milestone: Component: pidgin (gtk)
Version: 2.7.0 Keywords: system tray icon small
Cc: metalzelot, zx2c4

Description

I'm running Piding 2.7.0 under KDE 4.4.3 with GTK 2.20.1.

However the system tray icon is way too small compared to the others surrounding it (see screenshot). Unfortunately I can't backtrack the problem.

As all other icons work fine (including the ones from other GTK+ applications) there must be something wrong with Pidgin itself.

If you need some more information, just ask for it.

Attachments (2)

snapshot.png (53.9 KB) - added by johnpatcher 9 years ago.
Screenshot of my system tray
systemtray-multiple-entries.png (72.6 KB) - added by metalzelot 9 years ago.
System tray with empty slots and system tray settings showing multiple pidgin entries

Download all attachments as: .zip

Change History (15)

Changed 9 years ago by johnpatcher

Screenshot of my system tray

comment:1 Changed 9 years ago by rekkanoryo

  • Component changed from unclassified to pidgin (gtk)
  • Owner changed from rekkanoryo to QuLogic

comment:2 Changed 9 years ago by QuLogic

  • Status changed from new to pending

I'm not sure I see any other GTK+ applications in your screenshot. What size is your panel? Also, please check whether you have /usr/share/pixmaps/pidgin/tray/hicolor/<size>x<size>/* for size=16,22,32,48.

comment:3 follow-up: Changed 9 years ago by darkrain42

In addition to that, what GTK+ applications did you try with (not all use the same tray icon method that Pidgin now uses)?

comment:4 in reply to: ↑ 3 ; follow-up: Changed 9 years ago by johnpatcher

  • Status changed from pending to new

Replying to QuLogic:

I'm not sure I see any other GTK+ applications in your screenshot.

There weren't any running at the screenshot, my fault.

Replying to QuLogic:

What size is your panel?

To be honest, I don't know, I've changed it manually, but no height is shown. However changing it up (or down) doesn't fix it.

Replying to QuLogic:

Also, please check whether you have /usr/share/pixmaps/pidgin/tray/hicolor/<size>x<size>/* for size=16,22,32,48.

Yeah, those folders exist. However there is only a directory "/usr/share/pixmaps/pidgin/tray/16", but I guess this is normal?

Replying to darkrain42:

In addition to that, what GTK+ applications did you try with (not all use the same tray icon method that Pidgin now uses)?

I tried it with SMPlayer and jdownloader (both set up to use the GTK+ interface), but probably they implement the system tray in a different way. I figured out that bluetooth-applet (part of gnome-bluetooth) suffers from the same problem. So it seems that it is a more generic problem (with GTK+?). Anything I can do about it? How can we figure out what the issue is about?

comment:5 in reply to: ↑ 4 ; follow-up: Changed 9 years ago by QuLogic

  • Status changed from new to pending

Replying to johnpatcher:

Replying to darkrain42:

In addition to that, what GTK+ applications did you try with (not all use the same tray icon method that Pidgin now uses)?

I tried it with SMPlayer and jdownloader (both set up to use the GTK+ interface), but probably they implement the system tray in a different way. I figured out that bluetooth-applet (part of gnome-bluetooth) suffers from the same problem. So it seems that it is a more generic problem (with GTK+?). Anything I can do about it? How can we figure out what the issue is about?

You can try this out: teststatusicon.c (You also need prop-editor.c and prop-editor.h) You'll probably need to file a bug with the GTK+ people to find out more, though.

comment:6 in reply to: ↑ 5 Changed 9 years ago by johnpatcher

  • Status changed from pending to new

Replying to QuLogic:

You'll probably need to file a bug with the GTK+ people to find out more, though.

Are you sure this is a problem with GTK+? I would guess that this is a problem with KDE (Plasma) as it works quite well with Gnome, doesn't it? So maybe I should file a bug with the KDE people rather than the GTK+ people?

comment:7 Changed 9 years ago by metalzelot

I have the same problem since the update to Pidgin 2.7.0 and I'm also using KDE 4.4.3 and GTK 2.20.1 on Archlinux.

Before the update to Pidgin 2.7.0 the bug described in ticket #2466 affected me. This problem could always be resolved with changing the system tray visiblity to "never" and back to "always" (in preferences - interface - show system tray icon).

If I try the same to solve this problem the pidgin tray icon disappears when changing the option to "never" and the area in the system tray is left empty. If I move with the mouse over the empty system tray area I get a tooltip saying "Pidgin - Available" (or whatever the status was when I changed the preference option). But I do not get a context menu and can not activate pidgin with a left click on it.

When I set the visiblity option back to "always" a new entry in the system tray is created. Every time I repeat this I get one more empty system tray slot.

Also in the system tray settings of KDE I end up with multiple entries. The system tray with the wrong sized icon and multiple empty slots together with the system tray settings can be seen in the attached screenshot.

Changed 9 years ago by metalzelot

System tray with empty slots and system tray settings showing multiple pidgin entries

comment:8 follow-up: Changed 9 years ago by johnpatcher

I think it has something to do with the GTK theme. I'm using "kde44-oxygen-molecule", using "Raleigh" solves the issue, although its quite ugly ;). Can anyone confirm this?

comment:9 Changed 9 years ago by QuLogic

  • Status changed from new to pending

metalzelot:

The multiple entries thing is #11913.

johnpatcher:

You never said what distribution you were using. Perhaps you are running into a similar problem of a broken hicolor theme installed by KDE as in #11941.

comment:10 in reply to: ↑ 8 Changed 9 years ago by metalzelot

Replying to johnpatcher:

I think it has something to do with the GTK theme. I'm using "kde44-oxygen-molecule", using "Raleigh" solves the issue, although its quite ugly ;). Can anyone confirm this?

I can confirm this. I'm using the GTK theme "kde4-oxygen" to make GTK programs fit my Qt programs. If I change the theme back to "Raleigh" and restart Pidgin I get a normal sized icon.

comment:11 Changed 9 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:12 Changed 9 years ago by metalzelot

This ticket should be reopened. It was set to pending because information to the cause of a broken hicolor theme was requested. In my case the hicolor theme is not broken. Also in the screenshot of johnpatcher the icon is shown but wrongly sized, so bug #11941 can not be the same problem.

As pointed out by johnpatcher and me it has to do something with the GTK theme because it works fine when using the default theme which is "Raleigh".

Please reopen.

comment:13 Changed 9 years ago by zx2c4

Please re-open.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!