Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11941 closed defect (worksforme)

Broken tray icon for Pidgin 2.7.0 and KDE 3.5

Reported by: gagern Owned by:
Milestone: Component: pidgin (gtk)
Version: 2.7.0 Keywords: tray icon kde
Cc: HekMek

Description

Upgrading from Pidgin 2.6.6 to 2.7.0 breaks the tray icon for me on KDE 3.5: instead of an icon representing the status in front of a speech bubble, I get an icon with a question mark in front of a document. Downgrading to 2.6.6 "solves" the issue again.

Accoding to strace, the displyed image seems to be the one intended for unknown mime types: /usr/kde/3.5/share/icons/kdeclassic/32x32/mimetypes/unknown.png

I'm using Gentoo Linux, and installed both versions from their respective Gentoo ebuilds. As Gentoo no longer officially supports KDE 3.5, though, I'm filing this bug report directly with you.

Change History (11)

comment:1 follow-up: Changed 9 years ago by QuLogic

  • Status changed from new to pending

What version of x11-themes/hicolor-icon-theme do you have installed?

comment:2 in reply to: ↑ 1 Changed 9 years ago by gagern

  • Status changed from pending to new

Replying to QuLogic:

What version of x11-themes/hicolor-icon-theme do you have installed?

x11-themes/hicolor-icon-theme-0.12 which seems to install "/usr/share/icons/hicolor/index.theme" and a number of originally empty directories.

My strace run doesn't mention the index.theme file from that package. Instead pidgin seems to try accessing index.theme files from a number of different directories, and is successful with two of these: "/usr/kde/3.5/share/icons/kdeclassic/index.theme" and "/usr/kde/3.5/share/icons/hicolor/index.theme".

comment:3 Changed 9 years ago by andrixnet

I can confirm the bug on Slackware 12 as well and pidgin 2.7.0

comment:4 Changed 9 years ago by schmatzler

Same problem on Vectorlinux 6.0 - seems to be a duplicate of #11846

comment:5 follow-up: Changed 9 years ago by QuLogic

  • Status changed from new to pending

Gentoo has a new enough copy of x11-themes/hicolor-icon-theme, but the problem is KDE is messing with the search path. There's a fix for it here (which probably isn't in KDE3): https://bugs.gentoo.org/show_bug.cgi?id=267018

Any similar problems on other distros should go in #11846.

comment:6 in reply to: ↑ 5 Changed 9 years ago by gagern

  • Status changed from pending to new

Replying to QuLogic:

the problem is KDE is messing with the search path. There's a fix for it here (which probably isn't in KDE3)

Thanks for the pointer. That solved it. I comitted a fix for Gentoo KDE 3.5.

What's the correct resolution state for a thing like this that has been fixed outside the Pidgin code base?

comment:7 Changed 9 years ago by rekkanoryo

  • Resolution set to worksforme
  • Status changed from new to closed

The closest thing we have is "worksforme" but if this case becomes common enough, I can set up a "notourbug" resolution.

comment:8 follow-ups: Changed 9 years ago by andrixnet

gagern, QuLogic : can you help, please with Slackware-12 which runs KDE 3.5? Seems that exporting that variable in the profile, or the kde.sh in /etc/profile.d doesn't help :(

comment:9 in reply to: ↑ 8 Changed 9 years ago by schmatzler

Replying to andrixnet: Have you tried installing hicolor-icon-theme 0.12?

http://icon-theme.freedesktop.org/wiki/HicolorTheme

I am running VectorLinux?, (it's based on Slack 12). That one helped.

You can also configure Pidgin 2.7.1 with --enable-trayicon-compat ;)

comment:10 in reply to: ↑ 8 Changed 9 years ago by gagern

Replying to andrixnet:

gagern, QuLogic : can you help, please with Slackware-12 which runs KDE 3.5? Seems that exporting that variable in the profile, or the kde.sh in /etc/profile.d doesn't help :(

Exporting what variable?

The central point to what I did was remove the hicolor directory installed by KDE. The only file it contained was index.theme, which was outdated and superseded by the version installed by the hicolor theme package. Removing the KDE file fixed search order and made things work as they should. I don't know if this solution is applicable to you, as I don't know what files the corresponding slackware packages contain, but I guess you can figure out.

comment:11 Changed 9 years ago by andrixnet

schmatzler : thank you, that did the trick

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!