Opened 9 years ago

Closed 9 years ago

#11955 closed defect (duplicate)

Segmentation Fault during startup

Reported by: inherited Owned by:
Milestone: Component: pidgin (gtk)
Version: 2.7.0 Keywords:
Cc:

Description (last modified by inherited)

After logging in into some accounts and showing the GUI for approx. one second, pidgin sometimes crashes with a segmentation fault.

Machine:

Linux Erinaceus 2.6.33-ARCH #1 SMP PREEMPT Thu May 13 11:32:37 CEST 2010 x86_64 Intel(R) Core(TM)2 CPU T7200 @ 2.00GHz GenuineIntel GNU/Linux

Backtrace:

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff4cfdcd0 in __strcpy_chk () from /lib/libc.so.6
(gdb) bt
#0  0x00007ffff4cfdcd0 in __strcpy_chk () from /lib/libc.so.6
#1  0x00007fffe0edb0a6 in oscar_normalize ()
   from /usr/lib/purple-2/liboscar.so.0
#2  0x00007ffff523b01b in purple_normalize () from /usr/lib/libpurple.so.0
#3  0x00007ffff51f09fc in purple_find_conversation_with_account ()
   from /usr/lib/libpurple.so.0
#4  0x00007ffff51f352c in purple_conv_present_error ()
   from /usr/lib/libpurple.so.0
#5  0x00007fffe0ece44d in purple_parse_msgerr ()
   from /usr/lib/purple-2/liboscar.so.0
#6  0x00007fffe0ec8d7b in snachandler () from /usr/lib/purple-2/liboscar.so.0
#7  0x00007fffe0ec7af2 in flap_connection_recv ()
   from /usr/lib/purple-2/liboscar.so.0
#8  0x000000000046891e in ?? ()
#9  0x00007ffff54feb33 in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
#10 0x00007ffff54ff310 in g_main_context_iterate ()
   from /usr/lib/libglib-2.0.so.0
#11 0x00007ffff54ff982 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#12 0x00007ffff6656907 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#13 0x000000000048170d in main ()

Change History (3)

comment:1 Changed 9 years ago by inherited

  • Description modified (diff)

comment:2 Changed 9 years ago by inherited

  • Description modified (diff)

comment:3 Changed 9 years ago by darkrain42

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #11863.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!