Opened 9 years ago

Closed 9 years ago

#11963 closed defect (duplicate)

Pidgin 2.7.0 crashing a lot

Reported by: Gregory Owned by: MarkDoliner
Milestone: Component: ICQ
Version: 2.7.0 Keywords:
Cc:

Description

AppName?: pidgin.exe AppVer?: 2.7.0.0 ModName?: msvcrt.dll ModVer?: 7.0.2600.5512 Offset: 000360cb

Attachments (2)

b798_appcompat.txt (86.7 KB) - added by Gregory 9 years ago.
pidgin.RPT (38.6 KB) - added by Gregory 9 years ago.

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by Gregory

comment:1 Changed 9 years ago by datallah

  • Status changed from new to pending

Please follow the instructions to get a backtrace and attach it to this ticket.

Changed 9 years ago by Gregory

comment:2 Changed 9 years ago by Gregory

  • Status changed from pending to new

Attachment (pidgin.RPT) added by ticket reporter.

comment:4 Changed 9 years ago by Gregory

Added stack trace report.

comment:5 Changed 9 years ago by darkrain42

  • Component changed from unclassified to ICQ
  • Owner changed from rekkanoryo to MarkDoliner

The vast majority of those crashes are #11863 (ignore the description if you're not triggering it that way, that's only one set of triggering circumstances).

This one is unique:

Error occured on Friday, May 14, 2010 at 14:07:15.

Windows Version 5.1 Build 2600 Service Pack 3

C:\Program Files\Pidgin\pidgin.exe caused an Access Violation at location 68881767 in module C:\Program Files\Pidgin\liboscar.dll Reading from location 03864000.

Registers:
eax=00000000 ebx=03598b10 ecx=fffffeef edx=03863ef0 esi=02cc24e8 edi=03864000
eip=68881767 esp=0022ecf0 ebp=0022ed00 iopl=0         nv up ei pl zr na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00010246

Call stack:
68881767 C:\Program Files\Pidgin\liboscar.dll  byte_stream_putstr
6888BD41 C:\Program Files\Pidgin\liboscar.dll  icq_im_xstatus_request
68884D0A C:\Program Files\Pidgin\liboscar.dll  buddylist_modfirst
68895298 C:\Program Files\Pidgin\liboscar.dll  flap_connection_send
         C:\Program Files\Pidgin\pidgin.dll [2.7.0.0]
64A7929B C:\Program Files\Pidgin\pidgin.dll  pidgin_eventloop_get_ui_ops
         C:\Program Files\Pidgin\Gtk\bin\libglib-2.0-0.dll [2.20.5.0]
685EA27B C:\Program Files\Pidgin\Gtk\bin\libglib-2.0-0.dll  g_main_context_dispatch
685ED185 C:\Program Files\Pidgin\Gtk\bin\libglib-2.0-0.dll  g_main_context_prepare
685ED574 C:\Program Files\Pidgin\Gtk\bin\libglib-2.0-0.dll  g_main_loop_run
         C:\Program Files\Pidgin\Gtk\bin\libgtk-win32-2.0-0.dll [2.16.6.0]
00B14260 C:\Program Files\Pidgin\Gtk\bin\libgtk-win32-2.0-0.dll  gtk_main
         C:\Program Files\Pidgin\pidgin.dll [2.7.0.0]
64A92F20 C:\Program Files\Pidgin\pidgin.dll  pidgin_main
         C:\Program Files\Pidgin\pidgin.exe [2.7.0.0]
00402161 C:\Program Files\Pidgin\pidgin.exe
00403286 C:\Program Files\Pidgin\pidgin.exe
004010B6 C:\Program Files\Pidgin\pidgin.exe
00401128 C:\Program Files\Pidgin\pidgin.exe
         C:\WINDOWS\system32\kernel32.dll [5.1.2600.5781]
7C817077 C:\WINDOWS\system32\kernel32.dll  RegisterWaitForInputIdle

comment:6 follow-up: Changed 9 years ago by Gregory

I'm never doing Get X-status manually. It's crashing itself.

comment:7 in reply to: ↑ 6 Changed 9 years ago by datallah

Replying to Gregory:

I'm never doing Get X-status manually. It's crashing itself.

Right, the crash in #11863 is not limited to the ticket description.

comment:8 Changed 9 years ago by Robby

  • Status changed from new to pending

Does this remain an issue in 2.7.3?

comment:9 Changed 9 years ago by Robby

  • Resolution set to duplicate
  • Status changed from pending to closed

Closed as duplicate of #12459.
Oh, I just see you filed #12459.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!