Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#11964 closed defect (fixed)

Char "<" cuts off status-messages

Reported by: MarG Owned by: MarkDoliner
Milestone: 2.7.5 Component: ICQ
Version: 2.7.0 Keywords: < tag ICQ status message statusmessage &lt
Cc:

Description

If someone uses a statusmessage in ICQ, with a "<"-char (&lt) in it, it cuts off the message in the tooltip and the "buddy-info"- window.

The buddylist seems to handle these characters different (but not correct either, see buddylist in screenshot).

Don't know, if other protocols have same issues. I noticed this in 2.6.x already.

Screenshot example attached (Original statusmessage " <-- hat jetzt ein Macbook" )

Attachments (1)

err.png (28.9 KB) - added by MarG 9 years ago.
Screenshot of the problem

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by MarG

Screenshot of the problem

comment:1 follow-up: Changed 9 years ago by darkrain42

  • Status changed from new to pending

Is this actually happening in Pidgin 2.7.0 or is this only occurring in some "2.6.x" version (if the latter, update to 2.7.0 and try to reproduce)?

comment:2 in reply to: ↑ 1 Changed 9 years ago by MarG

  • Status changed from pending to new

Replying to darkrain42:

Is this actually happening in Pidgin 2.7.0 or is this only occurring in some "2.6.x" version (if the latter, update to 2.7.0 and try to reproduce)?

Yes, this is reproducable in 2.7.0, too.

comment:3 Changed 8 years ago by ivan.komarov@…

  • Resolution set to fixed
  • Status changed from new to closed

(In e4e0a8019c2a8da23c47db0095c8485f18ba6caa):
Escape status messages properly (Fixes #11964).

We now never strip HTML tags from status messages (this behaviour converted the "<-- hat jetzt ein Macbook" status from the bug to the empty string). Instead, we just escape HTML where needed.

Also, the x-status message is now not written to the "message" status attribute of PurpleStatus?, because it can be different from the available message for some clients (Miranda) and we don't want the x-status message to overwrite the available message.

comment:4 Changed 8 years ago by Robby

Ticket #12593 has been marked as a duplicate of this ticket.

comment:5 Changed 8 years ago by ivan.komarov@…

  • Milestone set to 2.7.5

(In 59e16ff94a4636665de90332c92822e35d063b2b):
Merged my changes that fix #11964 and #12593. Mark looked over them and said they looked good to him.

applied changes from 7b998c02b684a694f1089bee715e4a3952bbcf08

through 563c6a79e1266b750fe4bd608890195cfbcd8a2c

comment:6 Changed 8 years ago by rekkanoryo@…

(In f66a462582d88603680b07482658645162a98ed5):
ChangeLog some stuff that should have been, but wasn't. Refs #12810, #11964, #12593, #12768, #12781.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!