Opened 9 years ago

Closed 9 years ago

#11985 closed defect (duplicate)

Segmentation fault in main()?

Reported by: DenniX Owned by:
Milestone: Component: pidgin (gtk)
Version: 2.7.0 Keywords: segmentation fault start msn icq
Cc:

Description (last modified by datallah)

My pidgin is crashing always. It crashs with a segmentation error on sign in to msn & icq. Everything is up-to-date.

/var/log/messages: May 21 14:45:12 snake kernel: [15636.418919] pidgin[6118]: segfault at 0 ip 00007fab68071f70 sp 00007fff9c805888 error 4 in libc-2.11.1.so[7fab67f75000+178000]

Backtrace:

[dennix@snake:~] > gdb pidgin 2>&1 | tee ~/pidgin-backtrace.log
GNU gdb (GDB) 7.1-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/pidgin...(no debugging symbols found)...done.
(gdb) handle SIGPIPE nostop noprint
Signal        Stop	Print	Pass to program	Description
SIGPIPE       No	No	Yes		Broken pipe
(gdb) 
Signal        Stop	Print	Pass to program	Description
SIGPIPE       No	No	Yes		Broken pipe
(gdb) run
Starting program: /usr/bin/pidgin 
[Thread debugging using libthread_db enabled]
[New Thread 0x7fffdf300710 (LWP 6490)]
[New Thread 0x7fffd691e710 (LWP 6529)]
[Thread 0x7fffd691e710 (LWP 6529) exited]

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff4887f70 in __strcpy_chk () from /lib/libc.so.6
(gdb) bt full
#0  0x00007ffff4887f70 in __strcpy_chk () from /lib/libc.so.6
No symbol table info available.
#1  0x00007fffe1b14c86 in oscar_normalize () from /usr/lib/purple-2/liboscar.so.0
No symbol table info available.
#2  0x00007ffff4bb3f8b in purple_normalize () from /usr/lib/libpurple.so.0
No symbol table info available.
#3  0x00007ffff4b711dc in purple_find_conversation_with_account () from /usr/lib/libpurple.so.0
No symbol table info available.
#4  0x00007ffff4b712bc in purple_conv_present_error () from /usr/lib/libpurple.so.0
No symbol table info available.
#5  0x00007fffe1b1b1d4 in ?? () from /usr/lib/purple-2/liboscar.so.0
No symbol table info available.
#6  0x00007fffe1b1236a in ?? () from /usr/lib/purple-2/liboscar.so.0
No symbol table info available.
#7  0x00007fffe1b112b3 in ?? () from /usr/lib/purple-2/liboscar.so.0
No symbol table info available.
#8  0x000000000046dafe in ?? ()
No symbol table info available.
#9  0x00007ffff4e738c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
No symbol table info available.
#10 0x00007ffff4e77748 in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#11 0x00007ffff4e77c55 in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#12 0x00007ffff6251af7 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#13 0x0000000000485ef4 in main ()
No symbol table info available.

Attachments (1)

pidgin-backtrace.log (2.5 KB) - added by DenniX 9 years ago.
backtrace log

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by DenniX

backtrace log

comment:1 Changed 9 years ago by datallah

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #11863.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!