Opened 9 years ago

Closed 6 years ago

#11989 closed enhancement (duplicate)

Use Perl 5.12 on Windows

Reported by: jonchang Owned by: datallah
Milestone: Component: winpidgin (gtk)
Version: 2.7.0 Keywords:
Cc:

Description

Pidgin only searches for perl510.dll, and it's called perl512.dll for the new version. As far as I know there aren't any horribly incompatible changes.

findstr reveals the areas that might need to be changed:

$ findstr /n /i /s /c:"perl510" *
libpurple\plugins\perl\common\Makefile.mingw:84:LIBS =                  -lperl510 \
libpurple\plugins\perl\Makefile.mingw:52:                       -lperl510
pidgin\plugins\perl\common\Makefile.mingw:77:LIBS =                     -lperl510 \
pidgin\win32\nsis\pidgin-installer.nsi:72:!define PERL_DLL        "perl510.dll"

Change History (3)

comment:1 Changed 9 years ago by rekkanoryo

  • Component changed from plugins to winpidgin (gtk)
  • Owner set to datallah

comment:2 Changed 9 years ago by datallah

  • Summary changed from Pidgin for Windows doesn't load Perl 5.12 to Use Perl 5.12 on Windows
  • Type changed from defect to enhancement

I'm not sure that it will be reasonably possible to support both versions.

The reason that the dlls are named differently is presumably because there isn't an expectation of ABI backward compatibility.

At some point in the not too distant future (i.e. when I move to Perl 5.12), I'll update Pidgin to use that instead of 5.10.

comment:3 Changed 6 years ago by datallah

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #15599.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!