Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11996 closed defect (duplicate)

icq/oscar crash on single user

Reported by: exa Owned by:
Milestone: Component: libpurple
Version: 2.7.0 Keywords:
Cc:

Description

Hello,

recently, when one specific user is sending a message to me via ICQ, pidgin crashes instantly. I'm not sure why this happens (I guess that I'll just clear off my settings and it should disappear), but feel the necessity to post a backtrace to possibly find a bug or a problem that could also cause other crashes.

Affected (tested) 2.6.3 to 2.7.0

backtrace follows (sorry it's not from debug version, i'm gonna try to supply that one too):

(gdb) bt full

0  0x00007f87526d4e80 in __strcpy_chk () from /lib/libc.so.6
No symbol table info available.

1  0x00007f874a7003b5 in oscar_normalize ()
   from /usr/lib64/purple-2/liboscar.so.0
No symbol table info available.

2  0x00007f875530216b in purple_normalize () from /usr/lib/libpurple.so.0
No symbol table info available.

3  0x00007f87552bfcdc in purple_find_conversation_with_account ()
   from /usr/lib/libpurple.so.0
No symbol table info available.

4  0x00007f87552bfdcc in purple_conv_present_error ()
   from /usr/lib/libpurple.so.0
No symbol table info available.

5  0x00007f874a70765f in ?? () from /usr/lib64/purple-2/liboscar.so.0
No symbol table info available.

6  0x00007f874a6fdb41 in ?? () from /usr/lib64/purple-2/liboscar.so.0
No symbol table info available.

7  0x00007f874a6fca61 in ?? () from /usr/lib64/purple-2/liboscar.so.0
No symbol table info available.

8  0x000000000046cb7e in ?? ()
No symbol table info available.

9  0x00007f8753453f31 in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
No symbol table info available.

10 0x00007f8753457718 in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.

11 0x00007f8753457c05 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.

12 0x00007f875854ee37 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.

13 0x00000000004848df in main ()
No symbol table info available.

I'm gonna do some hacking and report if I come across a viable solution. If someone could patch/explain this, please do.

Cheers -mk

Change History (2)

comment:1 Changed 9 years ago by Robby

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #11863.

comment:2 Changed 9 years ago by exa

o nice, thanks.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!