Opened 9 years ago

Closed 9 years ago

#12039 closed defect (duplicate)

libpurple tries to include gst/gst.h when --disable-gstreamer given to configure, fails to build

Reported by: nn Owned by: rekkanoryo
Milestone: Component: unclassified
Version: 2.7.0 Keywords:
Cc:

Description

I'm trying to build pidgin/libpurple without gstreamer.

Initially I had this error while trying to build freebsd port; since then I tried manually building using the following configure line:

pie@area pidgin-2.7.0 % ./configure --disable-gstreamer --disable-gtkspell --disable-vv --disable-idn --disable-meanwhile --disable-avahi --disable-nm --disable-tcl --disable-perl

--disable-gstreamer should be the only important switch, the rest are for dependencies I don't have that configure complained about.

That configures ok on my system and builds until this error:

gmake[4]: Entering directory `/home/pie/tmp/pidgin-2.7.0/libpurple'
/bin/sh ../libtool --silent  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..  -DDATADIR=\"/usr/local/share\" -DLIBDIR=\"/usr/local/lib/purple-2/\" -DLOCALEDIR=\"/usr/local/share/locale\" -DSYSCONFDIR=\"/usr/local/etc\" -D_REENTRANT -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include   -Wall  -DPURPLE_DISABLE_DEPRECATED -DPIDGIN_DISABLE_DEPRECATED -DFINCH_DISABLE_DEPRECATED -DGNT_DISABLE_DEPRECATED -Waggregate-return -Wcast-align -Wdeclaration-after-statement -Wendif-labels -Werror-implicit-function-declaration -Wextra -Wno-sign-compare -Wno-unused-parameter -Wformat-security -Winit-self -Wmissing-declarations -Wmissing-noreturn -Wmissing-prototypes -Wpointer-arith -Wundef -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include   -I/usr/local/include/libxml2 -I/usr/local/include           -g -g -O2 -MT backend-fs2.lo -MD -MP -MF .deps/backend-fs2.Tpo -c -o backend-fs2.lo `test -f 'media/backend-fs2.c' || echo './'`media/backend-fs2.c
In file included from media/backend-fs2.c:29:
media/backend-fs2.h:62:21: error: gst/gst.h: No such file or directory
In file included from media/backend-fs2.c:29:
media/backend-fs2.h:63: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
media/backend-fs2.h:66: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
gmake[4]: *** [backend-fs2.lo] Error 1
gmake[4]: Leaving directory `/home/pie/tmp/pidgin-2.7.0/libpurple'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory `/home/pie/tmp/pidgin-2.7.0/libpurple'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/home/pie/tmp/pidgin-2.7.0/libpurple'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/home/pie/tmp/pidgin-2.7.0'
gmake: *** [all] Error 2

It looks like ./libpurple/media/backend-fs2.h unconditionally includes gst/gst.h.

Change History (1)

comment:1 Changed 9 years ago by QuLogic

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #11850.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!