Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#12049 closed patch (fixed)

No encoding declared in purple-remote

Reported by: Fractal Owned by:
Milestone: 2.7.4 Component: libpurple
Version: 2.7.0 Keywords: purple-remote encoding
Cc:

Description

Hi, I have non ASCII characters in my status message, and there is a little problem with purple-remote:

$ purple-remote getstatusmessage
Mieux vaut régner en enfer que servir au paradis
$ echo $(purple-remote getstatusmessage)
Traceback (most recent call last):
  File "/usr/bin/purple-remote", line 238, in <module>
    print output
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 12: ordinal not in range(128)

The attached patch fixes this (this is a patch against /usr/bin/purple-remote, I hope this is OK)

Guillaume Brunerie

Attachments (1)

purple-remote.patch (331 bytes) - added by Fractal 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by Fractal

comment:1 Changed 9 years ago by Guillaume Brunerie

  • Milestone set to 2.7.4
  • Resolution set to fixed
  • Status changed from new to closed

(In 738b56a615d291a1bedab422f2e8d912317789a2):
Make purple-remote expect and produce UTF-8 instead of ASCII. Fixes #12049.

comment:2 Changed 9 years ago by rekkanoryo@…

(In e1119abd5c3f78ae3b17c3a20ecb37d5ef001385):
Credit where due. Refs #12049.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!