Opened 8 years ago

Closed 9 months ago

#12059 closed defect (out of date)

Wrong online user count in groups

Reported by: poizon Owned by: QuLogic
Milestone: Component: MSN
Version: 2.7.0 Keywords: msn
Cc:

Description

To reproduce the bug:

  1. count the online users in a group (read the group tooltip or collapse the group)
  2. you need an msn user in this group, who listens music (for example, a pidgin user with musictracker plugin) and changes status from offline/hidden to online/busy/away
  3. count the online users again: the user, who listens music, is not counted as online user
  4. move this user tho another group: the wrong online count 'moves' with the user to the new group


(sorry for my english)

Attachments (2)

buddylist_tooltip.png (20.5 KB) - added by poizon 8 years ago.
purple-debug.log (2.0 KB) - added by poizon 8 years ago.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by poizon

comment:1 Changed 8 years ago by QuLogic

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #12050.

comment:2 Changed 8 years ago by poizon

I have applied a patch, which really fixes #12050 (7786ed6f7931081801ff5a3435820ed6f90ba2ca), but the online buddy count problem still exists. Is this really a duplicate?

comment:3 Changed 8 years ago by QuLogic

  • Resolution duplicate deleted
  • Status changed from closed to new

Maybe. Maybe not.

comment:4 Changed 8 years ago by QuLogic

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.
I cannot reproduce on MTN.

comment:5 Changed 8 years ago by poizon

  • Status changed from pending to new

I have created a debug log:

  • I added myself (xxxxxxxx@… in the log) to my buddy list, and started a music in Amarok.
  • After the musictracker plugin changed my status (the music icon showed up in the buddy list after my name), i changed my status to invisible, so the test buddy is now 'offline' on my buddy list. (I know, it's a third party plugin, but formerly i was able to reproduce this bug without musictracker on pidgin 2.6.x and i don't have 2 accounts + 2 pidgins for this debug.)
  • Now i started logging.
  • I changed my status to Busy.
  • The online count is now wrong in my group.
  • After few seconds i stopped logging. (I have deleted from the log the 'musictracker' and 'MPRIS' lines, but if you need them, i can attach the full log.)

Changed 8 years ago by poizon

comment:6 Changed 9 months ago by dx

  • Resolution set to out of date
  • Status changed from new to closed

Closing all MSN tickets, since it has been removed in pidgin 2.12.0 after being broken for a couple of years (see http://ismsndeadyet.com/). The skypeweb plugin can be used as an alternative (yes, it supports MSN logins too)

If this issue is still present in any other protocols supported by pidgin, please leave a comment and we will reopen it.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!