Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#12073 closed defect (fixed)

CentOS 5.5 tray icon is busted

Reported by: gaul Owned by: nosnilmot
Milestone: Component: unclassified
Version: 2.7.1 Keywords:
Cc:

Description

When upgrading from pidgin 2.6.6 to 2.7.0 or 2.7.1, the tray icon shows a broken icon with an X through it.

Attachments (1)

broken_icon.png (22.3 KB) - added by gaul 9 years ago.
broken icon

Download all attachments as: .zip

Change History (11)

Changed 9 years ago by gaul

broken icon

comment:1 Changed 9 years ago by cepheid

The same problem occurs with CentOS 5.2, using pidgin 2.7.0 or 2.7.1.

I suspect that the reason is that the directory structure and filenames in <exec_prefix>/share/pixmaps/pidgin/tray have changed since 2.6.x ... they are quite different now, and I suspect that pidgin 2.7.x is looking for the old directory structure and/or filenames, although trying to use the old directory structure and/or the old filenames (in any combination) doesn't seem to work...

A fix for this would be great because the tray icon is of very limited functionality if it can't find its PNGs.

comment:2 Changed 9 years ago by QuLogic

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #11846.
You need to upgrade your hicolor-icon-theme, or get your distribution's packager to use the --enable-trayicon-compat option when building Pidgin.

comment:3 Changed 9 years ago by gaul

I already have hicolor-icon-theme-0.9-2.1 installed and my copy of Pidgin comes from the official repository at http://rpm.pidgin.im/centos/5.0/x86_64/pidgin-2.7.1-0.el5.x86_64.rpm. Configure flags look like:

'--prefix=/usr' '--bindir=/usr/bin' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--mandir=/usr/share/man' '--sysconfdir=/etc' '--disable-schemas-install' '--disable-vv' '--disable-nm' '--enable-gevolution' '--enable-cyrus-sasl' 'CFLAGS=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables' 'PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/share/pkgconfig'

comment:4 Changed 9 years ago by khc

  • Resolution duplicate deleted
  • Status changed from closed to new

comment:5 Changed 9 years ago by QuLogic

  • Status changed from new to pending

Your hicolor-icon-theme is too old. You need to follow my second recommendation.

comment:6 Changed 9 years ago by cepheid

The latest version of hicolor-icon-theme is 0.12, but CentOS has not integrated that version yet, so 0.9 is the latest CentOS version, but not the latest absolute version.

--enable-trayicon-compat works when compiling from source; the official RPM copy should have that enabled for all CentOS RPMs, therefore. I recommend updating the official RPMs with the --enable-trayicon-compat configure flag, since _all_ CentOS versions ship with a too-old hicolor-icon-theme.

comment:7 Changed 9 years ago by gaul

  • Status changed from pending to new

Note that comment #3 refers to the RPM packaged by rpm.pidgin.im, not CentOS.

comment:8 Changed 9 years ago by QuLogic

  • Owner changed from rekkanoryo to nosnilmot

Oh silly me, I didn't notice you installed from here. I think nosnilmot takes care of this.

comment:9 Changed 9 years ago by nosnilmot

  • Resolution set to fixed
  • Status changed from new to closed

I've made new builds (pidgin-2.7.1-0.1.el5) that should fix this now.

comment:10 Changed 9 years ago by gaul

Confirmed fixed in pidgin-2.7.1-0.1.el5.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!