Opened 9 years ago

Closed 9 years ago

#12122 closed defect (duplicate)

gadugadu - get info not working

Reported by: 6thsurvivor Owned by: bartosz
Milestone: Component: Gadu-Gadu
Version: 2.7.1 Keywords: libgg userinfo
Cc:

Description

Every time i try to use 'get info' on someone using gadu gadu, it fail with a "gg: ggp_pubdir_reply_handler(): seq 1315784334 --> form 00000000(12:27:26) g_log: ggp_pubdir_reply_handler: assertion `form != NULL' failed " error in the console. PArtial information is retrieved properly(@console), but information window is still waitng..

Full console dump below (includes a sample botuser info): (12:27:24) network: found network (12:27:24) network: Received Network Change Notification. Current network count is 1, previous count was 1. (12:27:26) gg: It's time to perform a search... (12:27:26) gg: gg_pubdir50_new(3); (12:27:26) gg: uin: 6969951 (12:27:26) gg: gg_pubdir50_add_n(06AE66B8, 0, "FmNumber?", "6969951"); (12:27:26) gg: offset: 0 (12:27:26) gg: gg_pubdir50_add_n(06AE66B8, 0, "fmstart", "0"); (12:27:26) gg: gg_pubdir50(053A1018, 06AE66B8); (12:27:26) gg: gg_send_packet(053A1018, 0x14, ...); (12:27:26) gg: gg_send_packet() partial write(), 40 sent, 0 left, 0 total left (12:27:26) gg: search sequence number: 1275906446 (12:27:26) gg: ggp_get_info(): Added seq 1275906446(12:27:26) gg: gg_watch_fd(053A1018); (12:27:26) gg: gg_watch_fd() GG_STATE_CONNECTED (12:27:26) gg: gg_watch_fd_connected(053A1018, 022DC470); (12:27:26) gg: gg_recv_packet(053A1018); (12:27:26) gg: gg_recv_packet() header recv(1580,0028E510,8) = 8 (12:27:26) gg: gg_recv_packet() body recv(1580,0554BA60,46) = 46 (12:27:26) gg: gg_watch_fd_connected() received pubdir/search reply (12:27:26) gg: gg_pubdir50_handle_reply_sess(053A1018, 022DC470, 0554BA60, 46); (12:27:26) gg: gg_pubdir50_new(5); (12:27:26) gg: gg_pubdir50_add_n(06AE71F8, 0, "FmNumber?", "6969951"); (12:27:26) gg: gg_pubdir50_add_n(06AE71F8, 0, "FmStatus?", "1"); (12:27:26) gg: gg_pubdir50_add_n(06AE71F8, 0, "nickname", "Joy"); (12:27:26) gg: ggp_pubdir_reply_handler(): seq 1315784334 --> form 00000000(12:27:26) g_log: ggp_pubdir_reply_handler: assertion `form != NULL' failed

(12:27:26) gg: gg_event_free(022DC470); (12:27:26) gg: gg_event_free(022DC470);

System: windows 7 x32/x64. Fresh pidgin install. Didn't happen for <2.7 branch

Change History (2)

comment:1 Changed 9 years ago by abc00

comment:2 Changed 9 years ago by Robby

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #11958.
Thanks, abc00!

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!