Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#12129 closed defect (fixed)

pidgin minimizes to non-existent system tray

Reported by: acli Owned by:
Milestone: 2.7.8 Component: pidgin (gtk)
Version: 2.7.1 Keywords:
Cc:

Description

After upgrading to 2.7.1, closing the pidgin buddy list (by clicking the buddy list's close box) on an environment without a system tray (e.g., MacOS X's X11) causes the buddy list to disappear but all the other windows staying on the screen. If I kill pidgin and restart, pidgin will run but nothing shows on the screen.

In such a case compiling and running stalonetray is the only way to restore the buddy list.

This might have affected 2.7.0 but I could not check, as I could not get 2.7.0 to compile on my system.

Change History (5)

comment:1 Changed 9 years ago by datallah

  • Status changed from new to pending

In Tools->Preferences, you can set "Show system tray icon:" to "Never", and it should work better for this scenario.

comment:2 Changed 9 years ago by acli

  • Status changed from pending to new

I just verified that this workaround works as expected.

However, I think if the user does not know how to compile or install stalonetray for any reason, we still need some way (maybe a command-line option or a signal) that tells pidgin to restore the buddy list.

comment:3 Changed 8 years ago by QuLogic

Ticket #12824 has been marked as a duplicate of this ticket.

comment:4 Changed 8 years ago by qulogic@…

  • Milestone set to 2.7.8
  • Resolution set to fixed
  • Status changed from new to closed

(In 27639110c18cc1d52b6bb784f844217c23a73562):
Re-implement the embedding timeout, so that the buddy list doesn't seem to disappear on startup entirely if you don't have a notification area.

Fixes #12129.

comment:5 Changed 8 years ago by QuLogic

Ticket #12369 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!