Opened 9 years ago

Closed 9 years ago

#12206 closed defect

Pidgin segfaults on startup

Reported by: Nishith Owned by: rekkanoryo
Milestone: Component: unclassified
Version: 2.7.1 Keywords: segfault startup crash
Cc:

Description (last modified by rekkanoryo)

The version from pidgin PPA was crashing so I downloaded the source and installed but that has the same issue. Following is the trace. It happens every time on start up.

Attachments (4)

pidgin-crash-gdb (6.9 KB) - added by Nishith 9 years ago.
This is the trace I get when I run it in gdb
gdb-pidgin.txt (6.5 KB) - added by Nishith 9 years ago.
Backtrace
pidgin-backtrace.log (9.3 KB) - added by Nishith 9 years ago.
pidgin-2.7.1-backtrace.log (18.0 KB) - added by Nishith 9 years ago.

Download all attachments as: .zip

Change History (29)

Changed 9 years ago by Nishith

This is the trace I get when I run it in gdb

comment:1 Changed 9 years ago by rekkanoryo

  • Description modified (diff)

comment:2 Changed 9 years ago by rekkanoryo

  • Description modified (diff)
  • Status changed from new to pending

Please follow the instructions to get a backtrace and attach it to this ticket.

What you pasted and attached is not a usable backtrace.

comment:3 Changed 9 years ago by Nishith

  • Status changed from pending to new

Attachment (gdb-pidgin.txt) added by ticket reporter.

comment:5 Changed 9 years ago by Nishith

Followed the instructions to get a backtrace. Attached the file "gdb-pidgin.txt".

comment:6 Changed 9 years ago by darkrain42

  • Status changed from new to pending

Either uninstall the system-installed libpurple0 package or run "sudo ldconfig" and then re-get a backtrace.

Changed 9 years ago by Nishith

Backtrace

comment:7 Changed 9 years ago by Nishith

  • Status changed from pending to new

Attachment (gdb-pidgin.txt) added by ticket reporter.

comment:8 Changed 9 years ago by Nishith

Updated the trace file.

comment:9 Changed 9 years ago by rekkanoryo

  • Status changed from new to pending

You're missing debug symbols for the libpurple0 package. Install them and get the backtrace again.

comment:10 Changed 9 years ago by Nishith

  • Status changed from pending to new

I installed the libpurple-dev package but still did not get the debugging symbols. There is no libpurple-dbg package. What do I need to install to get the debugging symbols?

comment:11 Changed 9 years ago by darkrain42

  • Status changed from new to pending

The package is pidgin-dbg.

Changed 9 years ago by Nishith

comment:12 Changed 9 years ago by Nishith

  • Status changed from pending to new

Attachment (pidgin-backtrace.log) added by ticket reporter.

comment:13 Changed 9 years ago by Nishith

Uploaded the trace with debugging symbols.

comment:14 Changed 9 years ago by Nishith

The issue is with Yahoo's protocol handler, it seems. Pidgin is working fine once I disable my Yahoo! account.

comment:15 Changed 9 years ago by rekkanoryo

Hmm, I can't see a reason for this to be crashing where it is. Are you sure you were using Pidgin 2.7.1 and not code from the monotone repository?

comment:16 Changed 9 years ago by Nishith

I am using the version from the ubuntu repo. I have the pidgin-developers ppa added but I have disabled it for the time being. The crash is regular, happens on every start. Although after disabling the yahoo account its running fine.

comment:17 Changed 9 years ago by Nishith

Its not 2.7.1, its Pidgin 2.7.2devel (libpurple 2.7.2devel). I switched to this when 2.7.1 crashed but this is crashing too.

comment:18 Changed 9 years ago by darkrain42

The Pidgin developers' PPA does not include a development build of Pidgin (2.7.2devel). What is the output of apt-cache policy pidgin?

comment:19 Changed 9 years ago by Nishith

pidgin:
  Installed: 1:2.7.2~mtn20100617+957a4bbd-1~frasten0
  Candidate: 1:2.7.2~mtn20100617+957a4bbd-1~frasten0
  Version table:
 *** 1:2.7.2~mtn20100617+957a4bbd-1~frasten0 0
        500 http://ppa.launchpad.net/frasten/ppa/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
     1:2.7.1-1ubuntu1~pidgin1.10.04 0
        500 http://ppa.launchpad.net/pidgin-developers/ppa/ubuntu/ lucid/main Packages
     1:2.6.6-1ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages

This looks to be the monotone build you were talking about.

comment:20 Changed 9 years ago by Nishith

Ok, I removed the repo from where I was getting the 2.7.2 version.

This is the current output of the apt-cache policy pidgin command

pidgin:
  Installed: 1:2.7.1-1ubuntu1~pidgin1.10.04
  Candidate: 1:2.7.1-1ubuntu1~pidgin1.10.04
  Version table:
 *** 1:2.7.1-1ubuntu1~pidgin1.10.04 0
        500 http://ppa.launchpad.net/pidgin-developers/ppa/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
     1:2.6.6-1ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages

I have attached the backtrace (pidgin-2.7.1-backtrace.log)

Changed 9 years ago by Nishith

comment:21 Changed 9 years ago by rekkanoryo

  • Status changed from new to pending

Now that you've changed libpurple and pidgin versions, you need to reinstall the pidgin-dbg package. Note that the backtrace is currently showing ?? for function names in libpurple and gdb complains of CRC mismatches.

comment:22 Changed 9 years ago by Nishith

  • Status changed from pending to new

I reinstalled the dbg package, I am still getting CRC mismatch. What else could be wrong?

comment:23 Changed 9 years ago by darkrain42

  • Status changed from new to pending

Check the output of apt-cache policy libpurple0 and apt-cache policy pidgin-dbg to see what versions are installed and where they're installed from.

comment:24 Changed 9 years ago by Nishith

  • Status changed from pending to new

Ah! Brilliant. It was the libnotify from monotone that was causing the issue. Everything is working fine now. Thanks for all your help. I really appreciate it.

comment:25 Changed 9 years ago by darkrain42

  • Status changed from new to pending

There is no "libnotify from Monotone". We did not write, nor do we support or distribute, the pidgin-libnotify plugin. The backtraces you've provided contained no reference to the pidgin-libnotify plugin, so I don't actually expect the crashes are fixed. If it re-occurs, get another backtrace (with debug symbols) and indicate what version of Pidgin you're using.

comment:26 Changed 9 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!