Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#12284 closed defect (fixed)

Pidgin ignores messages sent from an icq transport

Reported by: stegmannt Owned by: MarkDoliner
Milestone: 2.7.4 Component: ICQ
Version: 2.7.1 Keywords: icq transport
Cc:

Description

I'm using pyicqt to communicate with my ICQ buddies. Since Pidgin 2.7 they can't receive any messages from me. They can see me typing, but the message gets lost somehow.

PyICQt doesn't show me any errors in its logs and its working perfectly with Pidgin 2.6.x and every other popular client like ICQ itself and Kopete.

The notable Pidgin 2.6 and and 2.7 debug window messages are attached.

Thanks.

Attachments (6)

purple2.6-debug.log (245 bytes) - added by stegmannt 9 years ago.
Pidgin 2.6.6 log
purple2.7-debug.log (146 bytes) - added by stegmannt 9 years ago.
Pidgin 2.7.1 log
complete2.7-debug.log (30.5 KB) - added by stegmannt 9 years ago.
complete debug log file
pyicqt.conf.xml (1.5 KB) - added by stegmannt 9 years ago.
wireshark_capture.pcap (1.7 KB) - added by stegmannt 9 years ago.
12284.diff (4.5 KB) - added by ivan.komarov 9 years ago.

Download all attachments as: .zip

Change History (20)

Changed 9 years ago by stegmannt

Pidgin 2.6.6 log

Changed 9 years ago by stegmannt

Pidgin 2.7.1 log

comment:1 Changed 9 years ago by stegmannt

Seems to be related to #12209 but I don't get any log messages like

Cookies don't match in rendezvous ICBM, bailing out.

comment:2 Changed 9 years ago by darkrain42

  • Component changed from ICQ to XMPP
  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.
If you're using pyicqt, the message should be coming in over *XMPP*, not ICQ, and these logs are missing anything like that.

comment:3 Changed 9 years ago by stegmannt

  • Status changed from pending to new

Perhaps I didn't explain the problem correctly:

I'm connected to ICQ via pyicqt transport. My buddy A is directly connected to ICQ using Pidgin 2.7. If I send a message to A through pyicqt, A should receive the message via ICQ directly. This worked perfectly with Pidgin 2.6.x. Since Pidgin 2.7 the debug log only shows

oscar: Incoming rendezvous message of type 16384, user 1234567, status 0
oscar: Got an ICQ Server Relay message of type 1

and the message window never shows up.

The complete debug log is attached.

Changed 9 years ago by stegmannt

complete debug log file

comment:4 Changed 9 years ago by darkrain42

  • Component changed from XMPP to ICQ

Ah.

comment:5 Changed 9 years ago by ivan.komarov

I registered an account on aqq.eu (which seems to be using pyicqt) and couldn't reproduce the bug. IMs get delivered as expected to Pidgin 2.7.1 with exactly the same log messages as you provided.

Since incoming message parsing gets to this point, my only assumption is that pyicqt sends malformed UTF-8 for some reason (which is unlikely, judging from its sources).

Could you please provide more details as to how to reproduce that? PyICQt version, how it is configured, etc. Alternatively, if your buddy A could capture the incoming packet (with Wireshark or a similar tool), that would also be great.

comment:6 Changed 9 years ago by darkrain42

  • Status changed from new to pending

Please also double-check that you haven't accidentally blocked the other person (Tools->Privacy)

comment:7 follow-up: Changed 9 years ago by stegmannt

  • Status changed from pending to new

Nobody is blocked. I've registered a new ICQ account for testing purposes and can reproduce it.

I'm running PyICQt version 0.8.1.5-3 (Ubuntu Lucid version). See the attachment for the detailed config.

I will also attach some sample packets captured with Wireshark.

Thanks!

Changed 9 years ago by stegmannt

Changed 9 years ago by stegmannt

comment:8 in reply to: ↑ 7 Changed 9 years ago by stegmannt

And btw: Why is the report always set from pending to new, when I'm awnsering?

comment:9 Changed 9 years ago by darkrain42

'pending' means "awaiting user response" (and a cron job will close tickets after two weeks with no response), so when you respond, trac sets it back to 'new'.

comment:10 follow-up: Changed 9 years ago by ivan.komarov

I think I fixed it in my SoC branch (type 2 messages receiving was really broken). I would appreciate it if you could patch Pidgin 2.7.2 sources with the patch I'm attaching, compile them, and then try to receive a message from PyICQt.

Changed 9 years ago by ivan.komarov

comment:11 Changed 9 years ago by stegmannt

I compiled the 2.7.2 sources with your patch and it seems to fix the issue.

Thanks!

comment:12 in reply to: ↑ 10 Changed 9 years ago by stegmannt

Replying to ivan.komarov:

I think I fixed it in my SoC branch (type 2 messages receiving was really broken). I would appreciate it if you could patch Pidgin 2.7.2 sources with the patch I'm attaching, compile them, and then try to receive a message from PyICQt.

Any chance to see this in 2.7.3?

comment:13 Changed 8 years ago by ivan.komarov

  • Resolution set to fixed
  • Status changed from new to closed

This was released in 2.7.4.

comment:14 Changed 8 years ago by rekkanoryo

  • Milestone set to 2.7.4
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!