Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#12471 closed patch (fixed)

Allow account change from disconnected account in conversation

Reported by: SgtPepper Owned by:
Milestone: 2.7.4 Component: pidgin (gtk)
Version: 2.7.3 Keywords:
Cc:

Description

This patch fixes bug #7203.

If a user has a buddy via two different accounts and one (which is the active account in a conversation) becomes unavailable, the "Send To" menu is disabled - leaving the user unable to switch to the account that's still available.

This patch simply leaves the current account in the "Send To" menu (though grayed out), even if it is disconnected. Now the user can select the good account, and the "Send To" menu will subsequently become disabled as before.

Attachments (2)

active_disconnected.patch (784 bytes) - added by SgtPepper 9 years ago.
Disconnected conversation patch
withpatch.GIF (29.7 KB) - added by SgtPepper 9 years ago.
Behavior with patch

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by SgtPepper

Disconnected conversation patch

comment:1 Changed 9 years ago by QuLogic

  • Milestone set to Patches Needing Review

Changed 9 years ago by SgtPepper

Behavior with patch

comment:2 Changed 9 years ago by SgtPepper

For clarity, I've added a picture illustrating the behavior with this patch. Without the patch, this situation would have the "Send To" menu disabled (making it impossible to change to the other option - even though it's usable).

comment:3 Changed 9 years ago by rekkanoryo

I intend to apply this patch. I need a real name to credit you with. An email address would be helpful as well.

comment:4 Changed 9 years ago by SgtPepper

Name: Keith Moyer email: pidgin@…

comment:5 Changed 9 years ago by pidgin@…

  • Milestone changed from Patches Needing Review to 2.7.4
  • Resolution set to fixed
  • Status changed from new to closed

(In 7c24035c10e3cd15c39417122d2b0e60b17e5611):
Allow using the Send To menu in the case that the active conversation's account disconnects. Previously, the Send To menu was unusable in this case, making it impossible to simply switch accounts and continue the conversation. Fixes #12471.

comment:6 Changed 9 years ago by rekkanoryo@…

(In b63bb09e1887b3f4fab117b64a18cfec6dc15875):
Credit where credit is due. Refs #12471.

comment:7 Changed 9 years ago by Robby

SgtPepper?, next time you can just attach the patch to the ticket it means to fix. :)

comment:8 Changed 9 years ago by Robby

Ticket #7203 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!