Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#12472 closed defect (fixed)

Yahoo File Transfer... Still....

Reported by: Swashbunglar Owned by: sulabh.dev
Milestone: 2.7.11 Component: Yahoo!/Yahoo! JAPAN
Version: 2.7.3 Keywords: Yahoo File Transfer
Cc: john13, oba, niteluzr, adyroman

Description

As of 2.7.3 I STILL cannot send or receive files via yahoo. I have default yahoo settings, no proxies. Files are said to be canceled before transfer is complete. The other side has the file just sitting saying it's still sending, or waiting for transfer.

Even tried on fresh clean install, no plugins. No Improvement.

Other client was Yahoo IM, and Trillian.. Neither worked. Why everything else works in pidgin, accept this is beyond me.

I know there are many other posts of this nature, BUT in the changelog for 2.7.3 under the yahoo section it says "Fix file transfers that get stuck with "Waiting for transfer to begin"." Which is misleading.. I assumed file transfers worked via yahoo... For me they do not. Unless there is some overly complicated, impossible to find instructions for a procedure making file transfers in yahoo work. It is broken.

Pidgin 2.7.3 (gfire plugin) Windows 7 Ultimate x64 AMD Phenom II X6 1090T @ 3.2ghz 8gb DDR2 1066 OCZ Memory

Attachments (2)

IPC2-16-09-2010-10.33.34.jpg (60.3 KB) - added by john13 6 years ago.
ft.c.patch (503 bytes) - added by cristi 6 years ago.
Patch - would solve transfer completed problem for other protocols as well

Download all attachments as: .zip

Change History (47)

comment:1 Changed 6 years ago by john13

Hi,

Still the same defect too. Files are canceled immediately in Pidgin after the acceptance from or to another Yahoo client like YM9.

On Win XP SP3.

comment:2 Changed 6 years ago by datallah

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.

comment:3 Changed 6 years ago by john13

See comments in the log below :

File transfer from Pidgin to YM client :

(23:57:15) xfer: request accepted for 04485FD8
(23:57:28) yahoo: 73 bytes to read, rxlen is 93  <--- File accepted in YM
(23:57:28) yahoo: Yahoo Service: 0xdc Status: 1
(23:57:28) dnsquery: Performing DNS lookup for relay.msg.yahoo.com
(23:57:28) dnsquery: IP resolved for relay.msg.yahoo.com
(23:57:29) yahoo: 230 bytes to read, rxlen is 250
(23:57:29) yahoo: Yahoo Service: 0xde Status: 1
(23:57:29) dnsquery: Performing DNS lookup for 98.136.113.157
(23:57:29) dnsquery: IP resolved for 98.136.113.157
(23:57:29) proxy: Attempting connection to 98.136.113.157
(23:57:29) proxy: Connecting to 98.136.113.157:80 with no proxy
(23:57:29) proxy: Connection in progress
(23:57:29) proxy: Connecting to 98.136.113.157:80.
(23:57:29) proxy: Connected to 98.136.113.157:80.
(23:57:29) GLib: g_source_remove: assertion `tag > 0' failed <--- nothing else until manual cancelation in pidgin transfer interface, file received is empty
(00:01:43) yahoo: 238 bytes to read, rxlen is 258 <--- cancel in YM
(00:01:43) yahoo: Yahoo Service: 0xdd Status: -1

File transfer from YM to Pidgin :

(00:02:38) yahoo: 1611 bytes to read, rxlen is 1024
(00:02:38) yahoo: 1611 bytes to read, rxlen is 1631
(00:02:38) yahoo: Yahoo Service: 0xdc Status: 1
(00:02:46) xfer: request accepted for 043DCAA8  <---- File accepted in Pidgin
(00:02:47) yahoo: 280 bytes to read, rxlen is 300
(00:02:47) yahoo: Yahoo Service: 0xdd Status: 1
(00:02:47) dnsquery: Performing DNS lookup for 98.136.113.155
(00:02:47) dnsquery: IP resolved for 98.136.113.155
(00:02:47) proxy: Attempting connection to 98.136.113.155
(00:02:47) proxy: Connecting to 98.136.113.155:80 with no proxy
(00:02:47) proxy: Connection in progress
(00:02:47) proxy: Connecting to 98.136.113.155:80.
(00:02:47) proxy: Connected to 98.136.113.155:80.
(00:02:47) dnsquery: Performing DNS lookup for 98.136.113.155
(00:02:47) dnsquery: IP resolved for 98.136.113.155
(00:02:47) proxy: Attempting connection to 98.136.113.155
(00:02:47) proxy: Connecting to 98.136.113.155:80 with no proxy
(00:02:47) proxy: Connection in progress
(00:02:47) proxy: Connecting to 98.136.113.155:80.
(00:02:47) proxy: Connected to 98.136.113.155:80.  <--- Pidgin says that YM client user cancelled the transfer and nothing more happen. Not appearing as canceled in YM.
(00:04:31) yahoo: 238 bytes to read, rxlen is 258 <-- cancel clicked in YM
(00:04:31) yahoo: Yahoo Service: 0xdd Status: -1

comment:4 Changed 6 years ago by datallah

Ticket #12479 has been marked as a duplicate of this ticket.

comment:5 Changed 6 years ago by ov1d1u

Same problem here while receiving files (I didn't tested sending files yet). Transfer fails immediately after accepting the file; however files are saved on memory and they contain:

<html><head><title>relay.msg.yahoo.com Not Found</title></head><body>Not Found<!-- failure --><!-- relay.msg.yahoo.com --></body></html>

comment:6 Changed 6 years ago by rekkanoryo

I've been trying to figure out what changed here, and I'm completely at a loss. I can't see any difference between what the official clients send to the relay server and what we send to the same relay server. I don't understand why the relay server is accepting the official clients' requests but rejecting ours--our requests are identical, near as I can tell.

Unfortunately, file transfer isn't my area of expertise, so there may be something really simple that I'm missing. At this point, I'd just like to know what that something is so I can figure out how to fix it.

comment:7 Changed 6 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:8 Changed 6 years ago by niteluzr

Please do not close this ticket. It hasn't been fixed and for yahoo users it's of very high importance!

comment:9 Changed 6 years ago by ov1d1u

Yes, please keep it open. We need file transfer on Yahoo!

comment:10 Changed 6 years ago by datallah

  • Status changed from closed to new

comment:11 Changed 6 years ago by wolfy67

Same problem occurs here. I'm using pidgin-2.7.3-1.fc12.x86_64

comment:12 Changed 6 years ago by rekkanoryo

For the record, we don't need "me too"s on this ticket.

comment:13 Changed 6 years ago by sulabh.dev

  • Milestone set to 2.7.4
  • Resolution set to fixed
  • Status changed from new to closed

We were not sending cookies properly. Next version of Pidgin should fix this issue.

comment:14 Changed 6 years ago by sulabh.dev

Ticket #12384 has been marked as a duplicate of this ticket.

comment:15 Changed 6 years ago by sulabh.dev

Ticket #12298 has been marked as a duplicate of this ticket.

comment:16 Changed 6 years ago by sulabh.dev

Ticket #12161 has been marked as a duplicate of this ticket.

comment:17 Changed 6 years ago by sulabh.dev

Ticket #12255 has been marked as a duplicate of this ticket.

comment:18 Changed 6 years ago by datallah

Ticket #12611 has been marked as a duplicate of this ticket.

Changed 6 years ago by john13

comment:19 Changed 6 years ago by john13

Hi,

Tried with the following revisions :

  • Pidgin 2.7.4devel (libpurple 2.7.4devel) pidgin-mtn-20100916
  • Yahoo messenger 8.1.0.421

Results :

  • Pidgin -> Yahoo : seems to work fine. Great !
  • Yahoo -> Pidgin : file is sent but not all. In transfer file windows State is not updated in realtime when sending and at the end of the transfert, state is set around 99% (in details view) and 0 to 2 % in main view. I've tried for several files (size from some kB to some MB) and the transfer is always cancelled with always 15 bytes remaning. So the file is incorect .

Screen capture attached. Can you reopen? if no I create a new one issue...

comment:20 Changed 6 years ago by rekkanoryo

  • Resolution fixed deleted
  • Status changed from closed to new

comment:21 Changed 6 years ago by john13

  • Yahoo -> Pidgin : Seems to be OK from now (with same nightly build). ?!

comment:22 Changed 6 years ago by mar

Hi,

I've used Yahoo latest 10.0.0.1270-us and Pidgin from nightly build - 2.7.4 , build few minutes ago.

Yahoo => Pidgin :

In Yahoo shows "A problem occurred while transferring the file "blabla". The transfer has been stopped" In Pidgin shows "Transfer Complete". And files seems to be completely transfered indeed.

Pidgin => Yahoo:

In Yahoo shows "You have received 1 file from ..." , so the transfer completes. In Pidgin shows progress 100%, but the transfer never shows as completed, hanging at 100% and time remaining unknown.

Perhaps those are different bugs.

comment:23 Changed 6 years ago by ov1d1u

I can confirm that Pidgin to Yahoo! file transfer get stuck pn 100% and the remaining time is Unknown.

comment:24 follow-up: Changed 6 years ago by wolfy67

Just upgraded to pidgin-2.7.4-1.fc12.x86_64 (as built by nosnilmot ) and I am still not able to receive files via Yahoo file transfer.

comment:25 in reply to: ↑ 24 Changed 6 years ago by john13

Replying to wolfy67:

Just upgraded to pidgin-2.7.4-1.fc12.x86_64 (as built by nosnilmot ) and I am still not able to receive files via Yahoo file transfer.

Are you using a soft firewall? I use Outpost and transfert don't work if I enable content filters. If this is disabled for pidgin, transfert works fine but the issue "file transfer get stuck pn 100% and the remaining time is Unknown" is still here.

comment:26 Changed 6 years ago by adyroman

This bug's milestone has been moved several times during the last few months. I'm trying to convince people to use Linux and since everybody I know uses Yahoo Messenger on Windows, this is a serious problem in the Windows to Linux migration. Do you at least have any meaningful estimate of when you might spend some time on fixing this problem? I don't want to sound demanding, I'd do it myself if I had any idea how to - I just want to stress that it is _very_ important that this bug be fixed. Thanks.

comment:27 Changed 6 years ago by wolfy67

If works for me if I disable the local firewall. I am using 2.7.5-1.fc12 for the moment.

comment:28 Changed 6 years ago by rekkanoryo

File transfer should work perfectly well when both sides use Pidgin. It should also work with the official client if the official client is version 8 or 9, but at this point that's not something that's easily tested.

Further, none of the developers who use Yahoo currently have the inclination or time to work on secondary features like file transfer. I understand this is frustrating for users who feel that file transfer is an important feature, but that really doesn't change anything.

comment:29 follow-up: Changed 6 years ago by adyroman

I just tested this again, with 2 clients on different computers on the same LAN, no firewall. Both sides were using Pidgin 2.7.8. The sending party never has confirmation that the transfer has successfully completed. The progress bar either stops randomly, or goes to 100%, but never reaches status "Finished". So although the file is transferred, it's not really working "perfectly well" as you're saying. Also, I would argue that file transfer is really not a secondary feature - a secondary feature would be the animated smileys or the YM games; file transfer is a primary feature, along with the ability to send text both ways. After all, that's pretty much all Pidgin does for Yahoo now - just send text. I would even argue that text formatting is less important than file transfer.

Thanks for the answer though - at least we know where we stand - the current position is "we don't give a flying ", but somehow packaged in nicer words. Too bad there's no alternative, except switch back to Windows...

comment:30 Changed 6 years ago by wolfy67

actually there are alternatives. My current favourite is bitlbee, but kopete is also a good ( and, more important, functional ) alternative. And kopete does not need ages to be updated when Yahoo decides to switch to new protocols. My reason to still use pidgin sometimes is pure laziness: I need my old archives and I am too lazy to make them available to bitlbee.

comment:31 Changed 6 years ago by adyroman

I'll try kopete - if that works, Pidgin is out. Thanks.

comment:32 Changed 6 years ago by wolfy67

You could also try Empathy ( http://live.gnome.org/Empathy ). Some distros have already replaced pidgin with it.

comment:33 in reply to: ↑ 29 Changed 6 years ago by rekkanoryo

Replying to adyroman:

I just tested this again, with 2 clients on different computers on the same LAN, no firewall. Both sides were using Pidgin 2.7.8. The sending party never has confirmation that the transfer has successfully completed. The progress bar either stops randomly, or goes to 100%, but never reaches status "Finished". So although the file is transferred, it's not really working "perfectly well" as you're saying.


I just tested this myself and found the following:

  • Pidgin 2.7.8 to Pidgin 2.7.8: Receiver always shows sender canceled; sender forever waits for transfer to start.
  • Yahoo Messenger 10 to Pidgin 2.7.8: Transfers full file. Pidgin as receiver says the transfer was canceled, but the entire file was transferred successfully.
  • Pidgin 2.7.8 to Yahoo Messenger 10: Transfers full file, but pidgin says the receiver canceled the transfer and Yahoo says there was a problem transferring the file.

When I tested this last (it's been a while now), all these scenarios worked perfectly with the then-current versions of Pidgin and Yahoo Messenger. Let me go on record as saying I hate YMSG with a passion.

Thanks for the answer though - at least we know where we stand - the current position is "we don't give a flying ", but somehow packaged in nicer words. Too bad there's no alternative, except switch back to Windows...

That's not strictly true. We do want Pidgin to work for the features we claim to support. That said, currently the Yahoo plugin is without a real maintainer, and very few of our developers actually use Yahoo. I do what I can where I can, but file transfer is way beyond my grasp, and trying to understand it is more work than I want to suffer through after working a 40-hour week to pay the bills.

comment:34 Changed 6 years ago by rekkanoryo

  • Milestone changed from 2.7.10 to Patches welcome

comment:35 follow-ups: Changed 6 years ago by cristi

Patch included! :)

File transfers succeeding but pidgin not recognizing that - happens to me as well (pidgin->kopete, and pidgin->windows Yahoo Messenger). Behavior as previously reported.

Problem lies in the fact that completed state is not evaluated correctly by the underlying protocol file transfer implementation and neither by the general libpurple file transfer module.

Below, simple patch. Tested with file transfer pidgin->kopete, pidgin->Yahoo messenger (v10?)

Would probably fix also bugs #13058 and #12670.

Patch on source code version 2.7.9:

--- ft.c.orig 2011-01-16 11:01:54.000000000 +0200 +++ ft.c 2011-01-16 11:05:44.000000000 +0200 @@ -1100,9 +1100,11 @@

r = write(xfer->fd, buffer, s); if (r < 0 && errno == EAGAIN)

r = 0;

  • if ((purple_xfer_get_bytes_sent(xfer)+r) >= purple_xfer_get_size(xfer))
  • purple_xfer_set_completed(xfer, TRUE);

}

+ if (r >= 0 && (purple_xfer_get_bytes_sent(xfer)+r) >= purple_xfer_get_size(xfer) && + !purple_xfer_is_completed(xfer)) + purple_xfer_set_completed(xfer, TRUE); +

return r;

}

Changed 6 years ago by cristi

Patch - would solve transfer completed problem for other protocols as well

comment:36 follow-up: Changed 6 years ago by Robby

  • Milestone changed from Patches welcome to Patches Needing Review

comment:37 Changed 6 years ago by adyroman

More than willing to test if anybody can get a build of that uploaded somewhere. If it's only one file, I can replace my system's 2.7.9 version of the file with the patched one.

comment:38 in reply to: ↑ 36 Changed 6 years ago by john13

Replying to Robby: Problem solved with cristi's patch on pidgin (mtn)->yahoo (8.0.0.1). Great job!

comment:39 in reply to: ↑ 35 Changed 6 years ago by Blingg

Replying to cristi: Tested the patch on pidgin 2.7.9 -> Yahoo! Messenger 10.0.0.1270 and it works. Thanks cristi!

comment:40 Changed 5 years ago by Robby

Has anyone noticed any regressions with that patch? Do file transfers still work using other services than Yahoo?

comment:41 Changed 5 years ago by Blingg

I just checked file transfer on the MSN protocol with the patch applied and I managed to send and receive files without any problem. Hope this patch gets pushed in the official release so other people can benefit from it.

comment:42 in reply to: ↑ 35 ; follow-up: Changed 5 years ago by rekkanoryo

  • Milestone changed from Patches Needing Review to 2.7.11

Replying to cristi:

Patch included! :)


In order to include this patch, I need a name (and preferably an e-mail address) to credit you with. Thanks!

comment:43 in reply to: ↑ 42 Changed 5 years ago by cristi

Replying to rekkanoryo:

Replying to cristi:

Patch included! :)


In order to include this patch, I need a name (and preferably an e-mail address) to credit you with. Thanks!

Cristi Posoiu

comment:44 Changed 5 years ago by Cristi Posoiu

  • Resolution set to fixed
  • Status changed from new to closed

(In 9d51cb9fbcc04d21597eed0381f4d06c53facc44):
Fix up some cases of file transfers never finishing. This will help certain instances of Yahoo file transfers not working, but not all. Fixes #12472.

comment:45 Changed 5 years ago by rekkanoryo@…

(In 0d73552ca01af09d2e31fb19d7d65fc39b3f133d):
Credit Cristi and fix up the ChangeLog a bit for consistency. Refs #12472.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!